[Communication Drivers] Schneider Electric SA MODBUS SLAVE Driver

Summary

Last Updated : Sep. 16, 2022

Details

Caution
Precautions for adding a new driver onto Windows Vista/7
Precautions for adding a new driver at Daylight Saving Time
Title Schneider Electric SA MODBUS SLAVE Driver
Version Ver. 1.19.12
Supported Software The required versions of software for this driver installer are as follows.
GP-Pro EX Ver. 2.10.000 or later
Pro-Server EX Ver. 1.30.000 or later

You can check your version by "Help" function -> "Version Info".
Supported Devices
  • MODBUS Master Type
Supported Units Required versions depend on models.
Please check "Supported Models / Version" for the required versions of GP-Pro EX.

Required driver versions for different models are listed below
Model Required driver version
GP3000 Series Ver. 1.10.01 or later
ST3000Series Ver. 1.10.01 or later
LT3000 Series Ver. 1.16.07 or later
GP4100Series GP4104 Ver. 1.13.03 or later
GP4114 Ver. 1.18.10 or later
GP4000M Series Ver. 1.14.06 or later
GP4000 Series Ver. 1.14.07 or later
LT4000M Series Ver. 1.17.08 or later
SP5000 Series Ver. 1.18.09 or later
SP5000X Series Ver. 1.18.09 or later
ST6000 Series Ver. 1.19.10 or later
ET6000 Series Ver. 1.19.10 or later
IPC Series for WinGP Ver. 1.12.02 or later
General PCs for WinGP Ver. 1.12.02 or later
Device/PLC
Connection Manual
For details, please read the "Device/PLC Connection Manual" in the lower part of this page.
For general information regarding Device connection and documentation conventions please refer to "Device/PLC Connection Manual".
Updated Content

[Ver. 1.19.12] (Sep. 16, 2022)

The following functions were improved:
  • Improve bit write issue for Discrete device
 

How to install (This is a self-extracting file.)

Prior to installation, be sure to close all software applications that are running.
  1. Click on the file name in the lower part of this page to start downloading the file.
  2. After download is complete, double-click on the downloaded file to start installation.
  3. Follow the instructions on the screen.
  4. After installation, start GP-Pro EX.
  5. Select [Schneider Electric SA] for "Manufacturer" and [MODBUS Slave] for "Series" in [Device/PLC] settings of [System Settings] on the [Project] menu.
When using the driver, be sure to refer to the Device Connection Manual PDF.
Also, for general information regarding Device connection and documentation conventions please refer to "Device/PLC Connection Manual".

Terms of use / Cautions

Please acknowledge the following terms of use before you use our download service.
Download of any file signifies your agreement to the terms of use.
Terms and conditions

Download file

Installer :
1.05 MB (1,105,624Byte)
Last update: 2022/09/09
Device/PLC Connection Manual :
2.32 MB (2,437,428Byte)
Last update: 2022/09/12

Update History

[Ver. 1.19.12]  (Sep. 16, 2022)

The following issues was corrected:
  • Improve bit write issue for Discrete device
 

[Ver. 1.18.10]  (Feb. 19, 2016)

The following issues was corrected:
  • Improve bit write issue for Holding register
 

[Ver. 1.18.09] (Apr. 22, 2014)

The following issues was corrected:
  • Improve a wait time issue for transmit time.
 

[Ver. 1.17.08] (Dec. 17, 2012)

The following issues was corrected:
  • Improve memory leak issue.
 

[Ver. 1.17.07] 

The following setting was added:
  • Supply a user option for user to select whether use 1:1 or 1:n connection.
 

[Ver. 1.15.07]  (Feb. 24, 2012)

The following feature was improved:
  • Expand the Block write command size.
 

[Ver. 1.14.07] (Sep. 22, 2011)

Maker Name changed
 
 

[Ver. 1.13.05] (Jul. 27, 2010)

The following issues were corrected:
  • When using GP4107, occasionally no response will be returned.
  • When using n:1 connection of the ST3000 series, occasionally no response will be returned.
  • When there is communication IDLE in the communication packets, occasionally no response will be returned.
 

[Ver. 1.13.04]  (Feb. 18, 2010)

The following issue was corrected:
  • Occasionally, GP4100 is not responded.
 

[Ver. 1.13.03] 

The following setting was added:
  • Support GP4100 Series.
    * To use a GP4100 Series, Ver. 2.60.000 or later versions of GP-Pro EX are necessary
 

[Ver. 1.12.02]  (Feb. 12, 2008)

The following settings were added:
  • WinGP is supported.
  • Diagnostics command[08(0x08)] is supported(Serial Line only)
 

[Ver. 1.11.02] (Oct. 1, 2007)

The following setting was added:
  • Support for Device Monitor
    *Ver. 2.00.000 or later version of GP-Pro EX are necessary to use a Device Monitor.
 

[Ver. 1.10.02] (Feb. 5, 2007)

The following issues were corrected:
  • When n: 1 connection in RS422/485(2wire). Occasionally, GP3000 is not responded.
  • Necessary "Character timeout value" for normal operation is larger than the specification value.