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Chapter 1 — SoftScreen Overview

This chapter provides an overview of the SoftScreen® Development System
for Windows, describing important features and resources.

SoftScreen Features

The SoftScreen Development System for Windows offers a flexible, power-
ful man-machine interface development tool. Using this tool, you are able to
connect the Focal Point™ 3000 family of workstations to a variety of popu-
lar programmable logic controllers and other intelligent plant floor devices.

SoftScreen consists of a development system and a run-time engine.

The Development System

The development system is an intuitive, object-oriented tool that allows a
designer to create intelligent user interface screens to replace less flexible
hard-wired control and monitoring devices. The powerful screen layout
functions support quick and easy placement of symbols, fundamental
graphic shapes, and 256-color and monochrome bitmaps.

Minimum system requirements for the development system are
e 80486, 66 MHz CPU (Pentium 100 MHz recommended)

e 3%-inch (1.44 Mbyte) floppy disk drive

e 16 Mbytes DRAM (20 Mbytes recommended)

e SVGA graphics capability (800 x 600, set to 256-color mode or higher,
recommended)

e 15 Mbytes hard drive space
e Microsoft Windows® 95/NT Operating System

e Mouse
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Caution
We also recommend you let Windows allocate virtual memory to
guarantee system integrity.

The Run-time Engine

The run-time engine executes applications downloaded to a 3000 worksta-
tion from the development system. Its operating system supports prioritized
scanning of I/O points.

The run-time engine makes full use of the 3000 workstation’s advanced
features:

e Screen animation
¢ Downloadable programs and drivers through serial ports

e Optional analog touch screen, providing various button sizes and place-
ment options

e Interface to standard PLCs, as well as high-speed networks

e Keypad access

Resources

In addition to this user’s guide, there are two other resources to which you
can refer when you have questions: on-line help and Xycom technical sup-
port.

Using On-line Help

On-line help provides a way for you to get assistance for the development
system quickly. There are several ways to access information in the help
system:

e Click on the Index command on the Help menu or the Index button, then
locate the topic on which you would like more information.

10
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e Click on the Search for Help On command on the Help menu or the
Search for Help On button, then locate the topic on which you would
like more information.

e Press F1 while pointing to a dialog box or menu command to open the
help topic that corresponds to that dialog box or menu command.

e Press F1 anywhere in the window (but not on a dialog box or menu
command) to open the help Contents window, and then select a topic.

e Press the Help button located in most dialog boxes.

Words or phrases in the help system that appear underlined and in green will
display a help window when clicked on. Words or phrases that appear in
green with a dotted underline will display a definition when clicked on.

For more information on using the Help system, select the Using Help com-
mand on the Help menu.

Contacting Technical Support

Xycom provides technical support to its SoftScreen users. If you have a
problem and cannot find its solution in the manual or on-line help, you can
call our technical support personnel at 1-800-289-9266 ext. 450.

You can also contact our support personnel via Internet e-mail. Our e-mail
address is support@xycom.com. Leave your name and phone number if you
want to be contacted by phone.

11
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Chapter 2 — Installing SoftScreen

This chapter describes how to install and uninstall the SoftScreen for Win-
dows Development System.

Making Backup Copies

Before installing SoftScreen, you should make backup copies of the Soft-
Screen disks. Refer to your Microsoft Windows® 95 or Windows NT™ Op-
erating System documentation for information on making backup copies.

Installing the Software

Because SoftScreen is a Microsoft Windows 95/NT Operating System pro-
gram, you must install it in Windows 95/NT. If SoftScreen for Windows is
already on your system, this installation will overwrite the current files.

To install SoftScreen...
1. Start Windows 95/NT.

Technical Note

We recommend you close all Windows applications before you install
SoftScreen.

2. Double-click on the Control Panel folder, then double-click on the
Add/Remove Programs icon.

3. Click on the Install button in the Add/Remove Program Properties dia-
log box.

4. Insert SoftScreen Disk 1 in your local drive (usually drive A:).

Follow the on-screen prompts to complete the installation. There are
several installation disks which the program will prompt you to insert as
they are needed.
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As files are being copied to your hard drive, three icons will display on the
left side of your workstation screen indicating your progress.

The far left icon indicates how much of an individual file has been trans-
ferred. The middle icon indicates how much of a floppy has been trans-
ferred. The far right icon represents the amount of space occupied on the
system’s hard drive before you install the driver.

Technical Note

To end the installation process at any time, select the Cancel button in
the setup dialog boxes. A prompt will inform you that setup is not
complete. Select the Exit Setup button if you still want to exit the in-
stallation program. If you wish to continue the installation, select the
Resume button.

Once SoftScreen has been installed, a prompt will ask if you want to view
the readme.txt file. We recommend that you read this file and print it out to
refer to, as it provides important information that you will not find in the
manual or on-line help.

If you want to access the readme.txt file later, it is located in the same di-
rectory in which you have installed your SoftScreen program files. You can
also access it from the SoftScreen on-line help system.

Converting a SoftScreen Version 1.x Application to
Version 2.x

The TRNSLAT.EXE utility provided with SoftScreen Version 2.x converts a
Version 1.x application to Version 2.x. To complete this conversion, follow
the steps below:

1. Execute TRNSLAT.EXE either by double clicking on the name in the
Explorer with the left mouse button or by typing in TRNSLAT.EXE in
the Start/Run dialog box.

2. The TRNSLAT dialog box appears.
Type in or browse for the existing 1.x application where specified.

4. Type in or browse for the new application directory where specified.
The path name must be different than what you used in Step 3.

14
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Technical Note

If you used the browse feature in Step 3, your current working direc-
tory is set to that of the 1.x application. You mus¢ change to a new di-
rectory.

5. Click OK to convert the application. It is not uncommon for the conver-
sion to take up to 15 minutes, depending on the size of the version 1.x
application.

Converting Customized SoftScreen Symbols from
Version 1.x to 2.x

The SYMTRSLT.EXE utility provided with SoftScreen version 2.x converts
Version 1.x symbols to Version 2.x. To complete this conversion, follow the
steps below:

1. Execute SYMTRSLT.EXE either by double clicking on the name in the
Explorer with the left mouse button or by typing SYMTRSLT.EXE in
the Start/Run dialog box.

2. The SYMTRSLT.EXE dialog box appears.
Click OK to convert the custom symbols.

Uninstalling SoftScreen

To uninstall SoftScreen...

1. From Windows 95/NT, click the Start button. Select the Settings com-
mand, then Control Panel.

2. From the Control Panel, double-click on Add/Remove Programs.

Double-click on the SoftScreen Development System for Windows entry
in the list of removable programs on the Install/Uninstall page.

4. Select Yes in the Confirm File Deletion dialog box.

You will be notified once the uninstall has been successfully completed.
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After the uninstall, Windows leaves one file in the directory in which you
stored the SoftScreen program. To delete this file, it is recommended that
you delete the directory in which the SoftScreen program resided.

Connecting to the Target Workstation

You can download from the development system workstation to the target
workstation via RS-232C or RS-485 connections.

Connecting via RS-232C

Figures 2-1 and illustrates the 9-pin pinout to connect from a development
system PC to a Focal Point™ target workstation.

Terminate shield braid to metal
connector backshell on the end of the
cable that connects to the Xycom unit.

L RXD
L o
Do
1 1
I 1
' ! GND
!
SoftScreen Development 3000
System PC Target Workstation

Figure 2-1. 9-pin RS-232C Interface from Development System to Target Workstation

Connecting via RS-485 Multidrop

Use a Belden 8302, maximum length 4000 feet, when connecting to the
RS-485 port of the run-time engine. Pinouts are shown in Figure 2-2.
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TXD- (;,1\

TXD- RXD- N
RXD- XD+ || o5
X0+ [ RXD+

RXD+ | 3 SLAVE

MASTER

TXD-

RXD-
TXD+
RXD+

SLAVE

TXD-

RXD-
TXD+
RXD+

SLAVE

Y
AR

up to 254 slaves ;XXDD'_

with repeaters TXD+
RXD+

SLAVE

Figure 2-2. RS-485 Multidrop Interface Pinouts

Up to 31 (254 with repeaters) run-time engines can be connected on a mul-
tidrop network to the development system workstation. This allows you to
make changes from a central location, and then download to any engine on
the RS-485 interface. Figure 2-3 depicts a sample multidrop configuration.
Termination is required on the Master and the last Slave on the network.

17



SoftScreen Development System for Windows User’s Guide

Sample Mulitidrop Configuration

STATION 1
SOFTSCREEN PORT 1 3000
DEVELOPMENT i
SYSTEM Workstation
Sample PLC Networks
STATION 2
PORT 1 3000 PORT 2 MODBUS MODBUS | MODBUS
Workstation ] SLAVE
STATION 3 -PLC-S
DATA
PORT1| 3000 | PORT2 B 1, |[HWY
. KE, KG, PLC-2
Workstation or other :l
PLC-3
STATION 4
PORT 1 3000 PORT 2 -
Workstation Mopsus MODBUS
I -
|
i .
STATION 255
PORT 1 3000
Workstation

Figure 2-3. Sample Multidrop Configuration

Contacting Technical Support

If you encounter problems when installing SoftScreen, try re-installing it. If
that does not solve the problem, call our customer support personnel at 1-
800-289-9266 ext. 450.
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You can also contact our customer support personnel via Internet e-mail.
Our e-mail address is support@xycom.com. Leave your name and phone
number if you wish to be contacted by phone.

Registering SoftScreen

SoftScreen users are registered when they order the software. However, if
you want to change the registration information, contact Xycom at 1-800-
289-9266 x344. We recommend you register as a SoftScreen user. As a reg-
istered user, you will receive technical support, as well as information on
product upgrades.
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SoftScreen is a tag-based system, in which tags are linked to data points
or internal system variables (i.e., expressions, strings, and constants).
These tags are then used to manipulate shapes through animations,
event/actions, recipes, and alarms.

Using Data Editor Forms

Tags are configured in Data Editor forms. Table 3-1 defines the buttons
available on every Data Editor form.

Table 3-1. Buttons-on Data Editor Forms

Button Definition

Add Adds the configured tag to the list box
Remove Removes the selected tags

Move Up Moves the selected tags up in the list
Move Down Moves the selected tags down in the list

Creating Tag Names

Tag names identify tags. Following are several guidelines for creating
tag names:

e Tag names must begin with a letter, and may contain up to 32 alpha-
numeric characters, underscores, or colons.

e Each tag name must be unique.

e Tag names are case sensitive, so be consistent when typing tag
names. You might want to create tag names that contain all upper
case letters or all lower case letters, but not a combination of both).
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Addressing Driver Data Points

Tag names can be defined in the following areas of an application:

Internal driver e Keyboard driver
PLC driver e Constants
Strings e Expressions
Screen names e Touch zones
Data entry shapes e Recipe names
Alarm names

The following sections define how to assign tags to internal and key-
board drivers.

Refer to your SoftScreen driver documentation for information on de-
fining tag names for specific PLC addresses.

Once you have configured device data points, you may want to duplicate
them in an application for another driver.

To duplicate device data point tags...

1.

Open the application from which you want to copy device data point
tags.

Select the Save As command on the File menu to save the applica-
tion with a new name.

In the Save Application As dialog box, type a new name in the Ap-
plication name text box, then click on the Save button.

Select Drivers from the Data drop-down list box in the Application
Navigator.

Double-click on the name of the driver from the associated list. This
opens the driver form that contains the tags you want to copy.

Select the Drivers command on the Configure menu.

In the Configure Physical Drivers dialog box, configure a driver of
the same type with a new name. Configure the port as None.

Press Add to add the new driver to the application.
Press OK to exit the Configure Physical Drivers dialog box.
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10.

11.

12.

13.

14.

15.

16.

17.

18.
19.

Select Drivers from the Data drop-down list box in the Application
Navigator.

Double-click on the name of the new driver from the associated list.
This opens the driver form to which you will copy the tags.

With both driver forms open, duplicate each of the tags in the old
driver form in the new driver form.

After you duplicate a tag in the new driver form, delete it in the old
driver form.

Click the Add button in the new driver form to add the tag once it
has been deleted in the old driver form.

When you have finished duplicating the tags, select the Drivers
command on the Configure menu.

Highlight the old driver name in the Configure Physical Drivers
dialog box, and then click on Remove. This deletes the old driver.

Highlight the new driver name-in the Driver Names list box, and
then select a port.

Click the Add button to add the new port configuration to the driver.

Select the Save Application button to save changes to the applica-
tion.

Using the Internal Driver

Every 3000 engine incorporates an internal driver. The internal driver
accesses the system clock, system-generated and system performance
variables, and internal registers.

To assign tag names...

1.

Select Drivers from the Data drop-down list box on the Application
Navigator form.

Double-click on the Internal entry in the list box to access the Inter-
nal Driver form, as shown in Figure 3-1.
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3-4

e

Figure 3-1. Internal Driver Form

Table 3-2 defines the fields in the Internal Driver form.

Table 3-2. Fields in the Internal Driver Form

Field

Definition

Tag Name

Defines the tag to be addressed.

Internal Address

Specifies the internal address to which the tag
will be linked (see valid address ranges in ta-
bles 3 through 5).

Global

Guarantees that the data point retains its value
even if it is not used by the current screen.

String Access

Allows string access when checked. This field
is available only when specifying register ad-
dress types. When this option is selected, you
must provide a string length, from 1 to 128
characters.

3. Click Add to add the tag to the list box.
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Once specified, internal driver tags can be used in animations,
event/actions, recipes, and alarms.

Addressing Valid Data Points

This section defines valid addresses for the internal driver. There are
four types of internal addresses:

e Register * System-generated variables

e System clock * System-performance variables

Technical Note

Registers and the contrast adjustment are read/write. Registers also
support strings. System variables are read only.

Internal Register Addresses

Internal registers can be used in any value or conditional expression. To
address a register, type the # sign, and then a value (from 1 to 9999) in
the Internal Address field. For example, if you wanted to address regis-
ter 30, you would type #30 in the Internal Address field.

Technical Note

The state of an internal register is not retained on power down.

System Clock Addresses

System clock addresses provide information on system date and time.
You can display this information by configuring a data display shape.

Table 3-3 defines the system clock addresses and ranges supported.
Table 3-3. System Clock Variables

System Clock | RIW Return Value Range
Hour R/W 0-23
Minute R/W 0-59
Second R/W 0-59
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System Clock

Return Value Range

Month

1-12

Day

1-31

Year

0-99

Day of Week

0-6: 0=Sunday, 1=Monday, etc.

SysTime

Returns the system time. This num-
ber is updated approximately every
quarter second. Note: Use data display
shapes to view the system time during
run-time. Refer to Chapter 5 for more
information on data display shapes.

SysDate

Returns the system date. This num-
ber is updated approximately every
quarter second. Note: Use data display
shapes to view the system date during
run-time. Refer to Chapter 5 for more
information on data display shapes.

Testing and Debugging Variables

Testing and debugging variables can be used to test and debug your ap-
plication before placing it into a production environment. These are
most frequently used to test animations, alarms, and event/actions.

Table 3-4 defines the system-generated variable addresses and ranges
supported by the internal driver.

Table 3-4. Testing and Debugging Variables

Variable

R/W

Return Value Range

Random

R

Returns a random number from 0.0 to
<1.0 approximately every quarter sec-
ond

RampUp

Cycles from 0.0 to 1.0 approximately
every eight seconds in .03125 incre-
ments

RampDown

Cycles from 1.0 to 0.0 approximately
every eight seconds in .03125 incre-
ments
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Variable R/W | Return Value Range

RampUpDown R Cycles from 0.0 to 1.0 to 0.0 approxi-
mately every 16 seconds in .03125 in-
crements

OscSin R Cycles from -1.0 to 1.0 (Sine values)
approximately every nine seconds in 9°
increments

OscCos R Cycles from -1.0 to 1.0 (Cosine values)
approximately every nine seconds in 9°
increments

System Performance Variables

You can address system-performance variables, allowing you to check
the performance of your system.

Table 3-5 defines the system performance variable addresses and ranges
supported by the internal driver.

Table 3-5. System Performance Variables

System Performance R/W | Return Value
Variable
RenderCYC R Returns the Render cycle time ( in

msecs), which indicates how long
it takes to draw the current
screen. This number is updated
approximately every quarter sec-
ond.

EvalCYC R Returns the evaluate cycle time
(in msecs), which indicates how
long it takes to evaluate all the
expressions in the current screen
and the Graphic Editor. This
number is updated approximately
every quarter second.

27



SoftScreen Development System for Windows User’s Guide

System Performance
Variable

Return Value

ActionCYC

Returns the service cycle time (in
msecs), which indicates how long
it takes to perform event/actions
in the current screen and the
Graphic Editor. This number is
updated approximately every
quarter second.

Contrast

Adjusts system contrast. To
change the contrast, you must
write a positive or negative con-
stant to this address. This con-
stant is relative, not absolute, and
indicates the amount the current
contrast setting will be altered by,
not what it is set to. For example,
if you write a +3 to this address,
and the current contrast setting is
10, the contrast will be altered by
3, to 13. The contrast setting
range is -128 to +127. So if you
write a +3, and the current con-
trast setting is +127, the contrast
will not change.

Note: On 3200 and 3300 target
workstations with monochrome
flat panel displays, contrast is
automatically adjusted every 10
minutes, based on the tempera-
ture. On the 3100 target worksta-
tion with monochrome or touch
screen flat panel display, contrast
is updated only at boot-up. You
should add contrast controls to
the application so you can update
your screen contrast while the
application is running.
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Using the Keyboard Driver

Every 3000 engine incorporates a keyboard driver. This driver allows
you to create tags that address keyboard and keypad keys.

For example, you can create a tag named Color that addresses the F1
key. You can then use the Color tag to animate a shape’s color when F1
is pressed.

Also, if you relegend the function keys on your workstation’s keypad,
you can use the keyboard driver to rename the function keys internally
to reflect these new legends. This will make it easier to assign and track
these keys.

To assign a tag to the keyboard driver...

1. Select Drivers from the Data drop-down list box on the Application
Navigator form.

2. Double-click on the Keyboard entry in the list box to access the
Keyboard Driver form, as shown in Figure 3-2.

Da Editor: test2 ( eram]mmmw
S

.

Figure 3-2. Keyboard Driver Form

Table 3-6 defines the fields in the Keyboard Driver form.
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Table 3-6. Fields in Keyboard Driver Form

Field Definition

Tag Name | Assigns the tag name

Key Specifies the key that the tag will address. You can
select any key from the drop-down list.

For example, if you relegend the F1 key on the workstation keypad
to “START,” you can configure the F1 key as illustrated in
Figure 3-3.

Figure 3-3. Keyboard Driver Example

3-10
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Technical Note

Keys configured in this form will only reflect the current state of
the key. For example, a tag tied to F1 will evaluate to 1 while the
key is pressed and 0 while the key is not pressed. To detect
changes in the state of keys, use key press and key release
event/actions. Refer to Chapter 11 for information on
event/actions.

Also, data for keys is invalid on the run-time engine until each key
has been pressed once.

3. Click Add to add the tag to the application.

This tag name can now be used in animations, recipes, and alarms.

Configuring Internal System Variables

In SoftScreen, you are able to configure tags that address internal system
variables, which consist of constants, strings, and expressions.

Creating Constant Tags
In the Constants form, you are able to link numbers and arrays of num-
bers to tags. These tags can then be used in expressions.
To configure a constant tag...

1. Select Application from the Data drop-down list box on the Appli-
cation Navigator form.

2. Double-click on the Constants entry in the list box to access the
Constants form, as shown in Figure 3-4.

3-11
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{ lnls )

Figure 3-4. Constants Form

Table 3-7 defines the fields in the Constants form.
Table 3-7. Fields in Constants Form

Field Definition

Tag Name | Assigns the tag name

Constant Specifies the constant or constants that the tag will
address. You can enter these values in exponential
notation.

For example, you can configure a tag that addresses a single con-
stant or you can configure one that indexes an array of constants, as

shown in Figure 3-5.
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Dala Eﬁltop}ulecﬂ { E;ﬁnst’amnls ]M

Figure 3-5. Constant Example

In the Constants List box in Figure 3-5, the first number is the index
(0, 1, and 2), and the second number is the assigned value (for ex-
ample, 1000).

Technical Note

Each time you add a new value to a tag, the index automatically
increments.

3. Click Add to add the tag to the list box.

You can now use this tag in expressions. Refer to the Creating Expres-
sion Tags section later in this chapter for information on using constant
tags in expressions.

Creating String Tags

In the Strings form, you can configure a tag to address a string or an ar-
ray of strings. Strings created in the Strings form are constants that can-
not be changed by the run-time engine. These tags can then be used in
expressions.
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To configure a string tag...

1. Select Application from the Data drop-down list box on the Appli-
cation Navigator form.

2. Double-click on the Strings entry in the list box to access the Strings
form, as shown in Figure 3-6.

Data Editor: PloicH { Slring]

Figure 3-6. Strings Form

Use the fields in this form to create tags that address string con-
stants. Table 3-8 defines these fields.
Table 3-8. Fields in Strings Form
Field Definition
Tag Name | Assigns the tag name

String Specifies the string or strings that the tag will
address. Strings can be up to 254 characters.
Note: Some drivers only support 128 characters, so a
string that contains more than 128 characters may be
truncated.

In the example in Figure 3-7, the tag Message is configured as an ar-
ray of strings, which can then be indexed in an expression.
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Turn machine on.
Hold for parts.
Close door.
Restart machine.

Figure 3-7. String Example

In the Strings List box in Figure 3-7, the first number is the index (0,
1, 2, and 3), and the second part is the assigned message (for exam-
ple, Turn machine on).

Technical Note

Each time you add a new string to a tag, the index automatically
increments.

3. Click Add to add the tag to the list box.

You can now use this tag in expressions. Refer to the Creating Expres-
sion Tags section for information on using string tags in expressions.

Creating Expression Tags

Expressions consist of one or more operators, operands, and/or tags.

To configure an expression...

1. Select Application from the Data drop-down list box on the Appli-
cation Navigator form.
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2. Double-click on the Expressions entry in the list box to access the
Expressions form, as shown in Figure 3-8.

Data E ditor- Projectl1 [ Expressions )

Figure 3-8. Expressions Form

Use the fields in this form to create tags that address expressions.
Table 3-9 defines these fields.

Table 3-9. Fields in Expressions Form

Field

Definition

Tag Name

Assigns the tag name

Data Type

Sets the data type of the expression to float or string.
The default is float.

Length

Sets the length of the expression in bytes to 4 if float is
the data type, and from 1 to 254 if string is the data type

Scan Rate

Sets how often the run-time engine will read the data
point, from ASAP to once every eight hours. The default
is ASAP.

Expression

Specifies the expression that the tag will address.
Expressions can incorporate tags that address strings,
constants, and keyboard, internal, and PLC data points,
as well as operators and operands. Expression strings
can be up to 254 characters. Note: Some drivers only
support 128 characters, so a string that contains more
than 128 characters may be truncated.

Table 3-10 defines valid numeric operators.

3-16

36




Chapter 3 — Configuring Tags

Table 3-10. Valid Numeric Operators

Operator Description Precedence* Result of Evaluation
! Logical negation 1 True or false
* Multiplication 2 Value

/ Division 2 Value

% Modulus (remainder) 2 Value

+ Addition 3 Value

- Subtraction 3 Value

<< Left shift 4 Value

>> Right shift 4 Value

== Equality comparison 5 True or false
1= Inequality 5 True or false
< Less than 6 True or false
> Greater than 6 True or false
<= Less than or equal to 6 True or false
>= Greater than or equal to 6 True or false
| Bitwise inclusive OR 7 Value

& Bitwise AND 7 Value

A Bitwise exclusive OR 7 Value

I Logical OR 8 True or false
&& Logical AND 8 True or false

* Operators at the same precedence level are evaluated from left to right.
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3-18

Table 3-11 defines valid string operators.
Table 3-11. Valid String Operators

Operator | Description Precedence* Result of
Evaluation

! Logical negation 1 True or false
+ Addition 2 String

<< Left shift 3 String

>> Right shift 3 String

== Equality comparison 4 True or false
1= Inequality 4 True or false
< Less than 5 True or false
> Greater than 5 True or false
<= Less than or equal to 5 True or false
>= Greater than or equal to 5 True or false
Il Logical OR 6 True or false
&& Logical AND 6 True or false

*Operators at the same precedence level are evaluated from left to right.

3. Click Add to add the tag to the list box.

This expression tag can now be used in animations, event/actions, reci-
pes, and alarms.

You can also use expressions to index a constant or string array.
To index a constant or a string in an expression...

1. Create a tag that addresses a constant or string array in the Constant
form or the String form. See Figure 3-7 for an example of a string
array.

2. Next, configure a tag that will return the index values of the constant
or string, to be used in the expression. For example, you might cre-
ate the tag “INDEX” in the internal driver form to address the run-
time engine’s seconds register.

3. Select Application from the Data drop-down list box on the Appli-
cation Navigator form.
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4. Double-click on the Expressions entry in the list box to access the
Expressions form, as shown in Figure 3-9.

. Data Editor: Project] [ Expressions )

Figure 3-9. Expression Indexing Example

5. Type a name in the Tag Name text box. In this example, type
“EXAMPLE.”

6. Type an expression in the Expression text box. For example, if you
used the string tag created in Figure 3-7 and the internal driver tag
created in Step 2, you would type the following:
“MESSAGE[INDEX]”.

7. Select String or Float as the Data Type. In this example, select
String.

8. Specify a length if you select String as the Data Type. In this exam-
ple, specify 20 as the length.

9. Set the Scan Rate. This is how often the run-time engine will scan
this tag. In this example, specify 1 minute.

10. Click Add to add the tag to the list box.

You could then configure a data display object attached to the EXAM-
PLE tag, to display the messages configured in the MESSAGE tag.
During run-time, MESSAGE 0 will display when INDEX is equal to 0,
MESSAGE 1 will display when INDEX is equal to 1, etc.

3-19
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Technical Note

If an indexed tag is used in an expression without an index refer-
ence, then the data at index 0 is used in the expression.

Evaluating Tags

There are four types of tags in SoftScreen: data point, string, constant,
and expression. Data point tags are evaluated during run-time based on
the point scan rate set in the driver form (internal and keyboard driver
data points are evaluated approximately once every quarter second).
Constant and String tags are not evaluated because they do not change.

Defining Global Tags

A PLC tag’s value is invalid when the screen it is on is first opened until
the engine gets its data. Also, when you switch to another screen, the
tag’s value is not updated, unless that same tag is on the new screen.

To guarantee that the tag’s value is up to date even if it is not used by
the current screen, it must be specified as a global tag. To do this, you
must configure it on the Master Template (because all objects and tags
on the Master Template are global) or as an alarm, because alarms are
global actions. You can also specify internal driver tags as global.

Ordering Tags

3-20

In the development system, you are able to change the order of anima-
tions (which are based on tags). You are also able to specify the order of
expression, string, constant, and data point tags within their respective
forms (for example, you can order all expression tags in the Expressions
form). However, changing the tag order does not always have an impact
during run-time.

For instance, the order of string, constant, internal driver, and keyboard
driver tags has no effect during run-time. The Move Up and Move Down
fields in the associated forms are for your convenience only, if you want
to group certain tags.
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The order of expression tags in the Expression form can have an impact
during run-time, depending on the content of the expression.

Tag Name Type-Ahead Feature

This feature allows you to locate tag names using either the Data Editor
(screens, recipes, and alarms) or the Animation Editor. As you begin
typing in each character of a tag name, the tag name edit box is filled
with the closest match to the defined tag name.

Expressions — Forward and Circular Referencing

Note

Forward and circular references are not allowed in expressions.

During runtime execution, expressions are evaluated in the order they
appear in the expression data form list box. A tag name that appears on
the right-hand side of an expression, may not be used on the left-hand
side of the current or following expression examples, listed in

Table 3-12.
Table 3-12. Expression Examples
Expression Errors Definition
y=y+1 Wrong. y is used on the right and left-hand side of the cur-
rent expression (circular reference).
y=x+1 Wrong. X is used on the right-hand side of the first ex-
X=2z pression and is used on the left-hand side of the second
expression (forward reference).
Correct Expression Definition
Usage
y=25 Correct. y is defined in the first expression and then used
X=y*3 in the second expression.

Expression errors will be found when generating an application.

3-21
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Locating Tags with the Tag Browser

The Tag Browser, located in the Tools menu, is a convenient way to
quickly search for tag names. This tool provides an alphabetical, on-
screen display of all defined and referenced tag names.

The Tag Browser form is shown in Figure 3-10.

Figure 3-10. Tag Browser Form

Drag and Drop Tag Names

The drag and drop method allows you to drag a tag name, from the
graphical display of the Tag Browser, to any place in the Data Editor
(including animations) that a tag is used (not defined).

Copying Tags
To copy tags used in SoftScreen from one field to another perform the

following steps:
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1. Using your mouse, double-click to highlight the tag name.

2. Press the right mouse button to access a pop-up menu. Select Copy
(this menu offers shortcuts to the cut, copy, paste, delete and undo
commands).

3. Go to your destination and select the Paste command.

Cross Reference Tool for Tag Names

The Cross Reference tool allows you to generate reports containing in-
formation on where tag names are used and where they are defined. Se-
lect either Tag Names Used or Tag Names Defined to generate a report.
More than one report may be generated without closing the first one.

Figure 3-11 shows the Cross Reference Configuration dialog box that
displays when you select the Cross Reference command on the Tools
menu.

Cross Reference Configuration

Figure 3-11. Cross Reference Configuration Dialog Box

Tag Names Used Option

Clicking on Tag Names Used in the Cross Reference Configuration dia-
log box brings up the Referenced Tag Names form (Figure 3-12). This
form lets you generate a report that lists where tags are defined and used.
The report may also contain undefined and duplicate tags (if you used
the same tag name in more than one place). Click on the column headers
to sort the distribution by that column, in descending order.
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" UNDEFINED  EXAMPLE

Strings EXAMPLE
o A Line Width Ani

Figure 3-12. Referenced Tag Names form

Table 3-13 defines the fields in the Referenced Tag Names form.
Table 3-13. Fields in Referenced Tag Names Form
Field Definition
Tag Name Referenced | Tag name displays in this column

Defined In Specifies where the tag is located

Used In Displays where the tag is used; in an animation, event,
action, or expression

Object Specifies the shape (if the tag is used in an animation)

In " | Specifies if the tag is in a screen, recipe, or alarm

Tag Names Defined Option

Click on the Tag Names Defined in the Cross Reference Configuration
dialog box to bring up the Defined Tag Names form (Figure 3-13). This
form generates a report of all defined tag names in your application.
Click on the column headers to sort the distribution by that column, in
descending order.
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Strings
Intermal
Internal
Internal
Internal
Internal
Constants
Constants
Constants

Figure 3-13. Defined Tag Names Form

Table 3-14 defines the fields in the Defined Tag Names form.
Table 3-14. Fields in Defined Tag Names Form

Field

Definition

Tag Name

Displays the tag name

Defined In

Specifies where the tag is defined

Tag Name Filter Option

Use this option to search for specific tags. This text box accepts the wild
card characters * and ?, where * is used For example, if you want to
search for undefined tags that begin with “N,” you would select the Tag
Names Used option and type N* in the Tag Name Filter text box. The
Referenced Tag Names form will open, displaying all tags (if there are
any) beginning with “N.”
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Chapter 4 — Getting Started

This chapter walks you step by step through creating a SoftScreen applica-
tion, from opening the software and naming an application, to generating
and downloading it to the run-time engine.

The example application demonstrates the basic steps to create and save an
application. Also, advanced animation functions will be defined to help you
create powerful screens quickly. This application is saved in the directory
you store SoftScreen program files.

Technical Note

This tutorial was designed to run on a 3100 workstation.

Helpful Hints

This section provides hints to help as you create your application:
e Remember that tag names are case sensitive.

e Use the Minimize and Maximize buttons located in the top-right corner
of all windows and forms to manage your desktop as you are creating
your application. Often times, you will have to switch between windows
and forms. Using the Minimize and Maximize buttons will save you
time, while also keeping unused windows and forms out of your way.

e Use your right mouse button to quickly cut, copy, paste, or delete text in
text boxes in SoftScreen. Just highlight the text you want to cut, copy or
delete, and, while your cursor is in the field you want to edit, press the
right mouse button. To paste cut or copied text, place your cursor in the
field you want to paste it to, then press the right mouse button and select
Paste. To undo a cut, copy, or paste command, press the right mouse
button, and select Undo.

4-1
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Creating the Application

This section describes how to begin by creating an application.

1. Open SoftScreen by clicking on the Windows 95/NT Start button, se-
lecting Programs from the menu, and clicking on the SoftScreen Devel-
opment System for Windows icon.

The Select New Target Workstation dialog box opens, as shown in
Figure 4-1.

Figure 4-1. Select New Target Workstation dialog box

Because applications are target specific, you must select the target work-
station for which you are configuring your application.

The development system specifies a 3100 unit as the default target
workstation.

2. From the Target: Family drop-down list, select the family of worksta-
tions for which you are creating your application: 3100, 3200, or 3300.

3. Select the Touch Screen Present option if the target workstation has a
touch screen. This option is selectable for 3100 and 3200 workstations.
It is automatically selected for 3300 workstations, as they come
equipped with touch screens.
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Technical Note
If the target workstation has a touch screen and you do not specify a
touch screen model on the development system, you cannot configure
touch zones for your application.

4. Click OK once you have specified the target workstation. SoftScreen
opens, with the Application Navigator form displayed, as shown in
Figure 4-2. :

;ﬁ(plialio Na;'ig: ic! ]

Figure 4-2. Application Navigator Form

This form provides a quick and easy way of creating applications and
configuring the drivers, screens, alarms, recipes, event/actions, and data
associated with them.

There are two types of information associated with every application:
graphic and data. The Graphic Editor tool is used to create graphic ele-
ments for your application; the Data Editor tool is used to associate data
with your application, tags, alarms, recipes, function keys, and touch
zone definitions. When a screen is created, a corresponding data editor
entry is created.
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5. Select the Open command from the File menu to access the Open Appli-

cation dialog box.

Select the Shellapp folder from the Softwin folder, then double-click on
the Shellapp.ssw file. This opens the Shell application. This application
provides a framework for creating a new application. You can use it to
get started quickly.

Select the Save As command on the File menu. The Save Application As
dialog box opens, as shown in Figure 4-3. These steps will save Shellapp
as a new application.

Save Application As

Tutorial
£3 sample Tutorial.ssw
&1 shellapp
&3 SoftDev
SwPersis
SymbolDB
£ TargetFiles

Figure 4-3. Save Application As Dialog Box

8. Select the drive on which you want to save the application from the Save

in drop-down list box, if it is not already selected.

9. Double-click on the folder in which you want to save the application, if

it is not already selected.

10. Type “Tutorial” in the Application name text box.
11. Click the Save button. SoftScreen creates a Tutorial folder in which the

Tutorial application is stored. Its new name appears in the Application
Navigator title bar.

After you have saved the application, selecting the Save Application
command automatically saves changes to “Tutorial.”
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Configuring the Master Template

This section describes how to configure a Master Template. Shapes placed
on this screen display as a background on every screen during run-time.

If you want to view shapes placed on the Master Template on all
screens on the development system, choose the Set Visibility com-
mand on the View menu when the Graphic Editor is active and the
Master Template screen is not being edited. Then select the Show
Master Template Shapes option. The shapes are shown on all screens
to help position other shapes; however, you can only edit them on the
Master Template.

Technical Note

1.

On the Application Navigator form, select Screens from the Graphic
drop-down list box, and then double-click on the Master Template entry.
Maximize the window if necessary.

Select the Insert Bitmap command on the Edit menu.

Double-click on Xycom.bmp in the Softwin directory. It is placed in the
top left-hand corner of your screen, as shown in Figure 4-4. If you have
a small bitmap (approximately 100 x 50) of your company logo, select it

now.
l Xycom

Main ||6raph ||Run iag set |ilarm
Menu ||Scrn |[{Scrn Scrn Up Log

Figure 4-4. Master_Template Screen with “Xycom Logo”
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© 0 N o

10.

11.

This “logo,” as well as the rest of the objects on the Master Template,
will display on every screen in your tutorial application during run-time.
All other screens will “overlay” the Master Template. Which means ob-
jects placed in the same location as the “logo” or the function keys will
be placed on “top” of the logo or function keys.

Double-click on the function key text you want to change. For instance,
if you want to change “Graph” to “Fault,” double-click on “Graph.” This
accesses the Shape Properties form.

Click on the Text tab to access the Text properties page, as shown in
Figure 4-5.

Shape Properties

Figure 4-5. Text Properties Page

Highlight “Graph” in the Text box, and type “Fault.”
Click OK or press ENTER when you have finished making changes.
Repeat steps 4 through 7 for each function key label you want to change.

In the Application Navigator there are event/actions assigned to function
keys F11-F16, which are the six function keys located on the bottom of
the 3100 front panel. To view these event/actions, select the Data Editor
button on the Tool bar or select Data Editor command from the Tools
menu.

Select Screens from the Type drop-down list box, then double-click on
the Master Template entry in the Name list box.

Click on the first event/action to view which data is defined.
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The first six event/actions listed in the Event/Actions list box are con-
figured for function keys F11-F16.

Technical Note

If you change the screen names associated with these event/actions,
you must also change the names of the screens. Or, if you change the
screen names, you must change the screens to which the event/actions
are attached.

12. Close the Event/Actions form and the Master Template Graphic Editor

by clicking the Close button in the top-right corner of each window.

Inserting Symbols

This section describes how to insert symbols on a screen.

1.

3.

From the Application Navigator form, double-click on the Main_ Menu
entry in the Graphic list box.

Select the Insert symbol button from the tool bar or the Insert Symbol
command on the Symbol menu to access the Insert Symbol dialog box.

Click on the ISA Symbol Library tab then click on the
_horz_valve_w_man_act symbol. Note that a preview of the symbol ap-
pears in the Preview window and a description displays in the Descrip-
tion box, as shown in Figure 4-6.
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4-8

Insert Symbol

cyclone_separator
_distillation_tower

Figure 4-6. Insert Symbol Dialog Box

Click OK or press enter to insert the symbol on the Main Menu screen.

To reposition the symbol, position the cursor on it, click and hold the
mouse button, and drag it to the center of the screen. Then release the
mouse button. See Figure 4-8.

Repeat steps 2 through 4, inserting the _pressure_storage_vessel and the
_pump symbols.

To reposition the pump/vessel, position the cursor on it, click and hold
the mouse button, and drag it to the right/left side of the screen. Then
release the mouse button. See Figure 4-8.

To align the pump and the vessel, select both shapes by drawing a box
around them, and then select the Align button from the toolbar or select
the Align command from the Arrange menu. The Align dialog box
opens, as shown in Figure 4-7.
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Figure 4-7. Align Dialog Box

9. Click on the Bottom radio button under Y Alignment, and click OK. The

two symbols are aligned by the bottom of the shapes outline box.

Technical Note

Be aware of where you place the symbols, so they do not overlap the
shapes placed on the Master Template.

To connect symbols using polylines ...

10. Click on the Polyline button in the Drawing Palette, located to the right

of the drawing area.

11. To connect the three symbols, as shown in Figure 4-8, click on a starting

point (either the top or bottom of a symbol) and drag the mouse to the
first point the line will change direction and click to set the point.

[ Screen Editor: Tutorial { Main_Menu )

Figure 4-8. Symbols Connected by a Line
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12. Continue drawing the line and setting change points where required. To

complete a line, double-click on the end point.

To change symbol properties...

16. To change symbol properties, double-click on the symbol you want to

change. This accesses the Shape Properties form, as shown in
Figure 4-9.

Figure 4-9. Shape Properties Form

Technical Note

4-10

The symbol is comprised of several shapes that have been grouped.
Since no properties have been defined for the group, the fields in this
form are empty. To change properties of individual shapes within a
symbol, ungroup the symbol and then select the shapes whose proper-
ties you want to change. Remember to regroup when finished.

In this form, you can access style properties (line color, type, and width,

and fill pattern, foreground color, and background color) and general
properties (internal name and description).

2. Select Width 3 to match the symbols line width, then click OK.

When you have finished changing style properties, click OK or press
ENTER.

4. Click on the Close button on the top-right corner of the Main_Menu

screen to close it.
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Configuring Tags

SoftScreen uses tags to attach values to shapes and objects. Tag names are

defined in device drivers, internal driver, touch zones, keyboard driver, ex-
pressions, constants, and strings. Tag names are used by shape animations,
event/actions, recipes, alarms, screen name, alarm name, recipe name, and
object name.

This section describes how to assign tags to the internal driver. Refer to
Chapter 3 or the specific driver manual for information on assigning tags in
other instances.

This section also builds a screen with a pilot light that is controlled by the
state of the F1 key. The screen will include an analog meter to display the
value of a tag.

1. From the Application Navigator form, double-click on the Run_ Scrn
entry in the Graphic list box.

2. Select the Insert Symbol button on the toolbar or select the Insert Sym-
bol command on the Symbol menu.

3. Click on the Indicators tab to access the Indicator symbol page.

4. Select the pilot_light red symbol, as shown in Figure 4-10.

4-11
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Insert Symbol

_pilot_light_blue
light

pilat ikt red
_pilot_light_red_green
_pilot_light_yellow

Figure 4-10. Preview of Pilot Light Symbol

5. Press ENTER to insert the symbol on the screen.
6. The Resolve Tag Names dialog box appears, as shown in Figure 4-11.

412
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10.

11.
12.
13.

Figure 4-11. Resolve Tag Names Dialog Box

This dialog box allows you to rename unresolved tags assigned to a
symbol. Unresolved tags are tags that reference a device data point.
Since device data points are not saved along with the symbol, these tags
are unresolved and need to be renamed.

In this example, you are going to rename the tag On_State.

Highlight the On_State tag in the New text box, and type “Pilot1” (this
name is case sensitive).

Click OK or press ENTER.

From the Application Navigator, select the Data Editor button on the
tool bar or select the Data Editor command from the Tools menu to ac-
cess the Select Data Form dialog box.

Select Drivers as the Type. Then double-click on the Internal driver in
the Name box.

Type “Pilotl” in the Tag Name text box.
Leave the Internal Address as #30, which addresses internal register #30.

Click the Add button to add the tag to the Name list box, as shown in
Figure 4-12.

413
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Data Editor: Projectl [ Internal )

e

Figure 4-12. Internal Driver Form
14. Minimize the Data Editor with the windows icon.
15. To return to the Run_Scrn, maximize the Screen Editor window.

16. Select the Insert Symbol button on the toolbar or select the Insert Sym-
bol command on the Symbol menu to access the Insert Symbol dialog
box.

17. Click on the Meters group tab.
18. Select the _analog_meter 0_to_1 symbol, as shown in Figure 4-13.

4-14
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19.
20.

21.
22.

23.

24.
25.
26.
27.

r {1 to ]
_analog_meter_0_to_10
_analog_meter_0_to_100

Figure 4-13. Preview of Analog Meter

Click OK to insert the symbol on the screen.

In the Resolve Tag Names dialog box, highlight the Needle_Value tag in
the New text box, and type “Meterl.” Remember that this name is case
sensitive.

Click OK.

Click on the analog meter symbol, drag it to the right of the pilot light,
and then release the mouse button.

Return to the Data Editor window. Minimize the screen editor, and then
maximize the Data Editor. (Alternate method is to select the Window
menu and then select Tile Vertical to display all open windows).

Type “Meterl” in the Tag Name text box.

Select RampUpDown from the Internal Address drop-down list box.
Click Add to add the tag to the list box.

Close the Data Editor.
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28. Select the Save Application command on the File menu to save changes

to the application.

Adding Text to a Meter

1.

SR

~

Return to the Run_Scm Editor.

Select the Text button T from the Drawing Palette or select the Text

Box command from the Shapes menu.
Draw a box in the bottom of the meter.
Inside the text box, type in “Meterl.”
Select the Style tab.

Set the foreground color to Black #0 and the background color to Cyan
#9.

Click OK."

Select the selection tool from the drawing palette and resize the width of
the text box as necessary.

Close the Graphic Editor.

Assigning Event/Actions

This section describes how to assign event/actions for a screen.

4-16
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Keypad Configuration

1. Open the Data Editor

2. Select Screens as the Type, and Run_Scm as the Name.

3. Click OK or press ENTER.

4. Configure keypad event/actions, as described in Table 4-1.

Table 4-1. Configuring Key Press/Release Event/Actions
Event Key | Tag name Action Tag name Tag name
(Destination) | (Source)

Key press F1 N/A Assignment Pilot1 One
Key release | F1 N/A Assignment Pilot1 Zero

*QOne and Zero are constants to change the state of Pilotl

5.

v 0 N %

Open the Tag Browser (shown in Figure 4-14) located on the Tools

menu.

Drag and drop Pilotl into Tag name (Destination) or type in Pilotl

Drag and drop One into Tag name (Source) or type in One.
Click the Add button
Repeat Steps 1 through 9 for Key release.
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&l agBrowser

Screens
Recipes

{ Data Points
Touch Zones

Figure 4-14. Tag Browser

Touch Zone Configuration (Optional)

1. Select the Touch Zone button on the Drawing Palette.

2. Click the cursor in the top left corner of the pilot light and drag the touch
zone until it is the same size as the pilot light. Then release the mouse
button. The touch zone now covers the pilot light, as shown in Figure

4-15.

4-18
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N I R

Figure 4-15. Touch Zone Example

Click on the Selection tool on the Drawing Palette, then double-click on
the Touch Zone. '

Click on the General tab to access the General properties page.

Change the name of the object to Pilot_TZ.

Highlight the “Pilot_TZ” text, and then press the right mouse button.
Select Copy. Windows copies the text, so you can paste it in other fields.
Press ENTER to return to the screen. This name identifies the touch zone.

Configure two touch zone event/actions, as described in Table 4-2.
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Table 4-2. Configuring Touch Zone Event/Action

Event Key Tag name Action Tag name Tag name
(Destination) | (Source)

Touch zone | N/A Pilot_TZ (use Assignment Pilot1 One
press right mouse but-

ton to paste text

copied in Step 8)
Touch zone | N/A Pilot_TZ (use Assignment Pilot1 Zero
release right mouse but-

ton to paste text

copied in Step 8)

*QOne and Zero are constants to change the state of Pilotl

10. Click on the Close button in the top-right corner of the Event/Action
form to close it.

11. Select the Save Application button on the toolbar or select the Save Ap-
plication command on the File menu to save changes to the application.

Generating the Application

4-20

You must generate the application before you can download it to the run-
time engine. Generating allows SoftScreen to compile the application into a
form the run-time engine can understand. If the application contains unde-
fined tags, they will be found during generate.

To generate the application...

1. Select the Generate command on the Tools menu or click the Generate
button.
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Technical Note

You will get an error message if you have not specified a startup
screen in the Application Navigator. Specify a startup screen, and then
regenerate.

2. If there are unresolved references in the application, a message states
this. Unresolved references refer to undefined tags, and forward and cir-
cular references. You cannot download an application until you have
corrected all unresolved references.

3. Click OK and the Generate window will display.

4. To print the listing in the Generate window, select the Print command on
the File menu or press the Print button.

5. Select Cross Reference from the Tools menu to obtain a listing of unde-
fined tags.

6. Choose the Tag Names Listed 6ption and a list of all tags used in your
application appears in the Referenced Tag Names form, as shown in
Figure 4-16.

] A Rotate Animation APoly... Screen: Screenl
{5 one Constants A Line Width Animation AGrou.. Screen: Screenl

SR

Figure 4-16. Referenced Tag Names Form
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Table 4-3 defines the fields in the Referenced Tag Names form.
Table 4-3. Fields in the Referenced Tag Names Form

Field

Definition

Tag Name Referenced | Displays the tag name

Defined In Specifies where the tag is defined or undefined
Used In Indicates where the tag is used: in an animation, event, action, or
expression
Object Specifies the shape (if the tag is used in an animation)
In Specifies if the tag is in a screen, recipe, or alarm

7. Locate the undefined tags. Undefined tags must be defined in the Data
Editor in one of six places:
o PLC driver
+ Internal driver
» Keyboard driver
o Constants
« Expressions
o Strings

8. Once all unresolved references are resolved, generate the application
again.
You may receive a message that states that “Possible memory problems
were detected.” This message indicates one of two things:
« Flash usage by the application is greater than or equal to the Flash

available for the application or
« RAM usage by the application is greater than or equal to the RAM
available for the application

9. Click OK, and the Successful Generation message displays.

10. Click OK again. The Memory Analysis window displays, as shown in
Figure 4-17.
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4(, Pm,cl‘IZ ————————————————————————————————— ]

| —— Vorkstation memory analysis --——
{Total flash: 1024K

{Flash available for application: 485K
{Flash usage by application: 1K

Master Template: 1K
Largest screen: Screenl 1K
{No recipes
No PrintScreens

Please refer to your user's manual for information
jon how to use these estimates.

Figure 4-17. Memory Analysis Window
To determine where the memory problem is, compare the Flash usage by

the application to the Flash available for the application and RAM usage
by the application and the RAM available for the application.

Once you determine the problem, make changes to the application to
correct it. For more information on the memory analysis tool, refer to
Chapter 13.

11. Once all problems have been corrected, regenerate the application. You
will receive a Successful Generation message. Click OK.

You are now ready to download the application. If you have not done so al-
ready, connect the development system to the target workstation. Refer to
Chapter 2 for cabling information.

Downloading the Application

Once you have successfully generated the application, you are ready to
download it to the run-time engine.

If you have not done so already, refer to Chapter 2 for instructions on how to
connect the development system workstation to the target workstation.
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Technical Note

You may want to password protect the screen that uses “Prepare for
Download” action.

1. Click the Download button from the toolbar or select the Download
command on the Tools menu to access the File Download dialog box, as
shown in Figure 4-18. The factory defaults should work with all new
units and demo units.

File Download

Figure 4-18. File Download Dialog Bo

2. Select the Workstation Address button if you need to change the target
workstation address or verify the link between a target workstation and
the development system workstation. This opens the Target Workstation
Address dialog box, as shown in Figure 4-19.

4-24
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arget Workstation Address

Figure 4-19. Target Workstation Address Dialog Box

If you receive an error that says the COM port you have selected cannot
be opened, it may be because

o The port is in use
e Another copy of Download is open, causing a conflict

If you resolve these problems and still receive an error, close and re-
open the File Download dialog box.

3. Select Point to Point to connect to one target workstation. Refer to
Chapter 12 if you want to connect to more than one target workstation.

4. Click on the Configure Download Port button to open the Configure
Download Port dialog box, as shown in Figure 4-20.

Figure 4-20. Configure Download Port Dialog Box

5. Select a Download Port. Choices are COM 1, COM 2, COM 3, or COM
4. The default is COM 1.
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6. Select a baud rate.

Technical Note

Some PCs may have problems communicating at baud rates higher
than 9600. If you have trouble downloading an application, select a
slower baud rate.

7. Click OK once you have changed the download port settings.

The Tutorial.download file associated with the most recent application
you have successfully generated will be specified in the File Download
dialog box.

8. Click on the Start File Download button to begin downloading.

If the connection between the development system workstation and the
target workstation is working properly, you will see the message
“Shutting down drivers, please wait,” on the engine.

Technical Note

Some devices, such as PLCs, may take a long time to shut down or
may not respond. If it appears that the device is not responding, cycle
the target workstation’s power.

Once the workstation is ready for you to download, a Triangle with
“OK” will appear.

The File Download Results dialog box will appear on the development
system screen. As the files associated with the application are success-
fully downloaded, the results are posted in this box.

9. Click OK once the application files have been “updated.” The applica-
tion will begin running on the target workstation.

If the files are not successfully downloaded, a failed message will appear
in the dialog box. If you receive a failed message, download the appli-
cation again. If it does not successfully download this time, cycle the
target workstation’s power, then repeat Step 8.
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Using the Run-time Engine

Technical Note

In the 3100 the six up arrow keys located directly below the display are
configured as F11-F16.

This section describes how to manipulate the application on the run-time en-
gine.

e Press function key F11 to access the Main_Menu screen.
e Press function key F13 to access the Run_Scm screen.

e Press F1 to see the pilot light change from red to green (on a color work-
station) or dark gray to light gray (on a monochrome workstation). Re-
lease F1 to return the pilot light to its original color.

Animating Shapes

This section describes how to configure animations for a shape on the devel-
opment system. The tags used in this section have been predefined and the
Tag Browser tool will be used for placing tag names into animation dialogs.
The Tag Browser windows will stay in the foreground to allow access to the
tag names.

To place a tag name in an animation...

1. Open the Tag Browser, located in the Tools menu or click on the Tag
Browser button on the toolbar.

2. Click on the tag name and drag the pointer to the tag name box, and re-
lease the mouse button.

3. The tag name is now configured.

If you wish to hide the Tag Browser, click on the minimize button to place it
on the Windows toolbar. Click on the Tag Browser from the Windows tool-
bar to restore.

4-27

73



SoftScreen Development System for Windows User’s Guide

Applying a Foreground Color Animation

4-28

1.

On the development system, double-click on the Main_Menu entry in
the Graphic drop-down list box on the Application Navigator form.

By using the Circle button from the Drawing Palette, add a small circle
above the horizontal valve, as shown in Figure 4-21.

gScreen Editor: Tutorial { Main_Menu }

Figure 4-21. Adding a Circle to Main_Menu Screen

Click on the Selection button on the Drawing Palette, then double-click
on the circle to access the Shape Properties form.

Change the circle’s foreground color to Red (#249) for color displays or
white (#255) for monochrome displays.

Click OK or press ENTER to accept the new foreground color.

Select the Animations button form the toolbar or select the Animations
command on the Edit Menu to access the Shape Animations dialog box.

Select the Foreground Color tab to access the Foreground color page.

Type “Valve_ON” in the Tag Name text box or use the Tag Browser and
drag and drop the name into the text box.

Select green (#250) for color units, or gray (#250) for monochrome
units, from the Color drop-down list box.

10. Click Add to add the animation to the list box, as shown in Figure 4-22.

11. Click OK to close animations dialog box.
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Shape Anima

Figure 4-22. Configuring a Foreground Color Animation

Applying a Visibility Animation

1. Add another small circle above the horizontal valve, as shown in Figure
4-23.

[ Screen Editor: Tutorial { Main_Menu ) =l B3

Figure 4-23. Adding a Circle to Main_Menu Screen

2. Use the Selection button from the Drawing Palette and double-click on
the circle to access the Shape Properties form.
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3. Change the circle’s foreground color to red (#1) for color displays or
gray (#248) for monochrome displays.

4. Click OK or press ENTER to accept the new foreground color.

5. Select the Animations command on the Edit menu to access the Shape
Animations dialog box.

Select the Visibility tab to access the Visibility animation page.

Type “Pump_ON” in the Tag Name text box or use the Tag Browser and
drag and drop the name into the text box, then select the Blink option.

8. Click Add to add the animation to the list box, as shown in Figure 4-24.

e T e e S S

Figure 4-24. Configuring a Visibility Animation

9. Click OK to accept the animation changes.
Applying a Fill Percent Animation

1. Return to the Main_Menu screen, and draw a small rectangle next to the

pressure storage vessel, above the horizontal valve, as shown in Figure
4-25.
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E,Scxeen Editor: Tutorial { Main_Menu )

Figure 4-25. Adding a Rectangle to the Main_Menu Screen

2. Using the Selector tool from the Drawing Palette, double-click on the
rectangle to access the Shape Properties form.

3. Change the rectangle’s foreground color to yellow (#251) for color units
or gray (#248) for monochrome units.

4. Click OK or press ENTER to accept the new foreground color.

5. Select the Animations command on the Edit menu to access the Shape
Animations dialog box.

6. Select the Fill Percent tab to access the Fill Percent animation page.

Type “Pressure” in the Tag Name text box or use the Tag Browser and
drag and drop the name into the text box.

Specify Up as the Direction.

9. Leave the Minimum Data Point Value as 0, and specify 1 as the Maxi-
mum Data Point Value.

10. Click Add to add the tag to the list box, and then click OK to accept the
animation changes.

11. Close the Graphic Editor.
In the Data Editor...

1. Open the Data Editor using icon on the toolbar or from the Tools menu..
Select Screens as the Type, and then double-click on the Main_Menu
entry in the list box. This accesses the Event/Actions form for the
Main_Menu screen, as shown in Figure 4-26.
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Enable data entry

Figure 4-26. Main_Menu Event/Actions Form

2. Add aKey press event attached to F6.

Choose Assignment as the Action, and type “Valve_ON” in the Tag
name (Destination) text box, and “One” in the Tag name (Source) text
box.

4, Click Add to add the event/action to the list box.
Add a key release event attached to F6.

6. Choose Assignment as the Action, and enter “Zero” in the Tag Name
(Source) text box, and “Valve_ON” in the Tag name (Destination) text
box.

7. Click Add to add the event/action to the list box.
Close the Data Editor.

Applying a Rotate Animation

1. Double-click on the Graph_Scm entry in the Graphic drop-down list box
on the Application Navigator form.

2. Select the Polygon button on the Drawing Palette.
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10.
11.

12.
13.

Create a polygon that looks like the one depicted in Figure 4-27. To cre-
ate a polygon, click where you want to place a point. Continue placing
points to complete the polygon, then double-click when you want to
complete the polygon.

[Z Screen Editor: Tutorial { Graph_Scin } |- 10 X] :

Figure 4-27. Adding a Polygon to the Graph_Scrn

Use the Selection button from the Drawing Palette and double-click on
the polygon to access the Shape Properties form.

Change the polygon’s foreground color to blue (#4) (for monochrome
and color units).

Click OK or press ENTER to accept the new foreground color.

Select the Animations command on the Edit menu to access the Shape
Animations dialog box.

Select the Rotate tab to access the Rotate page.

Type “Pressure” in the Tag Name text box or use the Tag Browser and
drag and drop the name into the text box.

Set the Reference to Center.

Specify 0 as the Minimum Data Point Value and 1 as the Maximum
Data Point Value.

Change the Maximum Angle to 255 degrees.
Click Add to add the animation to the list box, as shown in Figure 4-28.
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hape Animations

Pressure Center (Value Angle} Minimum(0.0,0) Ma

Figure 4-28. Configuring a Rotate Animation

14. Click OK to exit the Shape Animations form.

Applying Position and Sweep Angle Animations

4-34

Return to the Graph_Scm screen and click on the Pie button on the Drawing

Palette.

1. To draw a pie, click the cross hairs over the drawing area and draw a
circle.

2. Release the mouse button when the circle is the desired size.
Position the cross hairs (the radius will move with them) at the place on
the circle where you want the pie to start, then click and release the
mouse button. This sets the starting point.

4. Drag the cross hairs clockwise until a “wedge” of the pie is removed,

and then click to complete the pie, as shown in Figure 4-29.
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10.
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12.

13.

14.

Z{ Screen Editor: Tutorial [ Graph_Scin }

Figure 4-29. Adding a Pie to the Graph_Scrn

Click on the Selection button from the Drawing Palette.
Double-click on the pie to access its Shape Properties form.
Choose pattern #9 from the Pattern drop-down list box.

Select blue (#4) for color and monochrome units, as the foreground
color and yellow (#251) for color units, or light gray (#7) for mono-
chrome units, as the background color.

Click OK to accept the property changes.

Select the Animations command on the Edit menu, and then select the
Position tab from the Shape Animations form.

Type “Pressure” in the Tag Name text box or use the Tag Browser.

Leave the Minimum Data Point Value at 0, but change the Maximum
Data Point Value to 1.

Leave the minimum X and Y values at 0, and set the maximum X value
to 100 and the maximum Y value to -100. This will move the pie right
100 pixels (X) and up 100 pixels (Y) based on the value of the Pressure
tag.

Click Add to add the animation to the list box, as shown in Figure 4-30.
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Figure 4-30. Configuring a Position Animation

15. Select the Sweep Angle tab, and type “Pressure” in the Tag Name text
box or use the Tag Browser.

16. Set value ranges of 0 for the minimum Data Point Value and 1 for the
Maximum Data Point Value.

17. Set the minimum angle to 0° and the maximum angle to 275°.

Technical Note

Positive numbers in the angle field sweep clockwise, while negative
values sweep counterclockwise.

18. Click Add to add the animation to the list box, as shown in Figure 4-31.
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ressure  {Value Angle): Minimum(0.0,0) Maximum{
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Figure 4-31. Configuring a Sweep Angle Animation
19. Click OK to exit the Shape Animations form.

20. Click on the Save Application button to save changes to your applica-
tion.

Configuring Data Entry and Data Display Shapes

This section builds a data entry point with a data display on top to simplify
the screen layout.

1. Click on the Data Entry shape button on the Drawing Palette, and draw a
data entry shape on the Graph_Scrn screen.

2. On the Shapes Properties page, type “Numberl” in the Tag Name text
box or use the Tag Browser to drag and drop into the text box.

3. Leave the default settings in the remaining fields, as shown in
Figure 4-32.
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Figure 4-32. Data Entry Properties Page

4. Click on General and type “Entryl.”
5. Click OK to exit the Shape Properties form.

6. Click on the Text Box button on the Drawing Palette, and draw a text
box that covers the data entry shape.

7. Click on the Data Display radio button under Type, and then type
“Number1” in the Tag Name text box, as shown in Figure 4-33.

Shape Properties

Figure 4-33. Specifying Data Display Options
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8. Click OK to accept these formatting changes, and then click OK to exit
the Shape Properties form.

9. Close the Graphic Editor.

10. Select the Data Editor command on the Tools menu, and then select
Screens as the Type.

11. Double-click on the Graph_Scr entry in the Name list box.

12. Select Key press as the Event, and I-CURSOR (this is the cursor key in
the center of the arrow keys near the end of the list) as the Key.

13. Select Enable data entry as the Action. During run-time, this
event/action will allow you to enter data in the data entry shape.

14. Select Add to save the event/action.
15. Close the Event/Action form.

Creating an Alarm

This section describes how to configure, and define an alarm text display,
and alarm symbol for your application. The text display and symbol appears
when the tag goes into an alarm. They will be on top of the current screen
being displayed.

1. Select the Data Editor command on the Tools menu, and then select
Alarms as the Type, as shown in Figure 4-34.
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4-40

Select Data Foim

Figure 4-34. Creating an Alarm

Type “Test” in the Name text box, and then press ENTER. The Alarm
Form opens. At the same time, a corresponding alarm screen is auto-
matically generated.

Type “Pressure” in the Tag Name text box or use the Tag Browser. You
may recall that the “Pressure” tag is tied to the RampUpDown internal
variable that ranges from 0-1-0.

Specify 0.9 as the Hi Value.

Click on the Into tab at the bottom of the form to access the Into Alarm
page.
In the Message box, type “Test into alarm.”

Select Assignment as the Action, and specify Pump_ON as the Destina-
tion tag name and One as the Source tag name.

Add the into alarm settings to the list box, as shown in Figure 4-35.
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11.

12.
13.

14.

15.
16.
17.
18.

Test into alarm.

Figure 4-35. Specifying Into Alarm Page Settings
Close the Data Editor.

. Select the Graphic Editor command on the Tools menu, and select

Alarms as the Type.
Double-click on the Test entry.

Select the Text button and draw a text box on the screen.

Choose the Animated Text option, then click OK. The message entered
on the Into Alarm page (“Test”) will display during run-time when the
attached value goes into alarm.

Select the Insert Symbol icon or button to access the Insert Symbol dia-
log box.

Click on the Graphics tab and select the _alarm_circle_in symbol.
Click OK to place the symbol on the Test screen.
Close the Graphic Editor.

Select the Save button to save changes to your application.

You are now ready to generate and download the application.
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Generating and Downloading the Application

You must generate the application before you can download it to the run-
time engine. Generating allows SoftScreen to “compile” the application into
a form the run-time engine can understand. If the application contains unde-
fined tags, they will be found during generate.

Refer to the previous section, Generating the Application, for more infor-
mation on the generate function. Once you have successfully generated the
application, you can download it to the run-time engine.

If you have not done so already, refer to Chapter 2 for instructions on how to
connect the development system workstation to the target workstation.

Refer to the previous section, Downloading the Application, for detailed in-
formation on downloading your application.

Closing the Application

To close the application on the development system, select the Close com-
mand on the File menu.

If you have previously saved all changes, SoftScreen automatically closes
the application. If changes have been made, but not saved, a message box
prompts you to save them. Once you have responded to this prompt, Sofi-
Screen closes the application.

Exiting SoftScreen

4-42

To close the SoftScreen development system, select the Exit command on
the File menu. If the application is still open and you have previously saved
all changes, SoftScreen automatically closes. If modifications have been
made, but have not been saved, a message box prompts you to save them.
Once you have responded to this prompt, SoftScreen closes.
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An application consists of a Master Template, screens, and the shapes on
screens. Applications can include recipes, alarms, and event/actions.

The Master Template is a global screen. Shapes drawn on this screen
appear on every screen in the current application during run-time. Refer
to Chapter 6 for more information on the Master Template.

Screens contain shapes and bitmaps. Each shape contains properties and
can contain animations. Animations cause a shape to change during run-
time. Refer to Chapter 6 for more information on screens. Refer to
Chapter 7 for more information on animations.

Recipes are a list of assignments from one tag to another. Recipes are
loaded (read and then sent to the PLC) through an event/action. Refer to
Chapter 9 for more information on recipes.

Alarms signal that an analog value has gone too high or too low, or that
a discrete value has been turned on or off. Refer to Chapter 10 for more
information on alarms.

Event/actions are powerful and flexible events that occur during run-
time, triggering specific actions. Refer to Chapter 11 for more informa-
tion on event/actions.

Applications are essentially layers of these elements. The following list de-
scribes the order in which these elements are layered during run-time:

AN

Master Template (bottom-most layer)
Local Screen

Recipe shapes

Alarm shapes

Data entry shapes

Password entry (top-most layer)
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Creating a New Application

SoftScreen automatically creates an application when you open it for the first
time. This temporary application is “Untitled.” You can save this application
under a new name (see the section, Saving an Application, below) or you can
create a new application.

To create a new application...

1. Select the New Application command on the File menu or the New Ap-
plication button.

The Select New Target Workstation dialog box appears, as shown in
Figure 5-1.

Select New Target Workstation

Figure 5-1. Select New Target Workstation Dialog Box

2. Select a specific target workstation from the Target Workstation drop-
down list box. A corresponding description of the workstation you
choose appears in the Description box. The default is 3100M.

3. Click OK or press ENTER to close the Target Workstation dialog box.
The target you specified appears on the Application Navigator form un-
der Target Workstation.
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The Application Navigator window opens, along with the new applica-
tion. To change the default name of the application, you must save it, as
described in the following section.

Saving an Application

There are two ways to save an application. You can use the Save Application
command to save a new application or you can use the Save As command to
rename an existing application.

To save a new application...

1. Select the Save Application command on the File menu or click on the
Save Application button. The Save Application As dialog box opens, as
shown in Figure 5-2.

S —

SymbolDB
TargetFiles
&3 Tutorial

Figure 5-2. Save Application As Dialog Box

2. Select the drive on which you want to save the application from the Save
in drop-down list box if it is not already selected.

3. Double-click on the folder in which you want to save the application if it
is not already selected.

4. Type a name in the Application name text box, using up to 245 charac-
ters.

5. Click the Save button. SoftScreen saves the application. Its new name
appears in the Application Navigator title bar.
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After you have saved an application, selecting the Save Application com-
mand or the Save Application button automatically saves changes to the ap-

plication.
Caution
The system will display the following error message if it runs out of
memory:

PANIC: out of memory

To avoid running out of memory, save your application often.

To rename an existing application...

1. Inthe Application Navigator form, type an optional description in the
Description text box. This feature can be useful if you have numerous
applications.

2. Select the Save As command on the File menu. The Save Application As
dialog box opens, as shown in Figure 5-3.

SwPersis
(22 SymbolDB
TargetFiles
&4 Tutorial

Figure 5-3. Save Application As Dialog Box

3. Select the drive on which you want to save the application from the Save
in drop-down list box, if it is not already selected.

4. Double-click on the folder in which you want to save the application, if
it is not already selected.

5. Type the new name in the Application name text box, using up to 245
characters.

5-4
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6. Click the Save button. SoftScreen saves the application. Its new name
appears in the Application Navigator title bar.

After you have saved an application, selecting the Save Application com-
mand or the Save Application button automatically saves changes to the ap-
plication.

Opening an Existing Application

To open an existing application...

1. Select the Open command on the File menu or the Open button. The
Open Application dialog box appears, as shown in Figure 5-4.

Open Application

£ DBschema ;
{2 SymbaiDB
&2 TargetFiles
Tutorial

E.A SoftDev

Figure 5-4. Open Application Dialog Box

2. Inthe Look in drop-down list box, double-click on the drive on which
the desired application is stored, if it is not already selected.

3. Double-click on the folder in which the desired application resides, if it
is not already selected (when you name an application, it is saved in a
folder with the same name).

4. Double-click on the application name. The application will have the
same name as the folder, as well as an .ssw extension. The selected ap-
plication opens, and its name appears in the SoftScreen title bar.
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Engine/Alarm Configuration

General engine and alarm configuration is accomplished with a tabbed dia-
log box. This section describes Engine and Alarm configuration.

General Engine Configuration

1. From the Application Navigator form, select Engine from the Configure
menu.

Figure 5-5. Configure Engine Form — General Page

2. Click on the General tab. Table 5-1 lists the choices on the General page.
Table 5-1. Configure Engine - General Page Description

Action Description

Enable Pop-Up Keypad for Data Entry. Note: | Displays the pop-up keypad on
This choice is grayed out for non-touch the target workstation screen
workstations. when a data entry is pressed.

Default is enabled.
Enable automatic form feed before printing This option is not available.

Enable automatic form feed after printing This option is not available.

Refer to Chapter 14, “Entering Data,” for more information.

94




Chapter 5 — Creating Applications

Alarm Priority Configuration

There are 16 alarm priorities with a choice of up to 16 colors for each prior-

ity. Refer to Chapter 14, “Alarm Priorities” for more information.

| Configure Engine

Figure 5-6. Configure Engine - Alarm Priorities Page

To configure alarm priority...

1. From the Application Navigator, select Engine from the Configure
menu. The Configure Engine form opens, as shown in Figure 5-6.

2. Click on “Alarm Priorities” tab. Table 5-2 describes the choices on the

Alarm Priority page.
Table 5-2. Alarm Priority Page

Action Description

Alarm Priorities

Priority/Color To change the alarm’s priority color, double-
click on the line you want to change to bring
up the color chart . Click on the new color.
The default color is white. Note: the “Change
Color” button also brings up the color chart once
you select a line.

Driver Alarm Priority Sets the priority/color of any alarms that
originate from drivers.
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Master Alarm Shape Configuration

Master alarms are alarms that come from drivers or alarms that are config-
ured to use the Master Alarm Shape. Refer to Chapter 14, “Master Alarm
Shape,” for more information.

Figure 5-7. Configure Engine Form — Master Alarm Shape Page

To configure a master alarm shape...

1. From the Application Navigator, select Engine from the Configure
menu. The Configure Engine form opens, as shown in Figure 5-9.

2. Click on the Master Alarm tab. Table 5-3 describes the choices on the
Master Alarm Shape page.

Table 5-3. Master Alarm Shape Page

Action Description
Enable Enables the use of Master Alarm shape.
Display Time (seconds) Amount of time to display the Master Alarm

Shape ranges from 1 to 30 seconds. When con-
figuring an alarm to use the Master Alarm shape,
the time specified here will be used as the timeout
for that alarm.
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Action Description

Background Color There is a choice of 16 different background col-
ors for the Master Alarm shape. Note: The fore-

ground color of an alarm is chosen when config-
uring an individual alarm’s priority. See Chapter
10, Alarm Editor Form.

Alarm Display Window Configuration

Refer to Chapter 14, “Alarm Display Window,” for more information.

1. From the Application Navigator, select Engine from the Configure
menu. The Configure Engine dialog box opens.

Figure 5-8. Configure Engine Form — Alarm Display Window/Alarm Summary Page

2. Click on the Alarm Display Window/Alarm Summary tab. Table 5-4 de-
scribes the choices on the Alarm Display Window/Alarm Summary
Configuration page.
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5-10

Table 5-4. Alarm Display Window/Alarm Summary Configuration Page

Action Description
Enable Enables the Alarm display window
Window color There is a choice of 16 colors

Height (in lines) of Alarm Window | Number of lines that alarms occupy can be
from 2 to 12 for the 3100 target workstation
and 1 to 24 for the 3200/3300 target work-
stations.

Alarm Summary

Number of Alarms Number of alarms that are displayed in the
Alarm Summary are 10 to 255. Note: This
number is also used for the total number of
alarms in the Alarm Display Window.

Sort Order Selects the way alarms will be displayed in
: the alarm display window. Sorted by time or
sorted by priority.

Printing Alarms During Run-time

When alarms occur during run-time, they are logged in the alarm summary.
The alarm summary includes the following information in each entry:

e The user-defined message associated with the alarm
e The value at which the alarm was triggered
e The time and date when the alarm occurred

e The alarm’s state of acknowledgment

Note

If you have selected a 3200 or 3300 target workstation, you can con-
figure individual alarms to print under certain circumstances during
run-time.
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To print an alarm entry (3200/3300 only) during run-time...

Select the Print tab on the bottom of the Alarm form (Figure 5-11) to ac-

cess the Print alarm settings page, as shown in Figure 5-12.
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2. Specify Into and Out of print settings. You can specify from one to six
options for each alarm. Table 5-5 describes the options on this page.

Table 5-5. Alarm Print Settings

Option Description
Detected Prints when the associated value goes into or out of
alarm

Acknowledged | Prints when the alarm is acknowledged

Removed Prints when you delete the alarm in the alarm sum-
mary

Configuring Drivers

You must configure the drivers that you will use during run-time.

- To configure a driver...

1. Select the Drivers command on the Configure menu in the Application
Navigator or click on the Drivers button. The Configure Physical Driv-
ers dialog box opens, as shown in Figure 5-11.

Configure Physical Drivers

Allen-Bradley Data Highway Plus

Figure 5-11. Configure Physical Drivers Dialog Box

2. Select the appropriate driver from the Driver Type drop-down list box.

Type a name in the Driver Names text box. This name, which must be-
gin with a letter, can contain up to 32 alphanumeric characters, including
underscores. It cannot include colons.

5-12
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4.

Select a port from the Port drop-down list box. Choices are None,
COM1, COM2, and Special. The default is None.

Click the Add button. The name is added to the Driver Names list box.

Select the name from the Driver Names list box, and then click on the
Configure button. The corresponding Configuration dialog box opens.

This form varies, depending on the driver selected. For more informa-
tion on configuring and addressing drivers, refer to the appropriate
driver manual. For more information on addressing the internal and key-
board drivers, refer to Chapter 3.

If you have configured drivers that you no longer need, you can delete them.

When you delete a driver, you also delete its data points. If you still
want to use the data points in the application, do not delete the driver.

Caution

To delete a driver...

1.

In the Application Navigator, select the name of the driver you want to
remove in the Drivers Configured list box (you cannot delete the internal
or keyboard drivers).

Select the Delete command on the Edit menu. A message displays tell-
ing you this action will delete the selected device and all data points as-
sociates with it.

Click Yes if you still want to delete the driver and its associated data
points. Click No if you do not want to delete the driver and its associated
data points.

Converting Applications

Because applications are target specific, you must convert your application
if you want to change the application’s target workstation.

1.

Select the Convert Application command on the File menu or the Target
Workstation button. If you have made changes to the application that
have not been saved, a message box asks if you want to save changes.

After you respond to this message, the Select New Target Workstation
dialog box opens, as shown in Figure 5-12.

513

101



SoftScreen Development System for Windows User’s Guide
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Select New T arget Workstation

Figure 5-12. Select New Target Workstation Dialog Box

2. From the Target: Family drop-down list, select the family of worksta-

tions for which you are creating your application: 3100, 3200, or 3300.

Select the Touch Screen Present option if the target workstation for
which you are developing your application has a touch screen. This op-
tion is selectable for 3100 and 3200 workstations. It is automatically se-

lected for 3300 workstations, as 3300s come equipped with touch
screens.

Technical Note

You cannot convert an application created for a target with a touch
screen to a target without a touch screen.

Technical Note

If you select a conversion that is not allowed (such as converting a
3300 application to a 3100 application), the OK button is grayed. Once
you select an allowable conversion, the OK button becomes active.
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Technical Note
If the target workstation has a touch screen and you do not select the
touch screen option in the Select New Target Workstation dialog box,
you cannot configure touch zones for your application.

4. Click OK once you have specified the target workstation. The Save Ap-
plication As dialog box opens, so you can rename the application.

5. Select the drive on which you want to save the application from the Save
in drop-down list box, if it is not already selected.

6. Double-click on the folder in which you want to save the application, if
it is not already selected.

7. Type the new name in the Application name text box, using up to 250
characters.

8. Click the Save button. SoftScreen saves the application. Its new name
appears in the Application Navigator title bar.

Your application has been converted, and the new target workstation speci-
fied appears on the Application Navigator form under Target Workstation.

Closing an Application

To close an application, select the Close command on the File menu or the

Close button (E)

If you have previously saved all changes, SoftScreen automatically closes
the application. If changes have been made, but not saved, a message box
prompts you to save them. Once you have responded to this prompt, Sofi-
Screen closes the application.
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The Graphic Editor provides the necessary tools to quickly and easily create
graphical user interface screens. It allows you to create and place funda-
mental graphic shapes, symbols, and monochrome, 16-color, and 256-color
bitmaps.

Creating a New Screen

You can create new screens by selecting the Graphic Editor command on the
Tools menu or using the Application Navigator form, shown in Figure 6-1.

{{Master_Template

Figure 6-1. Application Navigator Form

The Application Navigator is the tool which allows you to navigate among
the various elements of your application. The Application Navigator form
displays on your screen when you open SoftScreen.
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To create a new screen from the Application Navigator form...

1. Select Screens from the Graphic drop-down list box on the Application
Navigator form.

2. Type a unique screen name in the Name text box. See Chapter 3 for in-
formation on creating valid names.

If you have created a default screen template, this screen will incorpo-
rate all elements of that template.

3. Press ENTER. A new Graphic Editor window opens, with the name of the
new screen in its title bar.

To create a new screen using the Graphic Editor tool...

1. Select the Graphic Editor command on the Tools menu or the Graphic
Editor button. The Select Graphic dialog box opens, as shown in
Figure 6-2.

{Master_Template

Figure 6-2. Select Graphic Dialog Box

2. Select Screens from the Type drop-down list box.

3. Type a unique screen name in the Name text box. See Chapter 3 for in-
formation on creating valid names.
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4.

If you want to create this screen based on an existing screen template,
select the template from the Create from Template drop-down list. The
Preview window displays the elements on the selected template, and the
Description box provides a description of the template, if there is one.

Click OK or press ENTER. A new Graphic Editor window opens with the
name of the new screen in its title bar.

You can open several windows in SoftScreen simultaneously. Each time you
select the Graphic Editor command on the Tools menu and choose an exist-
ing screen or create a new one, a new window opens.

If you want to open a duplicate window of a screen that is active, select the
New Window menu command on the Window menu.

If you have several windows open, use the commands on the Window menu
to organize and move among them. (Refer to Appendix A for more informa-

tion on Window menu commands.)

Technical Note

The number of screens you are able to create is limited by the amount
of available memory on your workstation. Refer to Chapter 13 for
more information on the number of screens you can create in your ap-
plication.

The number of windows you can open during a SoftScreen session is
limited by Windows resources. That is, if you have several Windows
programs open at the same time as SoftScreen, you will be more lim-
ited in the number of windows you can open within SoftScreen than if
you do not have any other programs open at the same time.

Opening an Existing Screen

You can open an existing screen in several ways.

To open an existing screen...

Select Screens from the Graphic drop-down list box in the Application
Navigator form, then double-click on the desired screen name in the as-
sociated list box. A Graphic Editor window opens, displaying the se-
lected screen, as shown in Figure 6-3.
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ninjolojnin

Figure 6-3. Graphic Editor with Bitmap of 3100 Front Panel Visible
or

e Select the Graphic Editor command on the Tools menu. When the Select
Screen dialog box opens, type in the name of the existing screen or dou-
ble-click on it in the list box. A Graphic Editor window opens, display-
ing the selected screen.

or

e Select the Graphic command on the View menu when the Graphic Edi-
tor is open. In the Select Screen dialog box, type the name of the screen
or double-click on it in the list box. The selected screen replaces the
screen displayed in the currently selected Graphic Editor window.

Opening the Master Template

6-4

The Master Template is a global screen. Shapes drawn on this screen appear
on every screen in the current application during run-time. For example, if
you place your company logo on the Master Template, it will appear on
every screen in your application during run-time.

To open the Master Template...

1. Select Screens from the Graphic drop-down list box on the Application
Navigator form.
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2. Double-click on the Master Template entry in the associated list box.
The Graphic Editor opens, with the Master Template drawing area dis-
played.

Technical Note

If you want to view shapes placed on the Master Template on all
screens on the development system, choose the Set Visibility com-
mand on the View menu. Then select the Show Master Template
Shapes option. The shapes are shown on all screens to help position
other shapes; they cannot be edited except on the Master Template.

You are now ready to place shapes on the screen. For more information on
creating shapes, refer to the Working with Shapes section in this chapter.

Specifying Screen Properties
You can do the following in the Screen Properties dialog box:
e Change screen color
e Set security level

e Provide a screen description

Changing Screen Color

You can choose a screen color from a 256-color palette.

Technical Note

You cannot change the screen color of the Master Template.

To change screen color...
1. Open the screen in your application whose color you wish to change.
2. Select the Properties command on the Edit menu. A submenu opens.

3. Select the Screen command from the submenu. The Screen Properties
dialog box opens, as shown in Figure 6-4.
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Figure 6-4. Screen Properties Dialog Box

4. Select the desired color from the Screen Color drop-down list box. The
number in parentheses next to the color indicates the color’s palette
number for reference. The default color is white (255).

5. Click OK or press ENTER to apply the new color.

Copying and Pasting Screens

To copy and paste a screen...

Technical Note

You cannot copy and paste the Master Template.

1. From the Application Navigator, select Screens from the Graphic list
box, and then highlight the screen you want to copy.

2. Select Copy from the Edit menu.
3. Open the application in which you want to copy the screen.
4. In the Application Navigator, select the Paste command on the Edit

menu. The Change Paste Names dialog box appears, as shown in Figure
6-5.
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Figure 6-5. Change Paste Names Dialog Box

5. To avoid a conflict with a tag name in the new application, type a new
recipe name in the New text box.

6. Click OK. The recipe graphic screen has been added to your application
with the name you specified in the New text box.

Assigning a Security Level

SoftScreen allows you to assign a security level to the target workstation to
restrict access during run-time to authorized personnel. To use security lev-
els, you must assign passwords. Refer to Chapter 14 for information on the
use of passwords during run-time.

To define passwords...

1. Inthe Application Navigator, select the Passwords command on the
Configure menu or the Passwords button. The Configure Passwords
dialog box opens, as shown in Figure 6-6.
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Configure Passwords

Figure 6-6. Configure Passwords Dialog Box

2. Select the security level for which you want to assign a password from
the List of Passwords box. There are 32 levels from which to select,
from 0-31.

Technical Note

Zero is the default security level on the engine. If you enter 0 in the
password box during run-time, the engine security level is reset to 0.

3. Type the password in the Password text box. Passwords must begin with
a letter, and can contain up to 32 alphanumeric characters. Use only
numbers if the run-time engine has no external keyboard.

4. Click Apply or press ENTER to accept the new password.

For example, when you first start the run-time engine, it is set to security
level 0. If a “Go to Screen” action attempts to open a screen set to level
10, a password text box will display. You must enter a password that is
set for security level 10 or above to open the screen. If you enter the
password for level 15, then the run-time engine’s new security level will
be 15. This means that any screens set to security levels from 0-15 can
be opened without providing a password.

To change or delete a password on the development system...

1. In the Configure Passwords dialog box, select the security level.
2. Click in the Password text box and highlight the current password.
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3. Press DEL, then type in the new password.

4. Click Apply or press ENTER.

5. Click OK when you have finished defining passwords.
To assign a security level to a screen...

1. Open the screen in your application to which you want to assign a secu-
rity level.

2. Select the Properties command on the Edit menu to access a submenu.

3. Select the Screen command. The Screen Properties dialog box opens, as
shown in Figure 6-7.

Screen Prop

Figure 6-7. Screen Properties Dialog Box

4. Type the desired level in the Security Level text box, from 0 to 31, with
0 being the least secure and 31 being the most secure. The default is 0.

5. Click OK or press ENTER to apply the security level to the screen.

Technical Note

If you have changed the security level of the run-time engine and want
to change it back to 0, you must provide the password (0). However, if
the run-time engine security level is currently set to 0, you do not have
to provide a password.
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Providing a Screen Description

To enable you to identify a screen more easily, you can provide a description
in the Screen Properties dialog box. You can also use this feature to log ap-
plication changes.

To provide a screen description...
1. Open the screen for which you want to provide a description.
2. Select the Properties command on the Edit menu. A submenu opens.

3. Select the Screen command. The Screen Properties dialog box opens, as
shown in Figure 6-8.

Figure 6-9. Screen Properties Dialog Box

4. Type a description of the screen in the Description text box. This de-
scription can be up to 32 Kbytes.

5. Click OK or press ENTER to save the description.

Working with Shapes

As you draw and place shapes, the status bar displays their X and Y coordi-
nates and width and height (in pixels), as shown in Figure 6-10. Also, when
pasting an object, it will be offset by 10 pixels to the right and to the bottom.
Use these numbers as a reference when drawing and placing shapes.

6-10
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" SoftScreen for Windows - [Screen Editor: Project] [ Screen ]

Figure 6-10. Screen Coordinates on Graphic Editor Status Bar

Technical Note

To provide flexibility when animating shapes, it is possible to draw
and move shapes outside the boundaries of the development system
drawing area.

Undoing Mistakes

Before you begin using Graphic Editor tools, you should understand how to
undo mistakes.

Select the Undo command on the Edit menu or click on the Undo button to
undo your last action in the current Graphic Editor session.

6-11
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Caution

If you are in the Graphic Editor and open one of the other SoftScreen
tools, you cannot undo the previous action in the Graphic Editor. Also,
if you save the application or apply an animation to a shape, Soft-
Screen empties the undo buffer and you will not be to undo the previ-
ous action.

Changing Screen Magnification

6-12

There are several ways you can increase or decrease screen magnification to
help you draw and place shapes:

Select the Zoom command on the View menu to access the Zoom Set-
tings dialog box.

Select from preset Zoom Settings of 50% to 400%. The default setting is
100%.

or

Click on the Custom option, and then type the desired percentage in the
text box, from 10% to 1000%.

Click on the Zoom Selected command on the View menu to magnify a
select area of the screen. Press and hold the left mouse button at the cor-
ner of the area you want to magnify, and then drag the mouse until the
bounding box surrounds the area. Release the left mouse button to mag-
nify the selected area.

Choose the Zoom In command on the View menu to increase the screen
magnification to twice its current size. For example, if magnification is
currently set to 100%, selecting Zoom In changes it to 200%.

Select the Zoom Out command on the View menu to decrease screen

magnification to half its current size. For example, if magnification is
currently set to 100%, selecting Zoom Out changes it to 50%.
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e Select the Zoom to Window command on the View menu to resize the
Graphic Editor so you can view the entire target front panel (if it is dis-
played; refer to the Arranging Shapes section later in this chapter for
more information on the target front panel), as well as the drawing area,
or just the drawing area (if the target front panel is not displayed).

Selecting and Deselecting Shapes

Once something is placed on the development system screen—whether it is a
shape you draw, a symbol you insert, or a bitmap you import-it is consid-
ered a shape, and commands can be applied to it and actions can be per-
formed on it.

There are several ways to select a single shape, and a group of shapes, using
the mouse and keyboard.

To quickly select all shapes on the screen, choose the Select All command
on the Edit menu or the Select All button. All shapes on the screen are en-
closed within a bounding box. You can then apply actions or commands to
all the shapes within the bounding box. :

To select individual shapes...

1. Choose the Selection command on the Shapes menu, or click on the Se-
lection tool on the Drawing Palette. This changes the cursor from cross
hairs (if you just finished drawing a shape) to a pointer.

2. Click on the first shape you want to select. A bounding box, with sizing
handles, appears around the shape.

3. Press SHIFT + click to select each additional shape. The bounding box
expands to include each shape as it is selected.

To select more than one shape...

1. Position the pointer on the drawing area outside the shapes you want to
select.

2. Press and hold the left mouse button, then drag the mouse so the
bounding box encompasses every shape you want to select (this is called
rubberbanding).

6-13
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Technical Note

To select an arc or a pie, treat it as if it is an ellipse and select the en-
tire shape, not just the arc or pie.

3. Release the left mouse button. The bounding box now surrounds all the
shapes you selected.

Once shapes have been selected, you can deselect them in several ways, as
indicated in Table 6-1.

Table 6-1. Deselecting Shapes

Selection Action to Deselect
Single shape Click on another shape.
Or

Click anywhere on the screen.

Multiple shapes Click anywhere on the screen (except
on a selected shape).

To deselect a particular shape, press
SHIFT + click on the shape.

To move selected shapes...

Use the arrow keys and the Selection tool to move selected shapes. The ar-
row keys will move the shape one pixel at a time. By pressing the CTRL key
and the ARROW key at the same time, the shape will shift 10 pixels at a
time. The Selection tool lets you drag the shape to any location on the
screen.

Drawing Shapes

You can use the Graphic Editor to draw lines, polylines, squares, rectangles,
polygons, circles, ellipses, pies, arcs, text boxes, touch zones, and data entry
shapes.

Technical Note
Hit the ESC key on your keyboard to abort the current action.

6-14
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Creating Lines

You can draw two types of lines in SoftScreen: lines and polylines.

4.

To draw a line...
1.

Select the Line command on the Shapes menu, or click on the Line
drawing tool on the Drawing Palette.

Position the cross hairs over the drawing area where you want the line to
start.

Press and hold the left mouse button, then drag the mouse in any direc-
tion until the line is the desired length and orientation.

Release the left mouse button to complete the line.

To draw a polyline...
1.

Select the Polyline command on the Shapes menu, or click on the
Polyline drawing tool on the Drawing Palette.

Position the cross hairs on the drawing area where you want the polyline
to start, and click.

Move the cross hairs to another point on the screen, and click to place
the line segment.

Continue to move the cross hairs, clicking once at the end of each seg-
ment.

Double click to complete the polyline.

Creating Squares and Rectangles

To draw a square...

1.

Select the Square command on the Shapes menu, or click on the Square
drawing tool on the Drawing Palette.

Position the cross hairs over the drawing area where you want to place a
corner of the square.

Press and hold the left mouse button, then drag the mouse in any direc-
tion until the square is the desired size.

6-15
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Technical Note

When drawing a square, you are constrained to drawing only a square.
However, once the square is completed, you can resize it into a rectan-
gle.

4.

Release the left mouse button to complete the square.

To draw a rectangle...

1. Select the Rectangle command on the Shapes menu, or click on the
Rectangle drawing tool on the Drawing Palette.

2. Position the cross hairs over the drawing area where you want to place a
corner of the rectangle.

3. Press and hold the left mouse button, then drag the mouse in any direc-
tion until the rectangle is the desired size.

4. Release the left mouse button to complete the rectangle.

Creating Polygons

6-16

To draw a polygon...

1. Select the Polygon on the Shapes menu, or click on the Polygon draw-
ing tool on the Drawing Palette.

2. Position the cross hairs over the drawing area where you want to place a
corner of the polygon, and click.

3. Move the cross hairs to another point on the screen, and click to draw
the first side.

4. Continue to move the cross hairs, clicking once at the end of each side.

5. Double-click on the last point to complete the polygon.
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Creating Circles and Ellipses

To draw a circle...

1. Select the Circle command on the Shapes menu, or click on the Circle
drawing tool on the Drawing Palette.

2. Position the cross hairs over the drawing area where you want the circle
to begin.

3. Press and hold the left mouse button, then drag the mouse in any direc-
tion until the circle is the desired size.

4. Release the left mouse button to complete the circle.

Technical Note

When drawing a circle, you are constrained to drawing only a circle.
However, once the circle is completed, you can resize it into an ellipse.

To draw an ellipse...

1. Select the Ellipse command on the Shapes menu, or click on the Ellipse
drawing tool on the Drawing Palette.

2. Position the cross hairs over the drawing area where you want the ellipse
to begin.

3. Press and hold the left mouse button, then drag the mouse in any direc-
tion until the ellipse is the desired size.

4. Release the left mouse button to complete the ellipse.

Creating Pies and Arcs

To draw a pie...

1. Select the Pie command on the Shapes menu, or click on the Pie draw-
ing tool on the Drawing Palette.

2. Position the cross hairs over the drawing area where you want the pie to
begin.

6-17
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6-18

Press and hold the left mouse button, then drag the mouse in any direc-
tion until the pie is the desired size.

Release the left mouse button.

Position the cross hairs (the radius will move with them) at the place on
the circle where you want the pie to start, then click and release the left
mouse button. This sets the starting point.

Drag the cross hairs until the pie is the desired size, then click to com-
plete the shape.

Technical Note

If you move the cross hairs counterclockwise, you will start with no
shape and draw the pie within the confines of the shape you created in
Step 3. If you move the cross hairs clockwise, you will create the de-
sired pie by “erasing” the rest of the shape.

To draw an arc...

1.

Select the Arc command on the Shapes menu, or click on the Arc
drawing tool on the Drawing Palette.

Position the cross hairs over the drawing area where you want the arc to
begin.

Press and hold the left mouse button, then drag the mouse in any direc-
tion until the arc is the desired size.

Release the left mouse button.

Position the cross hairs (the radius will move with them) at the place on
the circle where you want to start the arc, then click and release the left
mouse button. This sets the starting point.

Drag the cross hairs until the arc is the desired size, then click to com-
plete the shape.

Technical Note

If you move the cross hairs counterclockwise, you will start with no
shape and draw the arc within the confines of the shape you created in
Step 3. If you move the cross hairs clockwise, you will create the de-
sired arc by “erasing” the rest of the shape.
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Creating Text Boxes

There are three types of text boxes you can create: static text, animated text,
and data display.

To draw a static text box...

1. Select the Text box command on the Shapes menu, or click on the Text
drawing tool on the Drawing Palette.

2. Position the cross hairs over the drawing area where you want to place a
corner of the text box.

3. Press and hold the left mouse button, then drag the mouse in any direc-
tion until the text box is the desired size.

4. When you release the left mouse button, the Shape Properties form
opens, with the Text page active, as shown in Figure 6-11.

Figure 6-11. Static Text Properties Page in the Shape Properties Form

Caution

The text box will not be inserted if you choose Cancel in the Shape
Properties Form

5. Select the text size you want: 8, 12, 24, or 48 points. The default is 12.
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Technical Note

Underline is unavailable when 8 point text is selected.

6. Choose the Static Text option from the Type group.
7. Inthe Text box, type the text you want to display during run-time.

Technical Note

Although you can type in all the ASCII characters on the development
system, the run-time engine will only display ASCII characters from
20h (32 decimal) to 7Eh (126 decimal).

8. When you have finished setting text properties, click OK or press
ENTER. The specified text appears in the text box.

Technical Note

Text may look slightly different on the engine than it looks on the de-
velopment system.

To draw an animated text box...

1. Select the Text box command on the Shapes menu, or click on the Text

drawing tool on the Drawing Palette.

2. Position the cross hairs over the drawing area where you want to place a

corner of the text box.

3. Press and hold the left mouse button, then drag the mouse in any direc-

tion until the text box is the desired size.

4. When you release the left mouse button, the Shape Properties form
opens, with the Text page active, as shown in Figure 6-12.
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S = S

Figure 6-12. Animated Text Properties Page in the Shape Properties Form

Caution

The text box will not be inserted if you choose Cancel in the Shape
Properties Form

5. Select the text size you want: 8, 12, 24, or 48 points. The default is 12.

Technical Note

Underline is unavailable when 8 point text is selected.

6. Choose the Animated Text option from the Type group.

7. When you have finished setting text properties, click OK or press
ENTER.

In order to animate this text box, you must apply a text animation. Refer to
Chapter 7, Animating Shapes, for information on animating text.

You can use data display shapes to view tag values. For example, you can
use them to display system time and system date.

6-21
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To draw a data display shape...
1.

Select the Text box command on the Shapes menu, or click on the Text
drawing tool on the Drawing Palette.

Position the cross hairs over the drawing area where you want to place a
corner of the text box.

Press and hold the left mouse button, then drag the mouse in any direc-
tion until the text box is the desired size.

When you release the left mouse button, the Shape Properties form
opens, with the Text page active, as shown in Figure 6-13.

Shape Properties

Figure 6-13. Data Display Text Properties Page in Shape Properties Form

Caution

The text box will not be inserted if you choose Cancel in the Shape
Properties Form

5. Select the text size you want: 8, 12, 24, or 48 points. The default is 12.

Technical Note

Underline is unavailable when 8 point text is selected.

6-22
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6. Choose the Data Display option from the Type group. The Data Display
options appear, as shown in Figure 6-13.

You must provide the information described in Table 6-2 to configure

data display text.
Table 6-2. Data Display Options
Field Definition
Tag Name | Assigns a tag name. The value of this tag will be

displayed during run-time.

Data Type

Sets the data display type to Float (default) or String.

If you select Float, you must specify a format. The
default is Float.

Format

Sets the format to date, time, decimal, hexadecimal,
octal, or binary. If you select Decimal, Hexadecimal,
Octal, or Binary, you can specify Advanced proper-
ties. The default is Decimal.

Advanced

Accesses the Advanced page if you select Decimal,
Hexadecimal, Octal, or Binary as the format so you
can specify advanced format properties.

The Advanced page is shown in Figure 6-14.

S

Figure 6-14. Advanced Page
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Table 6-3 defines the fields in the Advanced Page.
Table 6-3. Fields in the Advanced Page

Field

Definition

Total Character Space

Sets the total number of characters in the
data display. This number should be
greater than or equal to the number of left
and right digits, plus the decimal point and
the sign. The default is 8.

Align to Column

Sets the column to which you want to align
the decimal point. The default is 0, which
means no column alignment. Column num-
ber begins at 1, which is the first character
space on the left in the text box.

Suppress leading zeros

Suppresses leading zeros when selected.
The default is on.

Suppress trailing zeros

Suppresses trailing zeros when selected.
The default is on.

Display +

Displays a “+” when selected and the
number is positive. The default is set to
suppress the sign. (The minus sign is al-
ways displayed if it is a negative number.)

Left digits

Sets the number of digits to the left of the
decimal point. The default is 5.

Right digits

Sets the number of digits to the right of the
decimal point. The default is 2.

Minimum value

Sets the minimum value of the number be-
ing displayed. The range is IEEE 32-bit
floating point minimum and maximum. The
default is 0.

Maximum value

Sets the maximum value of the number
being displayed. The range is IEEE 32-bit
floating point minimum and maximum. The
default is 65,535.

7. When you have finished setting data display text properties, click OK or

press ENTER.

Number signs (#) reflecting the number of digits appear in the data display
shape on the development system screen (for example, if you specify four
left digits and four right digits on the Advanced page, you would see

#iHH# ##1##). These number signs will not display during run-time.
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Creating Data Entry Shapes

Data entry shapes allow users to enter strings or numbers during run-time
that will be written to the associated tag.

Caution

Do not place data entry shapes on the Master Template, as you cannot
access them during run-time.

To create a data entry shape...

Technical Note

You cannot configure data entry shapes unless they are visible. To
view data entry shapes, you must select the Set Visibility command on
the View menu, and then check the Show Data Entry Objects option.

1. Select the Data Entry command on the Shapes menu, or click on the
Data Entry drawing tool on the Drawing Palette.

2. Position the cross hairs over the drawing area where you want to place a
corner of the data entry shape.

3. Press and hold the left mouse button, then drag the mouse to create a
data entry shape of the desired width.

4. When you release the left mouse button, the Shape Properties form
opens, with the Data Entry page active, as shown in Figure 6-15.

6-25
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Figure 6-15. Data Entry Properties Page in the Shape Properties Form

Caution

The data entry shape will be deleted if you choose Cancel in the Shape
Properties form.

5. Type a tag name in the Tag Name text box. This tag name identifies the
data point to which you will be sending data.

6. Select the format in which you want to enter the data: Float or String.
The default is Float.

7. If you select Float, specify a minimum and maximum value. The range
is -65535 to +65536. The defaults are 0 for the minimum value, 65535
for the maximum.

8. Select the Style tab if you want to change the default settings.

Technical Note

In the Style page, the Foreground color sets the text color; background
color sets the box color.

9. Click OK or press ENTER to complete the shape.

10. To turn off display of the data entry shape on the development system
screen, select the Set Visibility command on the View menu.

6-26
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11. Deselect the Show Data Entry Objects option.

Technical Note

A data entry shape is only visible during run-time at the time data en-
try is enabled. You will never see more than one data entry shape dis-
played at one time on the run-time screen.

A screen that contains data entry shapes must have an event/action defined
to enable them at run-time. Refer to Chapter 11, Assigning Event/Actions,
for more information.

If you have more than one data entry shape on a screen, you must specify the
order in which the cursor will move from one data entry shape to another. If
you do not, the cursor will not move from the first data entry object you
place on the screen.

To specify data entry links...

1. Select the Data Editor commarid on the Tools menu to open the Select
Data Form dialog box.

2. Double-click on the screen in which the data entry shapes are config-
ured. This opens the associated Event/Action form.

3. Click on the Data Entry Links tab located at the bottom of the form. The
Data Entry Links page opens.

An example of data entry links is shown in Figure 6-16.
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“ Sélén one \

dataentryl dataentry1 dataentryl
dataentry2 dataentry2 dataentry2 dataentry2

Figure 6-16. Data Entry Links Page

4. TFrom the list box, select the internal name of the data entry shape whose
links you want to change. This name displays in the Data Entry Name
box, and the associated links will appear in the Up, Down, Left, and
Right boxes.

Choose the links you want to set from each of the drop-down list boxes.

6. Repeat steps 4 and 5 for each of the data entry shapes whose links you
want to change.

7. Save the application to preserve these changes.

During run-time, you will be able to move among the data entry shapes in
the order in which you have specified.

Creating Touch Zones
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You can create touch zones on a screen if the target workstation has a touch
screen. Touch zones can then be linked to an action (such as acknowledging
an alarm or changing a password level) which is triggered when the touch
zone is pressed on the run-time engine.
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Technical Note

You cannot create touch zones on alarm or recipe screens.

To create a touch zone...

Technical Note

To configure touch zones on the development system, they must be
visible. With the Graphic Editor open, select the Set Visibility com-
mand on the View menu, and select the Show Touch Zones option.

1. Create a shape that you want to cover with a touch zone. (Touch zones
are not visible during run-time. Therefore, you want to “attach” the
touch zone to a visible shape so you know where the touch zone is lo-
cated on a screen).

2. Select the Touch Zone command on the Shapes menu, or click on the
Touch Zone drawing tool on the Drawing Palette.

3. Place the cross hairs on the drawing area near the shape you want to
cover with the touch zone.

4. Press and hold the left mouse button, then drag the mouse so that the
touch zone covers the selected shape.

5. Release the left mouse button to complete the touch zone. The Shape
Properties form opens, with the General page displayed. You must enter
a name for the touch zone.

6. Type a name in the Name text box and a description of what the touch
zone does in the Description text box, then press OK.

7. To hide the touch zone on the development system screen, select the Set
Visibility command on the View menu.

8. Deselect the Show Touch Zone option. All touch zones on the develop-
ment system will become invisible.

Now you must create a touch zone event that is linked to an action. Refer to
Chapter 11, Assigning Event/Actions, for more information.
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Importing Bitmaps

In addition to creating shapes and placing symbols, you can import bitmaps
in the Graphic Editor.

Caution
You cannot insert bitmaps that are larger than the display of your tar-
get workstation. A bitmap can be up to 320 x 240 x 256 colors on a
3100, and up to 640 x 480 x 256 colors on a 3200 or 3300.

Also, be aware that bitmaps use large amounts of memory on the target
workstation. Refer to Chapter 13 for information on available memory.

To import bitmaps...

1. Select the Insert Bitmap command on the Edit menu. The Open dialog
box appears.

2. Ifthe bitmép you want is not located on the current drive, select the ap-
propriate drive from the Look In drop-down list box.

3. Double-click on the desired folder.

4. From the resulting list, double-click on the bitmap you want to insert.
The selected bitmap is inserted in the top left-hand corner of the devel-
opment system screen.

Technical Note

You can move bitmaps once you have placed them on screen. How-
ever, you cannot resize, rotate, or flip them.

Applying Shape Properties

All shapes display static properties. Default properties can be set for the
shapes. You can also apply specific properties to individual shapes.

There are four shape property pages in the Shape Properties form.

e The Style property page sets line color, type, and width, fill pattern,
foreground color, and background color. All properties on this page do
not apply to all shapes.
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e The Text Property page sets the specifications for text boxes. This page
appears only when you draw or edit a text box.

e The Data Entry Property page sets the specifications for data entry
shapes. As such, it only appears in the Shape Properties form when you
draw or edit a data entry shape.

e The General page sets the internal name and description for all shapes,
so it is always available in the Shape Properties form.
Table 6-4 describes the style properties.
Table 6-4. Style Properties
Style Property Definition

Line Color Sets the color of lines and borders around shapes.
You can choose from 255 colors. The default is black
(0). This property does not apply to data display
shapes, touch zones, data entry shapes, or text.

Line Type Sets the line type of lines and borders around shapes
to solid (1), large dashed (2), or small dashed (3). The
default is solid (1). This property does not affect data
display shapes, touch zones, data entry shapes, or
text. Note: All line types will display as a solid line on the
development system. However, the selected line type will
display properly during run-time.

Line Width Sets the width of lines and borders around shapes to
1, 2, or 3. The default is 1. This property does not
affect data display shapes, touch zones, data entry
shapes, or text. Note: If you select line width option 2 or 3,
line types 2 and 3 will not display on the development sys-
tem. However, the selected line type will display properly
during run-time.

Fill Pattern Sets the fill pattern of a shape. You can choose from
32 patterns. You can also choose not to set a fill pat-
tern. The default is 2. This property does not affect
lines, polylines, arcs, text, touch zones, data display
shapes, and data entry shapes.

Foreground Color Sets the foreground color of shapes. You can choose
from 256 colors. The default is gray (7). This property
does not affect lines, polylines, arcs, text, touch
zones, data display shapes, and data entry shapes.
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Style Property Definition

Background Color Sets the background color of shapes. You can choose
from 256 colors. The default is dark gray (248). This
property does not affect lines, polylines, arcs, text,
touch zones, data display shapes, and data entry
shapes.

Table 6-5 defines Text properties.
Table 6-5. Text Properties
Text Property | Definition

Font Sets the font to Courier. Underline is available in all
font sizes except 8 point.

Size Sets the point size of the text to 8, 12, 24, or 48. The
default is 12.

Type Specifies whether text is Static, Animated, or Data

| Display. The default is Static.

Text Defines the message to be displayed if Static is the

specified type

Table 6-6 defines the General properties.
Table 6-6. General Properties

General Property | Definition

Name Provides the internal name of the shape. You
can change this name if you like.

Description Allows you to provide a description of the shape

Changing Style Properties for Individual Shapes

You can change the properties of individual shapes.

To change line properties of a shape...
1. Choose the Selection tool on the Drawing Palette.
2. Double-click on the shape or shapes whose properties you want to alter.

or
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Select the shape or shapes. Click the Properties command on the Edit
menu and then the Shape command or the Shape Properties command.

The Shape Properties form opens, with the Style Properties page active,
as shown in Figure 6-17.

Technical Note

If you double-click on a text box, the Shape Properties form opens
with the Text Properties page active.

Figure 6-17. Style Properties Page in the Shape Properties Form

3. Select a color from the 256-color palette in the Color drop-down list
box.

4. Inthe Type drop-down list box, choose a line type.

Technical Note

All line types will display as a solid line on the development system.
Also, if you select a line width other than option 1, line types other
than 1 will not display. However, the selected line type will display
properly during run-time.

5. Choose the desired width from the Width drop-down list box.
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6. Click Apply to apply these styles to a shape without exiting the dialog
box.

or

Click OK or press ENTER to exit the dialog box and apply the styles to
the selected shapes.

To change the fill pattern and color of a shape...

1. Choose the Selection tool on the Drawing Palette.

2. Double-click on the shape or shapes whose properties you want to alter.
or

Select the shape or shapes. Then select the Properties command on the
Edit menu and then the Shape command, or click on the Shape Proper-
ties button.

The Shape Properties form opens, with the Style page active, as shown
in Figure 6-18.

Figure 6-18. Style Properties Page in the Shape Properties Form

3. Select one of 32 patterns from the Pattern drop-down list box.

4. Choose a foreground color from the Foreground drop-down list box. If
you select the white pattern, foreground color determines the color of the
shape. If you select the solid black pattern, changing the foreground
color does not affect the shape.
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5. Choose the desired background color from the Background drop-down
list box. If you select the solid black pattern, background color deter-
mines the color of the shape. If you select the white pattern, the back-
ground color does not affect the shape.

6. Click Apply to apply these styles to a shape without exiting the dialog
box.

Or click OK or press ENTER to exit the dialog box and apply the styles
to the selected shapes.

Specifying Default Shape Properties
You can change the default settings of shape properties without changing the
properties of shapes you have already created.
To change the default shape properties...

1. Select the Properties command on the Edit menu, then select the Shape
(default) command. The Default Shape Properties form opens, with the
Style page displayed, as shown in Figure 6-19.

fault S e Prope

Figure 6-19. Style Properties Page in the Default Shape Properties Form

2. If you want to change Style default settings, you can specify Line Color,
Type, and Width, as well as a Fill Pattern, Foreground Color, and Back-
ground color.
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3. Select the Text tab if you want to change the default settings of text in
text boxes. Change the Text Size, Style (Underline), and Type, as well as
the message if you specify Static Text as the format.

4. Select the Data Entry tab to change the default settings for Data Entry
shapes.

5. Click OK or press ENTER to set the new default properties.

All shapes you create during the current SoftScreen session will display
these new default settings.

Technical Note

These default settings are not saved when you exit SoftScreen.

Providing a Shape Description

You can provide a description for each shape (up to 32 Kbytes), to help you
identify it more easily. You can also use the description as a log of changes
to a shape, as well as a place to list assigned tags.

To provide a shape description...

1. Choose the Selection tool on the Drawing Palette.
2. Double-click on the shape to access the Shape Properties form.

3. Click on the General tab to access the General Properties page, as shown
in Figure 6-20.
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Shape Properties »

Figure 6-20. General Properties Page

4. Type a unique name for the shape in the Name text box, using up to 32
characters.

5. Type a description in the Description text box, up to 32 Kbytes. This can
be used to store details about the shape’s purpose or revision history.

6. Click OK or press ENTER to save the name and description.

Arranging Shapes

You can quickly change the way shapes are arranged using the following

commands:

e Grid ¢ Ungroup
e Align ®  Order

e Group

If you are configuring an application for a either a 3100, 3200 or 3300 target
workstation, you can also use a bitmap of the target workstation’s front
panel to help you place shapes on the drawing area and align them with ele-
ments on the target’s front panel. If you specified a 3100 Front Panel target,
this bitmap is displayed on your screen when you open the Graphic Editor. If
you do not want to view this bitmap, select the Set Visibility command on
the View menu and click the Show Target option to turn it off.
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Using the Grid

6-38
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SoftScreen automatically displays a grid on the development system screen
to help in positioning shapes (this grid does not display on the run-time en-
gine). To change the grid default settings, select the Grid command on the
View menu or the Grid button. The Grid Settings dialog box opens, as
shown in Figure 6-21.

Grid Settings

Figure 6-21. Grid Settings Dialog Box
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Table 6-7 defines the fields in this dialog box.
Table 6-7. Fields in the Grid Settings Dialog Box
Field Definition

Display Grid Turns display of the grid on and off. When selected
(the default), the grid will display on the develop-
ment system screen, and a check mark will appear
next to the Grid command on the View menu.

Snap to Grid Causes shapes you draw to snap to intersecting
points of the grid, allowing you to precisely align
shapes. The default is off. This feature works even if
the grid is not displayed. To toggle the Snap to Grid
setting, press and hold the CTRL key as you are
drawing or moving shapes. Once you release the
CTRL key, Snap to Grid reverts to the settings speci-
fied in the Grid Settings dialog box. Note: If you
draw a shape the size of one grid square with the
Snap to Grid feature turned on, you will not be able
to move the shape. To alleviate this problem, use
the CTRL key to toggle the Snap to Grid feature on
and off. For example, if you have Snap to Grid on
and you draw a circle that is one grid square, press
and hold down the CTRL key to move the circle.

Grid Spacing Sets the size of the squares forming the grid (small
dashed lines), from 2 to 200 pixels. The default is
20.

Guide Line Sets the spacing between guide lines (thick dashed

Spacing lines), from 2 to 20 grid squares. The default is 4.

To change grid sizing settings...

1. Select the Grid command on the View menu or the Grid button to open
the Grid Settings dialog box (see Figure 6-21).

2. Choose a number from 2 to 200 for the Grid Spacing setting. The value
in this field sets the size of the squares forming the grid (small dashed
lines), from 2 to 200 pixels.

3. Choose a number from 2 to 20 for the Guide Line Spacing setting. The
value in this field sets the spacing between guide lines (thick dashed
lines), from 2 to 20 grid squares.
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4. Click OK or press ENTER. The new grid settings are implemented.

Any changes made in the Grid Settings dialog box become the default set-
tings for any new screens you create and for the screen that is currently ac-
tive. However, if multiple graphic windows are open, changes do not affect
them until they are closed and then reopened.

Aligning Shapes
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The Align command allows you to align two or more shapes on the devel-
opment system screen.

To align shapes...

1. Choose the Selection command on the Shapes menu, or click on the Se-
lection tool on the Drawing Palette. This changes the cursor from cross
hairs (if you just finished drawing a shape) to a pointer.

2. Select two or more shapes that you wish to align.

Choose the Align command on the Arrange menu or the Align button.
The Align dialog box opens, as shown in Figure 6-22.

Figure 6-22. Align Dialog Box

4. Choose an alignment option. You can align shapes along the X axis,
along the Y axis, or along both axes. Table 6-8 defines the alignment
options.
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Table 6-8. Alignment Options

Alignment Option

Definition

None

Does not align the selected shapes along
the X or Y axis. This is the default setting.

Left

Aligns the selected shapes with the left
edge of the left-most selected shape

Center X

Aligns the horizontal center of the selected
shapes with the horizontal center of the area
that contains the shapes

Right

Aligns the selected shapes with the right
edge of the right-most selected shape

Top

Aligns the selected shapes with the top
edge of the top-most selected shape

Center Y

Aligns the vertical center of the selected
shapes with the vertical center of the area
that contains the selected shapes

Bottom

Aligns the selected shapes with the bottom
edge of the bottom-most selected shape

5. Click OK or press ENTER to align the selected shapes.

Once you exit the dialog box and the selected shapes are aligned, the dialog
box reverts to its default settings (None for both X and Y).

Technical Note

The bounding boxes around the shapes are aligned, not the shapes
themselves. So if you align an arc and a circle to the top, the top of the
arc might not align with the top of the circle.

Grouping Shapes

The Group command lets you group shapes so you can apply commands
(such as Delete and Cut), actions (such as resizing or moving), and anima-
tions to them as if they were a single shape.
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Technical Note
Data entry shapes cannot be grouped.

To group shapes...

1. Choose the Selection command on the Shapes menu, or click on the Se-
lection tool on the Drawing Palette. This changes the cursor from cross
hairs (if you just finished drawing a shape) to a pointer.

2. Select the shapes you want to group.

Select the Group command on the Arrange menu or the Group button.
The selected shapes are “locked” together as one shape.

To ungroup grouped shapes, select the Ungroup command on the Arrange
menu or the Ungroup button, then click outside the bounding box. The
shapes revert to their individual status.

Caution

If you ungroup a group of shapes that are animated, the animations will
be deleted.

Ordering Shapes

As shapes are created, they are stacked in the order they are placed. This
concept is not obvious unless shapes overlap each other.

To change the order in which shapes are stacked, use the Order command on

the Arrange menu. This command accesses a submenu of five commands, as
defined in Table 6-9.
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Table 6-9. Order Commands

Order Command

Definition

Bring to Front

Places the selected shape on top of
all shapes on the screen

Laf Send to Back

Places the selected shape below all
shapes on the screen

Bring Forward

Places the selected shape on top of
the shape above

Push Backward

Pushes the selected shape below
the shape underneath

You can only apply the Order command to one shape at a time.

Technical Note

Transforming Shapes

You can change the appearance and orientation of shapes by applying the
following transformations:

e Size
e Rotate
e Flip

Sizing Shapes

Once a shape has been selected, a bounding box with handles surrounds it.
The handles are used to resize the shape.

To resize shapes...

1. Choose the Selection command on the Shapes menu, or click on the Se-
lection tool on the Drawing Palette. This changes the cursor from cross
hairs (if you just finished drawing a shape) to a pointer.
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Position the pointer over one of the sizing handles. The pointer changes
into an arrow. You can now resize the selected shape in the direction of
the arrow heads.

Press and hold the left mouse button, then drag the handle until the
shape is the desired size.

Release the left mouse button to resize the shape.

Rotating Shapes
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You can rotate shapes once they have been placed on the development sys-
tem screen. This rotation only affects shapes on the development system. To
rotate shapes during run-time, refer to Chapter 7, Animating Shapes.

You cannot rotate, data entry shapes, touch zones, text, and bitmaps.

Technical Note

To rotate shapes...

1.

Choose the Selection command on the Shapes menu, or click on the Se-
lection tool on the Drawing Palette. This changes the cursor from cross
hairs (if you just finished drawing a shape) to a pointer.

Select the shape or shapes you want to rotate.

Select the Rotate command on the Arrange menu or the Rotate button.
The Rotate dialog box opens.

Choose the angle at which you would like to rotate the shape or shapes:
90, 180, or 270 degrees.

Click OK or press ENTER to rotate the selected shapes at the specified
angle.
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Flipping Shapes
You can flip shapes once they have been placed on the development system
screen. This action has no effect on shapes during run-time.
To flip shapes...

1. Choose the Selection command on the Shapes menu, or click on the Se-
lection tool on the Drawing Palette. This changes the cursor from cross
hairs (if you just finished drawing a shape) to a pointer.

2. Select the shape or shapes you wish to flip.

Technical Note

You cannot flip text or bitmaps. However, if they are part of a group
that is flipped, they will move with the group while retaining their
original orientation.

3. Select the Flip Horizontal command on the Arrange menu or the Flip
Horz. button to flip shapes from left to right.

or

4. Select the Flip Vertical command on the Arrange menu or the Flip Vert.
button to flip shapes from top to bottom.

The selected shapes are automatically flipped.

Positioning Shapes with the Arrow Keys
You can move a shape or selected shapes by using the arrow keys on your
keyboard.
To position a shape(s)...
1. Select the shape or shapes you want to move.
To move all shapes, choose Select All from the Edit menu. To move

some of the shapes, hold the SHIFT key down while selecting the shapes
you want to move.

2. Press an arrow key to move the shape(s) one pixel. To move the shape(s)
10 pixels, press the CTRL key while pressing an arrow key.
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Technical Note

If you have the snap-to-grid option turned on and you use the arrow

keys to move shapes, the snap-to-grid function is overridden.

Editing Shapes

6-46

Cut, copy, paste, and delete are basic operations you can perform on shapes
in SoftScreen.

To copy shapes...

1. Choose the Selection command on the Shapes menu, or click on the Se-
lection tool on the Drawing Palette. This changes the cursor from cross
hairs (if you just finished drawing a shape) to a pointer.

2. Select the shape or shapes you want to copy.

3. Select the Copy command on the Edit menu, the Copy button, or press
CTRL+C.

The selected shapes are copied to the Windows clipboard. Each shape is
saved on the clipboard with its associated animations (Scale, Rotate,
etc.) and properties (Fill Pattern, Line Style, etc.).

To cut shapes...

1. Choose the Selection command on the Shapes menu, or click on the Se-
lection tool on the Drawing Palette. This changes the cursor from cross
hairs (if you just finished drawing a shape) to a pointer.

2. Select the shape or shapes you want to cut.

3. Select the Cut command on the Edit menu, the Cut button, or press
CTRL+X.

The selected shapes are erased from the screen and placed on the Windows
clipboard. Each shape is saved with its associated animations (Scale, Rotate,
etc.) and properties (Fill Pattern, Line Style, etc.).
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@ To paste shapes...

Select the Paste command on the Edit menu, the Paste button, or press
CTRL+V.

The clipboard contents are placed on the screen . Objects are offset from the
location from which they were cut by 10 pixels to the right and to the bot-
tom. Each shape is placed with its associated animations (Scale, Rotate, etc.)
and properties (Fill Pattern, Line Style, etc.).

Saving Changes to a Screen

[ ..
o To save changes to a screen, you must save the current application. To do

this, select the Save Application command on the File menu or the Save Ap-
plication button in any of the tools. If you have not previously saved the
screen, refer to the section, Creating a New Screen, at the beginning of this
chapter. ’

Caution

Whenever you select Save Application, all changes to the application
are saved, not just changes made in the current tool.

Selecting a Startup Screen

In the development system, you can choose the screen you want to display
when the run-time system starts. If you do not specify a startup screen, an er-
ror will occur when you try to generate the application.

To specify a startup screen...

1. Inthe Application Navigator form, click on the Startup Screen drop-
down list box. This box provides a list of all the screens configured for
the current application.

2. Click on the screen you want to display upon run-time start-up.

Save the application.
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Printing Screens
There are three parts to printing a development system screen:

e Setting up the printer
e Previewing the screen you want to print

e Printing from the default printer

Setting up the Printer

Because SoftScreen uses the Windows Printer settings, you should only use
the Print Setup command if you want to change these settings or you want to
print from a printer other than the default. The Print Setup command on the
File menu accesses the Print Setup dialog box. The options in this dialog box
depend upon the selected printer.

Refer to your printer manual for more information on printer settings.

Previewing a Screen
You can view a screen exactly as it will look when printed, before sending it
to the printer.
To preview a screen before printing...

1. Select the Print Preview command on the File menu. The Print Preview
window opens with the screen displayed.

2. From this window, you can select the Zoom In button to better view the
screen. Once you have selected the Zoom In button, the Zoom Out but-
ton is activated, allowing you to return the view of the screen to its
original size (the Zoom In and Zoom Out buttons have no effect on the
size of the printed screen).

3. Select the Close button to close the Print Preview window and return to
the Graphic Editor window.
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Printing a Screen

Once you have chosen a printer and specified its settings in the Print Setup
dialog box, you are ready to print.

To print the current screen...

1. Select the Print command on the File menu, the Print button, or the Print
button in the Print Preview window.

2. The Print dialog box appears. The options in this dialog box depend
upon the default printer you have selected.

3. Click OK or press ENTER to send the screen to the printer. SoftScreen
will print a graphical image of the shapes on the screen. If the Target
front panel is displayed, it will also print.

Deleting a Screen

The Application Navigator form is the only place from which you can delete
screens.

Technical Note

You cannot delete the Master Template.

To delete a screen...

1. Select Screens from the Graphic drop-down list box on the Application
Navigator form.

2. Select the screen you want to delete from the accompanying list box.

3. Select the Delete command on the Edit menu to delete the screen.

Technical Note

You cannot use the DEL key to delete a screen. The DEL key can be
used to delete characters in the screen name, not the screen itself.
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Chapter 7 — Animating Shapes

This chapter defines SoftScreen animations. Animations are dynamic prop-
erties that are configured on the development system and applied to shapes
during run-time. They allow you to animate shapes in your applications, us-
ing them to emulate real-life processes and I/O.

There are two types of animations: spatial and non-spatial.

e Spatial animations (such as rotate or position) change a shape’s (or
group of shapes”) location or orientation.

e Non-spatial animations (such as foreground color or line width) do not
change a shape’s location or orientation. They just change a shape’s (or
group of shapes’) appearance.

Technical Note

Multiple animations can be applied to a single shape, allowing a vari-
ety of capabilities.

Using Animation Pages

Every animation provides a page in which you specify the its parameters.
Table 7-1 defines the fields available on every animation page.
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Table 7-1. Fields on the Animation Page
Field Definition

Tag Name | Specifies a tag name for the animation. You can type in
an existing tag name or you can specify a new tag name.
If you specify a new tag name, you must define it in the
Data Editor before you download the application. Refer
to Chapter 3 for more information on configuring tags.
Note: Tag Name Type Ahead feature allows you to lo-
cate existing tag names. As you type in each character
of a tag name, the tag name edit box is filled with the
closest match to the defined tag name.

Add Adds the configured animation to the list box.
Remove Removes the selected animations.
Order Accesses the Animations Ordering dialog box, allowing

you to alter the order in which all animations are applied
to a shape (a shape can be an individual shape or a
group of shapes).

Technical Note

Fields in animation pages requiring data point minimums and maxi-
mums will accept IEEE 32-bit floating point values.

Applying Non-spatial Animations

Non-spatial animations are conditional. They occur when the attached tag is
true (or non-zero). They differ from spatial animations in that they do not
change location or orientation. Also, you cannot combine non-spatial ani-
mations of the same type because only the last animation that evaluates true
will be applied to the shape.

For example, if you configure an animation to apply a blue background color
to a shape and another animation to apply a yellow background color to the
same shape, the shape will not turn green. Instead, the last animation that
evaluates to true will take effect (refer to Chapter 3, Configuring Tags, for
information on how tags are evaluated).

Non-spatial animations are Background Color, Foreground Color, Line
Color, Line Width, Line Type, Fill Pattern, Text, and Visibility.
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Technical Note

Non-spatial animations applied to an individual shape in a group take
precedence over non-spatial animations of the same type applied to the
group. For example, apply a background color animation to a shape.
Next, group that shape with other shapes and apply a background color
animation to the group. During run-time, the individual shape will re-
tain its background color animation and it will take precedence when
both the individual shape’s and the group’s background color anima-
tions are true.

You cannot apply certain non-spatial animations to all shapes. Table 7-2 de-
fines which non-spatial animations apply to which shapes.

Table 7-2. Non-spatial Animations

Shape Background Foreground Line Line Width | Line Fill Pattern | Text Visibility
Color Color Color Type

Line X X X X

Polyline X "X X X

Square X X X X X X X

Rectangle X X X X X X X

Polygon X X X X X X X

Circle X X X X X X X

Ellipse X X X X X X X

Pie X X X X X X X

Arc X X X X X X X

Text X X X X

Touch zone

Data entry

Data display X X

Bitmap X

Foreground, Background, and Line Color

SoftScreen lets you animate foreground, background, and line colors. If you

apply a color animation to a shape, the shape’s color will change during run-
time when the attached tag is true (or non-zero). Refer to Chapter 3, Config-
uring Tags, for information on how tags are evaluated.
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To animate color...
1. Select the shapes whose color you want to animate.

2. Select the Animations command on the Edit menu or the Animations
button to open the Shape Animations form.

3. Choose the Background Color, Foreground Color, or Line Color tab, de-
pending on which you want to animate. The corresponding page will
display. For example, if you choose the Background Color tab, the
Background Color animations page will display, as shown in Figure 7-1.

Shape Animations

Figure 7-1. Background Color Animation Page

4. Type the tag name to which you want to link the animation in the Tag
Name text box.

5. Select the color which you want the shape to change into from the Color
drop-down list box.

Click Add to add the animation to the list box.
7. Click OK or press ENTER to apply the animation.
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Line Width

If you apply a line width animation to a shape, the shape’s line width will
change during run-time when the attached tag is true (or non-zero). Refer to
Chapter 3, Configuring Tags, for information on how tags are evaluated.

To animate a shape’s line width...

1.

Select the shape or group of shapes whose line width you want to ani-
mate.

Select the Animations command on the Edit menu or the Animations
button to open the Shape Animations form.

Choose the Line Width tab to access the Line Width animation page, as
shown in Figure 7-2.

Figure 7-2. Line Width Animation Page

In the Tag Name text box, type the name of the tag to which you want to
link the animation.

Select a line width from the Width drop-down list box.
Click Add to add the animation to the list box.
Click OK or press ENTER to apply the animation.
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Line Type

If you apply a line type animation to a shape, the shape’s line type will
change during run-time when the attached tag is true (or non-zero). Refer to
Chapter 3, Configuring Tags, for information on how tags are evaluated

To animate a shape’s line type...

1. Select the shape or group of shapes whose line type you want to ani-
mate.

2. Select the Animations command on the Edit menu or the Animations
button to open the Shape Animations form.

3. Choose the Line Type tab to access the Line Type animation page, as
shown in Figure 7-3.

Shape Animations

Figure 7-3. Line Type Animation Page

4. Inthe Tag Name text box, type the name of the tag to which you want to
link the animation.

Select a line type from the Type drop-down list box.
6. Click Add to add the animation to the list box.
Click OK or press ENTER to apply the animation.
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Fill Pattern

If you apply a fill pattern animation to a shape, the shape’s fill pattern will
change during run-time when the attached tag is true (or non-zero). Refer to
Chapter 3, Configuring Tags, for information on how tags are evaluated.
move to top of section

To animate a shape’s fill pattern...

1. Select the shape or group of shapes whose fill pattern you want to ani-
mate.

2. Select the Animations command on the Edit menu or the Animations
button to open the Shape Animations form.

3. Choose the Fill Pattern tab to access the Fill Pattern animation page, as
shown in Figure 7-4.

Figure 7-4. Fill Pattern Animation Page

4. Inthe Tag Name text box, type the name of the tag to which you want to
link the animation.
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Text

5. Select a fill pattern from the Pattern text box. If you select pattern 1, the
shape will contain a solid foreground color. If you select 2, the shape
will contain a solid background color. If you select 3 through 32, the
shape will contain a pattern of foreground and background colors, which
are set in the Shape Properties form (refer to the section Applying Shape
Properties in Chapter 6 for more information on setting shape colors).

6. Click Add to add the animation to the list box.
7. Click OK or press ENTER to apply the animation.

To animate text, you must select the Animated Type option on the Text
properties page. For more information on specifying text properties, refer to
the Creating Text Boxes section in Chapter 6.

If you apply a text animation to a text box, the message will display during
run-time when-the attached tag is true (or non-zero). Refer to Chapter 3,
Configuring Tags, for information on how tags are evaluated.

To animate text...

1. Select the text box whose text you want to animate.

2. Select the Animations command on the Edit menu or the Animations
button to open the Shape Animations form.

3. Select the Text tab to access the Text animation page, as shown in
Figure 7-5.
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Figure 7-5. Text Animation

4. Inthe Tag Name text box, type the name of the tag to which you want to
link the animation.

5. Type the message you want to display.

Technical Note

Although you can type in all the ASCII characters on the development
system, the run-time engine will only display ASCII characters from
20h (32 decimal) to 7Eh (126 decimal).

On the 3100 engine, you are able to display up to 40 characters in 8 and
12 point type; 20 characters in 24 point type; and 10 characters in 48
point type. On the 3200 and 3300, you are able to display 80 characters
in 8 and 12 point type; 40 characters in 24 point type; and 20 characters
in 48 point type.

6. Click Add to add the animation to the list box.
7. Click OK or press ENTER to apply the animation.
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Visibility

If you apply a visibility animation to a shape, during run-time the animated
shape will be invisible when the attached tag is false (zero) and visible when
the attached tag is true (non-zero). If you select the blink option, the shape
will blink when the attached tag is true (or non-zero) and will not blink (but
it will be visible) when the tag is false (zero). Refer to Chapter 3, Configur-
ing Tags, for information on how tags are evaluated.

To make a shape blink or change its visibility...

1. Select the shape or group of shapes that you want to make blink or
whose visibility you want to change.

2. Choose the Animations command on the Edit menu to open the Shape
Animations form.

3. Click on the Visibility tab to access the Visibility animation page, as
shown in Figure 7-6.

Figure 7-6. Visibility Animation Page

4. Inthe Tag Name text box, type the name of the tag to which you want to
link the animation.

5. To change the shape’s visibility, click Add to add the animation to the
list box.

7-10
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To make the shape blink, select the Blink option, and then click Add.

The shape will blink every second.

6. Click OK or press ENTER to apply the animation.

Applying Spatial Animations

Spatial animations cause a shape, or group of shapes, to change location or
orientation. When you apply more than one spatial animation of the same
type to a shape or group of shapes, they are combined (except for fill percent

animations).

For example, if you apply an animation that rotates a shape 5° and then ap-
ply another animation that rotates the same shape 10°, the shape will rotate

15°.

You cannot apply certain spatial animations to all shapes. Table 7-3 defines
which spatial animations apply to which shapes.

Caution

unpredictably during run-time.

Do not apply a spatial animation to a group that includes a shape to
which the animation does not apply. If you do, that shape will behave

Table 7-3. Spatial Animations

Shape Fill % Sweep Angle

Position

Scale

Rotate

Line

X

Polyline

Square

Rectangle

Polygon

X
X
X
X

Circle

Ellipse

X | X | X | X|X]|X

Pie

Arc X

X | X | X | X | X]|X|X]|X]|X

Text/Data Dis-
play

X I X | XX | X]|X|X|X]|X]|Xx

Touch zone
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Shape Fill % Sweep Angle Position Scale Rotate
Data entry
Bitmap X X

Fill Percent

712

If you apply a fill percent animation to a shape, during run-time the shape
will fill incrementally from the minimum fill percentage when the attached
tag is less than or equal to the minimum data point value. It will continue to
fill until it reaches the maximum fill percentage when the attached tag is
greater than or equal to the maximum data point value.

Fill Percent animations do not combine. Instead, when you apply more than
one fill percent animation to a shape, the last animation in the list will be ap-
plied to the shape; all others will be ignored.

To animate a shape’s fill percent...

1. Select the shape or group of shapes whose fill percent you want to ani-
mate.

2. Select the Animations command on the Edit menu or the Animations
button to open the Shape Animations form.

3. Select the Fill Percent tab to access the Fill Percent animation page, as
shown in Figure 7-7.

166




Chapter 7 — Animating Shapes

b

Figure 7-7. Fill Percent Animation Page

Type the name of the tag to which you want to link the animation in the
Tag Name text box.

In the Direction drop-down list box, choose the direction in which you
want to the shape to fill: Right, Left, Up, or Down. The default is Right.

Type a minimum data point value in the Minimum Data Point Value text
box.

Specify a percentage from 0 to 100 in the Minimum Fill text box. This
sets the percentage of the shape that will be filled when the attached tag
is less than or equal to the minimum data point value.

A fill percent applied to a pie may behave differently than you expect.
This is because a fill percent animation applied to a pie is based on the
size of the bounding rectangle, not the size of the pie.

Figure 7-8 illustrates this. It shows how a fill percent of 60% is applied
to two different pies that have the same size bounding rectangle.

7-13
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100%

0%

Figure 7-8. Fill Percent Example

8. Type a maximum value in the Maximum Data Point Value text box.

9. Specify a percentage from 0 to 100 in the Maximum Fill text box. This
sets the percentage of the shape that will be filled when the attached tag
is greater than or equal to the maximum data point value.

For example, if you set this value to 75%, 75% of the shape will be
filled when the attached tag is greater than or equal to the maximum data
point value.

10. Click Add to add the animation to the list box.
11. Click OK or press ENTER to apply the animation.

Sweep Angle

7-14

If you apply a sweep angle animation to a shape, during run-time, the shape
will sweep incrementally from the minimum angle when the attached tag is
less than or equal to the minimum data point value. It will continue to sweep
until it reaches the maximum angle when the attached tag is greater than or
equal to the maximum data point value.

To apply a sweep angle animation...

1. Select the shape or group of shapes to which you want to apply a sweep
angle animation.

2. Choose the Animations command on the Edit menu to open the Shape
Animations form.

3. Click on the Sweep Angle tab to access the Sweep Angle animation
page, as shown in Figure 7-9.
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Starting point

i i

Figure 7-9. Sweep Angle Animation Page

Type the name of the tag to which you want to link the animation in the
Tag Name text box.

In the Point to Sweep drop-down list box, choose Starting point or End-
ing point. This is the edge of the pie or arc that will change its angle.

Starting point is the first edge set when drawing the arc or pie. Ending
point is the last edge set.

Type the minimum data point value in the Minimum Data Point Value
text box.

Specify a number from -32768 to +32767 in the Minimum Angle text
box. This sets the offset from the shape’s original angle—either from the
starting or ending point (refer to Step 5)—at which the shape will sweep
when the attached tag is less than or equal to the minimum data point
value.

For example, suppose you specify starting point as the point to sweep
and -12° in the Minimum Angle text box. The shape will sweep -12°
from its original starting point when the value of the attached tag is less
than or equal to the minimum data point value.

Type the maximum data point value in the Maximum Data Point Value
text box.
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169



SoftScreen Development System for Windows User’s Guide

Position

7-16

9.

Specify a number from -32768 to +32767 in the Maximum Angle text
box. This sets the offset from the shape’s original angle—either from the
starting or ending point (refer to Step 5)—at which the shape will sweep
when the attached tag is greater than or equal to the maximum data point
value.

For example, suppose you specify starting point as the point to sweep
and 250° in the Maximum Angle text box. The shape will sweep 250°
from its original starting point when the attached tag is greater than or
equal to the maximum data point value.

10. Click Add to add the animation to the list box.
11. Click OK or press ENTER to apply the animation.

If you apply a position animation to a shape, during run-time the shape will
move incrementally from the minimum X and Y offsets when the attached
tag is less than or equal to the minimum data point value. It will continue to
move across the screen until it reaches the maximum X and Y offsets when
the attached tag is greater than or equal to the maximum data point value.

To change a shape’s position...

1.
2.

Select the shape or group of shapes whose position you want to change.

Select the Animations command on the Edit menu or the Animations
button to open the Shape Animations form.

Select the Position tab to access the Position animation page, as shown
in Figure 7-10.
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ions

Figure 7-10. Position Animation Page

4. Type the name of the tag to which you want to link the animation in the
Tag Name text box.

5. Type the minimum data point value in the Minimum Data Point Value
text box.

6. Specify a number from -32768 to +32767 in the Minimum X and Y text
boxes. This sets the offset from the shape’s original location at which
the shape will be when the attached tag is less than or equal to the mini-
mum data point value.

These numbers are relative, not absolute. For example, if the shape is
originally drawn at X=114 and Y=168, and you specify -32 as the mini-
mum X and Y, the shape will be located at X=82, Y=136 when the at-
tached tag is less than or equal to the minimum data point value.

Technical Note

If you apply a position animation to a group of shapes, the offset ap-
plies to the X and Y coordinates of the group, not the individual
shapes.

7. Type the maximum data point value in the Maximum Data Point Value
text box.
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Scale

718

8. Specify a number from -32768 to +32767 in the Maximum X and Y text
boxes. This sets the offset from the shape’s original location at which
the shape will be when the attached tag greater than or equal to the
maximum data point value.

These numbers are relative, not absolute. For example, if the shape is
originally drawn at X=114 and Y=168, and you specify 50 as the maxi-
mum X and Y, the shape will be located at X=164, Y=218 when the at-
tached tag is greater than or equal to the maximum data point value.

Technical Note

If you apply a position animation to a group of shapes, the offset ap-
plies to the X and Y coordinates of the group, not the individual
shapes.

9. Click Add to add the animation to the list box.
10. Click OK or press ENTER to apply the animation.

If you apply a scale animation to a shape, during run-time the shape will
scale incrementally from the minimum X and Y percentages when the at-
tached tag is less than or equal to the minimum data point value. The shape
will continue to scale until it reaches the maximum X and Y percentages
when the attached tag is greater than or equal to the maximum data point
value.

Technical Note

Although scale animations are combined when applied to the same
shape, a shape will never scale greater than its original size. For exam-
ple, if you scale a shape 50%, then scale it 75%, it will not scale to
125% of its original size. Instead, the shape will scale to 50% of its
original size, and then it will scale to 75% of the 50% size.

To scale a shape...

1. Select the shape or group of shapes that you want to scale.
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2. Select the Animations command on the Edit menu or the Animations
button to open the Shape Animations form.

3. Select the Scale tab to access the Scale animation page, as shown in
Figure 7-11.

Figure 7-11. Scale Animation Page

4. Type the name of the tag to which you want to link the animation in the
Tag Name text box.

5. In the Reference drop-down list box, choose the point around which you
want the shape to grow and shrink: Top Left, Top Right, Center, Bottom
Left, Bottom Right, or Custom (Center is the default).

If you select Custom, you must also specify a number from -32768 to
+32767 in the X and Y text boxes. This is an absolute point, around
which the shape grows or shrinks.

Technical Note

If you apply a scale animation to a group of shapes, the reference point
is in relation to the group, not the individual shapes.

Figure 7-12 provides an example of how a different reference point can
affect the way a shape displays during run-time. In this example, the
rectangles on the left indicate how they were drawn on the development

7-19
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7-20

system. Both rectangles have the same scale settings: minimum X and Y
are 0% and maximum X and Y are 50%. The only difference is the ref-
erence point. The top rectangle’s reference is Top Right; the bottom
rectangle’s reference is Bottom Left. The rectangles on the right (with
the thicker outline) indicate how the rectangles will look after the scale
animation has reached 50% during run-time. The dotted lines around the
left rectangles indicate the size and location of the original rectangles.

Top Right

Top Right

Bottom Left Bottom Left

Figure 7-12. Scale Example with Different Reference Points

Type the minimum data point value in the Minimum Data Point Value
text box.

Specify a percentage from 0 to 100 in the Minimum X and Y text boxes.
This determines the shape’s size, as a percentage of its original size,
when the attached tag is less than or equal to the minimum data point
value.

For example, if you specify 10% as the minimum X and Y, the shape
will be 10% of its original size when the attached tag is less than or
equal to the minimum data point value.

Type the maximum data point value in the Maximum Data Point Value
text box.

Specify a percentage from 0 to 100 in the Maximum X and Y text boxes.
This determines the shape’s size, as a percentage of its original size,
when the attached tag is greater than or equal to the maximum data point
value.

For example, if you specify 75% for the maximum X and Y, the shape
will be 75% of its original size when the attached tag is greater than or
equal to the maximum data point value.

10. Click Add to add the animation to the list box.
11. Click OK or press ENTER to apply the animation.
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Rotate

If you apply a Rotate animation to a shape, during run-time the shape will
rotate incrementally from the minimum angle when the attached tag is equal
to the minimum data point value until it reaches the maximum angle when
the attached tag is equal to the maximum data point value. The tag will re-
main at the minimum angle if the data point value is less than the minimum,
and it will remain at the maximum angle if the data point value is greater
than the maximum.

Technical Note

When you apply a rotate animation to a bitmap, data display, or static
text shape, it will only affect its position, not its orientation.

To rotate a shape...
1. Select the shape or group of shapes that you want to rotate.

2. Choose the Animations command on the Edit menu to open the Shape
Animations form.

3. Click on the Rotate tab to access the Rotate animation page, as shown in
Figure 7-13.

Figure 7-13. Rotate Animation Page
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4. Type the name of the tag to which you want to link the animation in the
Tag Name text box.

5. In the Reference drop-down list box, choose the point around which you
want the shape to rotate: Top Left, Top Right, Center, Bottom Left,
Bottom Right, or Custom (Center is the default).

If you select Custom, you must also specify a number from -32768 to
+32767 in the X and Y text boxes. This is an absolute point, around
which the shape rotates.

Technical Note

If you apply a rotate animation to a group of shapes, the reference
point is in relation to the group, not the individual shapes.

Figure 7-14 provides an example of how a different reference point can
affect the way a shape displays during run-time. In this example, the
rectangle with the thick border indicates how the rectangle was drawn on
the development system. The rectangle is set to a 0° minimum angle
and a 50° maximum angle. The gray rectangle indicates how the rectan-
gle will look after the rotate animation has reached 50° when the refer-
ence is set to Top Left. The white rectangle indicates how the same rec-
tangle will look when the reference is set to Center.

Figure 7-14. Rotate Example with Different Reference Points

6. Type the minimum data point value in the Minimum Data Point Value
text box.
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7. Specify a number from -32768 to +32767 in the Minimum Angle text
box. This sets the offset from the shape’s original angle at which the
shape will rotate when the attached tag is less than or equal to the mini-
mum data point value.

For example, if you enter 10° in the Minimum Angle text box, the shape
will rotate 10° in a counterclockwise direction from its original position
when the attached tag is less than or equal to the minimum data point
value.

Technical Note

Positive angles rotate counterclockwise. Negative angles rotate clock-
wise.

8. Type the maximum data point value in the Maximum Data Point Value
text box.

9. Specify a number from -32768.to +32767 in the Maximum Angle text
box. This sets the offset from the shape’s original angle at which the
shape will rotate when the attached tag is greater than or equal to the
maximum data point value.

For example, if you enter 250° in the Maximum Angle text box, the
shape will rotate 250° in a counterclockwise direction from its original
position when the attached tag is greater than or equal to the maximum
data point value.

10. Click Add to add the animation to the list box.
11. Click OK or press ENTER to apply the animation.

Technical Note
A shape’s fill pattern will not rotate.
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Ordering Animations

Every animation page has an Order button, which accesses the Animations
Ordering dialog box, as shown in Figure 7-15.

Animations Or ng

Visibility Pump_ON  Blink
Line Color Color [ (253)

Figure 7-15. Animations Ordering Dialog Box

You can select multiple items in this dialog box. The Move Up button al-
lows you to move selected animations up in the list; Move Down allows you
to move them down; and Remove deletes selected animations.

Ordering Non-spatial Animations

If you apply more than one non-spatial animation of the same type to a
shape, the last one that evaluates to true (non-zero) will occur. If you apply
more than one non-spatial animation of different types to a shape, they will
all occur when they evaluate to true (non-zero) because they are mutually
exclusive. However, you might not always be able to “see” an animation.

For example, if you apply an animation that changes a shape’s fill pattern to
solid background (pattern 1)and you apply an animation to the same shape
that animates the foreground color, you will not see the foreground color
animation take place (although it does) because foreground color does not
apply when the pattern is a solid background.
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Ordering Spatial Animations

The order of spatial animations that can be combined (scale, position, and
rotate) may have a pronounced effect on how a shape behaves during run-
time. For example, a shape may behave one way if you apply a scale anima-
tion and then a position animation and it may behave another way if you ap-
ply a position animation and then a scale animation. It depends on the ani-
mation parameters that are set.

Technical Note

Because the rotate animation does not apply to all shapes, it is always
applied to a shape after all scale and position animations are applied.
However, rotate animations retain their order among themselves.
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Working with Symbols

Symbols allow you to create and save predefined shapes, along with their as-
sociated event/actions and animations, which can then be inserted in multi-
ple applications. SoftScreen comes with symbol libraries—which include
such things as push buttons, switches, and pilot lights.

Refer to Chapter 4 for examples of using symbols in an application.

Customizing the Symbol Palette

The Symbol Palette is a user-configurable toolbar that comes configured
with predefined symbols. As you create symbols, you can add them to the
Symbol Palette.

To add symbols to the Symbol Palette...

1. Select the Customize Symbol Palette command on the Options menu.
The Customize Symbol Palette dialog box displays as shown in
Figure 8-1.

8-1
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Figure 8-1. Customize Symbol Palette Dialog Box

2. Select a symbol group, click on the checkboxes of the symbols you want
to add to the palette, and then click OK. The symbols are then added to
the Symbol Palette, which you can open using the Symbol Palette com-
mand on the View menu.

Inserting Symbols

In your applications, you can insert graphic symbols and constant, string,
and expression symbols that you create, as well as predefined symbols that
come with SoftScreen.

To insert graphic symbols using the symbol palette...
1. Open the screen on which you want to insert a symbol.

2. Select the Symbol Palette command on the View menu to open the
Symbol Palette, shown in Figure 8-2.
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alette

T———

Figure 8-2. Symbol Palette Window

3. Click on the symbol, and, while holding down the left mouse button,
drag it over the screen, then release the mouse button.

To insert graphic symbols...
1. Open the screen on which you want to insert a symbol.

2. Select the Insert Symbol command on the Symbol menu in the Graphic
Editor or click on the Insert Symbol button. The Insert Symbol dialog
box opens, as shown in Figure 8-3.

Insert Syrmnbol

_butterfly_valve
_check_valve
_compressor
_conveyor
cyclone_separator

Figure 8-3. Insert Symbol Dialog Box
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8-4

This dialog box will only display graphic symbols and graphic symbol
groups.

The following are some guidelines you must follow when inserting a
symbol.

e Data entry shapes and touch zones cannot be inserted on recipe or
alarm screens.

o Data entry shapes cannot be inserted if a data entry with the same
name already exists in the application.

e Data entry shapes cannot be inserted on the Master Template.

e Data points, including touch zones, cannot be inserted on a screen if
a data point, or touch zone, with the same name, but a different
value or different type, already exists in the application.

e Touch zones cannot be inserted in an application that is not config-
ured for a target workstation with a touch screen.

e If a group of shapes contains a touch zone and a touch zone cannot
be inserted on a screen (because the target engine isn’t configured
for a touch screen or a touch zone with the same name already exists
in the application), the group of shapes will not be inserted.

Click on the tab of the group that contains the symbol you want to insert.
A list of the symbols in the selected group appear in the Symbol Names
list box.

Click on the name of the symbol you want to insert. A preview of the
symbol appears in the Preview box. A description, if the symbol has one,
appears in the Description text box.

Due to sizing constraints, some small symbol details may not be visi-
ble in the Preview box.

Technical Note

To insert the symbol, click OK or press ENTER. The symbol is inserted
in the same location in which it was it was created. If you try to insert a
symbol that is not allowed to be inserted (see Step 2), you will receive a
message that tells why the symbol was not inserted.
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6.

If the symbol references unresolved tags, the Resolve Tag Names dialog
box opens, as shown in Figure 8-4. Unresolved tags are tags that refer-
ence a device data point. They are considered unresolved because device
data points are not saved with the symbol.

Figure 8-4. Resolve Tag Names Dialog Box

This dialog box allows you to rename unresolved tags assigned to a
symbol. You must define a tag to duplicate what the tag attached to the
symbol does, or rename the tag and tie it to the appropriate data points.

To rename a tag, select it from the Current drop-down list box, and then
type a unique name in the New text box. If you need to rename a touch
zone to avoid a conflict, select it from the Current drop-down list and
type a unique touch zone name in the New text box.

After you have finished renaming tags, click OK or press ENTER to ac-
cept the new tag names.

If you insert a symbol that incorporates data points with the same name,
of the same type (expressions, constants, strings, recipes, alarms, etc.),
but different values than the ones currently defined in your application,
the Data Point Conflict dialog box will display, as shown in Figure 8-5.

8-5
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f Data Point Conflict

Figure 8-5. Data Point Conflict Dialog Box

This dialog box indicates the value of the data point in the application
and in the symbol, and allows you to choose whether to replace or keep
the existing value. Table 8-1 describes the choices in this dialog box.

Table 8-1. Data Point Conflict Dialog Box Options

Button

Description

Replace

Replaces the data point value in the application when it is in con-
flict with a data point value in the symbol. If there is more than one
data point in conflict, data points will continue to appear in the dia-
log box after you press Replace until you’ve replaced, or skipped,
them all.

Replace All

Replaces the data point values in the application when they are in
conflict with data point values in the symbol. If you select this op-
tion, you will be unable to view all conflicting data points before you
replace them.

Skip

Keeps the data point value in the application when it is in conflict
with a data point value in the symbol. If there is more than one data
point in conflict, data points will continue to appear in the dialog
box after you press Skip until you've skipped, or replaced, them all.

Skip All

Keeps the data point values in the application when they are in
conflict with data point values in the symbol. If you select this op-
tion, you will be unable to view all conflicting data points before you
skip them.

Cancel

Cancels symbol insertion.
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To insert constant, string, or expression symbols...

1. Open the constant, string, or expression data editor in which you want to
insert a symbol.
2. Select the Insert Symbol command on the Symbol menu.
Click on the symbol you want to insert.
4. Click OK or press ENTER to insert the symbol.
Creating Symbols

You can create graphic symbols, as well as constant, string, and expression
symbols.

To create a graphic symbol...

1.

2.
3.
4

Create a shape or shapes in the-graphic editor.
Apply the necessary properties and animations.
Select the shape(s).

Select the Create Symbol command from the Symbol menu or click on
the Create Symbol button. The Create Symbol dialog box opens, as
shown in Figure 8-6.

reate S ymbol

ISA Symbol Library
Meters
Push Buttons

Figure 8-6. Create Symbol Dialog Box
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5. Type a unique symbol name in the Name text box. This name is used to

identify the symbol.

The names of symbols shipped with SoftScreen begin with an under-
score. To avoid overwriting symbols, do not begin symbol or group
names with an underscore.

Caution

In the Groups list box, select the name of the group in which you want to
place the symbol.

or

If you want to create a new symbol group, click on the Create Group
button, type the name of a new group in the Group Name text box, and
then click OK.

Type a description of the symbol in the Description text box. Use this
feature to describe the symbol’s functions and purpose. A good descrip-
tion should include what the symbol does, how it works, and where it
can be used.

Click OK or press ENTER. If there are no unresolved tags associated
with the symbol, it is added to the symbol library along with any associ-
ated animations, properties, and event/actions.

Unresolved tags are tags that reference a device data point. They are
considered unresolved because device data points are not saved along
with the symbol. Therefore, when you insert a symbol that includes tags
that reference a device data point, you must define a tag to duplicate
what the tag attached to the symbol does, or rename the tag and tie it to
the appropriate data points.

If unresolved tags are associated with the symbol, the Set Tag Name
Notes dialog box opens, as shown in Figure 8-7.
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Figure 8-7. Set Tag Name Notes dialog box

This dialog box allows you to describe the tags assigned to a symbol.
This is important because symbols are saved with tags, but device data
points are not saved. When you insert a symbol that includes tags, the
default tag is used (which is no longer attached to a data point). The de-
scription, if filled out properly, allows you to remember what the tag
controls in the symbol.

So you must configure data points in your application to duplicate the
actions of the tags assigned to the symbol, or you must rename the tags
and ensure they reference the appropriate data points in the application
in which the symbol is inserted.

10. Click OK or press ENTER to save changes to the tags and add the symbol
to the symbol library. All associated animations, properties, and
event/actions are saved along with the symbol.

To create a constant, string, or expression symbol...

Open the constant, string, or expression data editor.

2. Select the constants, strings, or expressions you want to save as a sym-
bol. You can select as many as you like.

3. Select the Create Symbol command on the Symbol menu or click the
Create Symbol button. The Create Symbol menu opens, as shown in
Figure 8-8.
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Figure 8-8. Create Symbol Dialog Box for Constants

Only those groups containing the same type of symbols will appear in
the Groups box. For example, if you are creating a constant symbol, only
constant symbol groups will appear in the Create Symbol dialog box.
Any graphic, string, or expression symbol groups you have created will
not be visible.

Type a unique symbol name in the Name text box. This name is used to
identify the symbol.

Caution

The names of symbols shipped with SoftScreen begin with an under-
score. To avoid overwriting symbols, do not begin symbol or group
names with an underscore.

5.

In the Groups list box, select the name of the group in which you want to
place the symbol.

or

If you want to create a new symbol group, click on the Create Group
button, type the name of a new group in the Group Name text box, and
then click OK.
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6. Type a description of the symbol in the Description text box. Use this
feature to describe the symbol’s functions and purpose. A good descrip-
tion should include what the symbol does, how it works, and where it
can be used.

7. Click OK or press ENTER. The Set Tag Name Notes dialog box displays,
as shown in Figure §-9.

Set Tag Name Notes

Figure 8-9. Set Tag Name Notes Dialog Box

8. Use this dialog box to provide a description of the tag name attached to
the symbol.

9. Click OK to save the symbol along with the tag name description.
To change properties of a shape within a symbol...

1. Ungroup the symbol and select the shape whose properties you want to
change.

2. Make the changes and then regroup after your are finished.

Deleting Symbols and Symbol Groups

SoftScreen allows you to delete symbols and symbol groups.

8-11
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Caution
If you delete a symbol, you cannot use the Undo command to retrieve
it.
To delete a symbol...

1. Select the Delete Symbols command on the Symbol menu in the Graphic
Editor or click on the Delete Symbols button. The Delete Symbol dialog
box opens, as shown in Figure 8-10.

Delete Symbol

[T agitator
~]_blower
_butterfly_valve
[1_check_valve
[—]_compressor

Figure 8-10. Delete Symbol Dialog Box

2. Click on the tab that identifies the symbol group in which the symbols
you want to delete are saved.

3. Inthe Symbol Names list box, click in the checkbox of the symbols you
want to delete.

8-12
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4. Click the Delete Symbol button. A message box displays, asking if you
still want to delete the symbols. Click Yes if you want to delete the
symbol(s), No if you do not. (Deleting symbols cannot be undone.)

5. If you want to delete other symbols, select the symbol group and repeat
steps 3 through 5.

6. Click Close when you finish deleting symbols.
To delete a symbol group...

1. Select the Delete Symbols command on the Symbol menu in the Graphic
Editor or click on the Delete Symbols button. The Delete Symbol dialog
box opens, as shown in Figure 8-11.

Delete Symbol

Figure 8-11. Delete Symbol Dialog Box

2. Click on the tab that identifies the symbol group that you want to delete.
You must delete all symbols in the symbol group before you can delete
the group. Refer to the previous section for information on how to delete
symbols.
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3. Once you have deleted all symbols in the group, click the Delete Group
button to delete the symbol group. When you delete a symbol group, the
tab is removed from the dialog box.

Technical Note
If you delete the last group, the dialog box automatically closes.

4. Repeat steps 2 and 3 to delete additional symbol groups.
5. Click Close when you have finished deleting symbol groups.

Working with Templates

Templates allow you to create and save predefined screens, alarms, recipes,
strings, expressions, and constants, which can then be inserted in other ap-
plications. SoftScreen comes with default templates for screens, alarms, and
recipes. ’

Refer to Chapter 4 for examples of using templates in an application.

Creating New Screen, Recipe, and Alarm Templates

In this section, templates refer to a screen, recipe or alarm object. From the
Application Navigator you can create new templates for screens, recipes or
alarms by using the default template. This is a convenient way to create a
starting point for a new screen, recipe or alarm.

1. From the Application Navigator, select Screens, Recipes or Alarms from
either the Graphic or Data drop-down list box.

2. Type a new name in either the Graphic or Data text box and press
ENTER.

3. Select the Create Template command from the Symbol menu. The Cre-
ate Template dialog box opens, as shown in Figure 8-12.
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Figure 8-12. Create Template From Dialog Box

6. Click on the Name you want to create as a template (so it appears in the
Name text box).

7. Type a unique name in the Template Name text box.

Type a description of the template in the Description text box. Use this
feature to describe what the screen looks like.

9. Click OK or press ENTER to save the template.

Creating New Objects from Templates

You can create a new object from any existing template.

To create an object from the Graphic Editor tool...

1. Select the Graphic Editor command on the Tools menu or the Graphic
Editor button on the Application Toolbar. The Select Graphic dialog box
opens, as shown in Figure 8-13.
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Select Graphic

Figure 8-13. Select Graphic Dialog Box

2. Type a unique name in the Name text box. using up to 32 alphanumeric
characters, as well as underscores and colons. The name mus? begin with
a letter or a colon.

3. You may select an existing template from the Create from Template
drop-down list box to create a new object or

Select None from the Create from Template drop-down list box to create
a new object without using any template.

Deleting Templates

Technical Note

If you delete a symbol, you cannot use the Undo command to retrieve
it.

1. Select the Delete Template command from the Symbols menu. The De-
lete Template dialog box opens, as shown in Figure 8-14.
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Delete Template

Figure 8-14. Delete Template Dialog Box

2. Choose the template you want to delete from the Template Name list
box.

3. Click the Delete Template button. A message box displays asking if you
still want to delete the template. Click Yes if you want to delete the tem-
plate, No if you do not. (Deleting templates cannot be undone.)

SoftScreen Symbol Libraries

This section defines the symbols provided with SoftScreen. These symbols
can be inserted on any screen, recipe, or alarm, unless noted otherwise.

Symbol libraries provide over 150 ready-to-use objects. They are grouped by
function and can be inserted onto a Graphic Editor screen. When inserted,
many of the symbols can be dynamically linked to real-time data. SoftScreen
will prompt you for the tag name you wish to use when the symbol is in-
serted.
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In previous SoftScreen versions, the Selectors group included 3D sym-
bols. Because these symbols were determined to be too memory inten-
sive, the symbols and group were removed.

Technical Note

Control Graphics Group

Table 8-2. Control Graphic Symbols

Control Graphics
Symbol

Description

®

_and logic gate

Symbol for an AND logic function

?

_coil

.Electrical symbol for a coil

T

_contact NC horz

Electrical symbol for a normally closed contact with the connec-
tions at the sides

—“Ne—

_contact NC vert

Electrical symbol for 2 normally closed contact with the connec-
tions on the top and bottom

~

__contact_NO_vert

Electrical symbol for a normally open contact with the connections
at the top and bottom

r.

_flow_switch

Electrical symbol for a flow switch

=2

_foot_switch

Electrical symbol for a foot switch
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Control Graphics
Symbol

Description

T Electrical symbol for a fuse
_fuse
_L Electrical symbol for a ground connection
_gr-;-und
G Electrical symbol for a normally closed limit switch

_limit switch NC

=

_limit switch NO

Electrical symbol for a normally open limit switch

kS

_liquid level switch

Electrical symbol for a liquid level switch

QTo Electrical symbol for a normally closed momentary contact mush-
_momentary mush_hd NC_PB room head push button
e el Electrical symbol for a normally open momentary contact mush-
¢ o room head push button
_momentary mush hd NO PB
olo Electrical symbol for a normally closed momentary contact single
mementary NC B circuit push button
1 Electrical symbol for a normally open momentary contact single
@] (@]

_momentary NO_PB

pole push button

=D

_or_logic_gate

Symbol for an OR logic gate

XX
V\
_pilot light

Electrical symbol for a pilot light
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Control Graphics Description
Symbol

n Electrical symbol for a push to test pilot light
p—_%

_pilot light push to_test

o0 Electrical symbol for a single pole break switch
_single break switch

Q.c % Electrical symbol for a temperature actuated switch

_temperature actuated switch

% Electrical symbol for a thermal overload heater

_thermal overload heater

(¢}

.Electrical symbol for a de-energized timer switch

K\V

_time switch de-energized

QTO Electrical symbol for an energized timer switch

_time switch energized

5 Electrical symbol for a two-position contact switch
o o

two position contact sw

‘? o Electrical symbol for a vacuum switch

_vacuum_switch
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Meters Group

Table 8-3. Meter Symbols

Meter Symbol

Description

_analog_meter 0_to_1

This analog meter symbol has a scale from 0 to 1. To use this
symbol, insert it on a graphic screen. Rename the Needle_value
tag to the device driver tag you wish to monitor.

_analog_meter 0_to_10

This analog meter symbol has a scale from 0 to 10. To use this
symbol, insert it on a graphic screen. Rename the Needle_value
tag to the device driver tag you wish to monitor.

_analog_meter_0_to_100

This analog meter symbol has a scale from 0 to 100. To use this
symbol, insert it on a graphic screen. Rename the Needle_value
tag to the device driver tag you wish to monitor.

Graphics Group

Table 8-4. Graphic Symbols

Graphic Symbol

Description

B

_alarm circle in

This symbol displays when the associated value goes into alarm.
To use this symbol, insert it on an alarm screen. Then configure
alarm settings in the data editor.

alarm circle in and out

This symbol displays when the associated value goes into and
out of alarm. To use this symbol, insert it on an alarm screen.
Then configure alarm settings in the data editor.

_alarm circle out

This symbol displays when the associated value goes out of
alarm. To use this symbol, insert it on an alarm screen. Then
configure alarm settings in the data editor.

&

_recipe failed

This symbol displays when the associated recipe has failed. To
use this symbol, insert it on a recipe screen. Then configure rec-
ipe settings in the data editor.
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Graphic Symbol

Description

_recipe posted

This symbol displays when the associated recipe has been
posted. To use this symbol, insert it on a recipe screen. Then
configure recipe settings in the data editor.

Indicators Group

Table 8-5. Indicator symbols

Indicator Symbol

Description

_pilot_light blue

This blue pilot light changes color shading and intensity when its tag is
1 or greater, or true. To use this symbol, insert it on a graphic screen.
Rename the On_State tag to the device driver tag you wish to monitor.
Using the data editor, you can add a keypad or touch zone event/action
to the screen to assign a new value to the device driver tag.

This green pilot light changes color shading and intensity when its tag is
1 or greater, or true. To use this symbol, insert it on a graphic screen.
Rename the On_State tag to the device driver tag you wish to monitor.
Using the data editor, you can add a keypad or touch zone event/action
to the screen to assign a new value to the device driver tag.

This red pilot light changes color shading and intensity when its tag is 1
or greater, or true. To use this symbol, insert it on a graphic screen.
Rename the On_State tag to the device driver tag you wish to monitor.
Using the data editor, you can add a keypad or touch zone event/action
to the screen to assign a new value to the device driver tag.

_pilot_light red green

This normally red pilot light changes to green when its tag is 1 or
greater, or true. To use this symbol, insert it on a graphic screen. Re-
name the On_State tag to the device driver tag you wish to monitor.
Using the data editor, you can add a keypad or touch zone event/action
to the screen to assign a new value to the device driver tag.
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Indicator Symbol

Description

_pilot_light yellow

This yellow pilot light changes color shading and intensity when its tag
is 1 or greater, or true. To use this symbol, insert it on a graphic screen.
Rename the On_State tag to the device driver tag you wish to monitor.
Using the data editor, you can add a keypad or touch zone event/action
to the screen to assign a new value to the device driver tag.

ISA Symbol Library Group

Table 8-6. ISA symbols

ISA Symbol Description
C I j An agitator
_agitator
G A blower
_blower
N A butterfly valve
_butterfly valve
N A check valve
_check _valve
1: A compressor
_compressor
@ A conveyor
_conveyor
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ISA Symbol Description

.@ A cyclone separator

_cyclone separator

@ A distillation tower

_distillation tower

v A downward-pointing arrow

down_arrow

:® A heat exchanger

_heat_exchanger

f | A heat furnace

_heat furnace

. ;; ' A horizontal valve with an actuator

_horz_valve w_actuator

I El A horizontal valve with a manual actuator

_horz_valve w_manual actuator

“— A horizontal valve with a throttling actuator

_horz_valve w_throttling actuator

M An inline mixer

inline mixer
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ISA Symbol Description
‘ A left-pointing arrow
_left arrow
- T A liquid filter
_liquléfiilter
A motor

_motor

>

_pressure_storage vessel

A pressure storage vessel

g A
_pump

A reactor
__reactor

A relief valve

1 N

_relief valve

)

_right arrow

A right-pointing arrow

_rotary feeder

A rotary feeder
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ISA Symbol Description
4[ :l]]' A rotary kiln
_rotary kiln

screw_conveyor

A screw conveyor

U

_storage bin

A storage bin

3"E A transformer
_transformer
‘C} A turbine
_turbine

A An upward-pointing arrow
_up_arrow

A vacuum

_vacuum

vert valve w_actuator

A vertical valve with an actuator
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ISA Symbol

Description

vert valve_w__manual_actuator

A vertical valve with a manual actuator

_vert_valve_w_throttl ing actuator

A vertical valve with a throttling actuator

8

_vessel

A vessel

N/1

_weight hopper

A weight hopper

Push Buttons Group

The push button symbols are available only if you have selected a target

with a touch screen.

Table 8-7. Push Button Symbols

Push button Symbol

Description

_latched pbtn rnd w_ind

This push button with a round actuator is latched "on" with a
touch press, verified with an indicator lamp, and released
with a separate tag. To use this symbol, insert it on a graphic
screen. Rename the On_State tag to the device driver tag
you wish to control. Rename the Actual_State tag to the de-
vice driver tag you wish to monitor with the indicator lamp.
Rename the Release_Bit tag to the device driver tag you will
use to unlatch the button. Add keypad controls by adding
key press event/actions for these tags in the data editor for
the screen.
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Push button Symbol Description

This latched push button with a square button is latched "on"

with a touch press and released with a separate tag. To use
D this symbol, insert it on a graphic screen. Rename the
On_State tag to the device driver tag you wish to control.
Rename the Release_Bit tag to the device driver tag you will
use to unlatch the button. Add keypad controls by adding
key press event/actions for these tags in the data editor for
the screen.

_latched_pushbutton_square

A single touch press will push "in" the square button on this

maintained push button. A second touch press will release it.
O To use this symbol, insert it on a graphic screen. Rename
the On_State tag to the device driver tag you wish to control.
_Baintained pushbutton square Add keypad control by entering a key press event/action for
each TZ1 event/action in the data editor for the screen.

This momentary push button with a square button is selected
D . and released with a single touch press and release. To use

this symbol, insert it on a graphic screen. Rename the
On_State tag to the device driver tag you wish to control.
Add keypad control by entering key press and key release
event/actions for each TZ1 touch press and touch release
event/action in the data editor for the screen.

_momentary pushbutton square

Constants Group

The following symbols can be inserted on the Constants form.

The _true_false symbol contains constants for true and false, as shown in
Figure 8-15.
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s
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Figure 8-15. _true_false Constants Symbol

m

ymbol contains constants zero through ten, as shown

The zero tens
Figure 8-16.
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zero_ten Constants Symbol

Figure 8-16.
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Machine Cycle Group

This group includes the _machine_cycle_message string, which provides
messages used for a machine control cycle that can be inserted on the Strings
form.

Turn machine on

phoons SRS A0
Turn machine on
Load parts
Close door
Auto cycle
Open door
Unload part
Clear part
Manual control

0
1
2
3
4
5
6
7

Figure 8-17. _machine_cycle_message String Inserted on the Strings Form

Expression Groups

The following symbol groups include symbols that can be inserted on the
Expressions form.

Machine Cycle Message Control Group

This group contains the _message_control expressions, which retrieves mes-
sages from the machine cycle message symbol.
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Data Editor: 10[! { ExplessionsA] ]

Figure 8-18. _message_control Expression Inserted on the Expressions Form

Scaling Group

This group contains the _scale_by_100 expression, which scales a datapoint
by dividing it by 100.

Data Editor 3100 { Exple ions )

FLC Tag/ 100

Figure 8-19. _scale_by 100 Expression Inserted on the Expressions Form
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Compare Group

This group includes the _is_greater than_ 100 expression, which checks for a
datapoint value to be greater than 100.

30 seconds

PLC Tag> 100 Float

Figure 8-20. _is_greater_than_100 Expression Inserted on Expressions Form
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This chapter describes how to configure recipes. Recipes are a list of assign-
ments from one tag to another. Recipes are loaded (read and then sent to the
PLC) through an event/action. Because recipes provide a way to change
many PLC values at one time, special error detection is provided. Part of
each recipe configuration includes parameters for when the recipe has been
posted successfully and when there is a failure. These parameters include
shapes to display and posted/failed assignments.

Recipes consist of a data element (recipe settings) and an optional graphical
element (recipe shapes). Recipe settings are specified in the Data Editor.
Recipe shapes are configured in the Graphic Editor.

Technical Note

When a recipe is loaded, the run-time engine places it in an internal
queue. When the current recipe has completed, the next recipe in the
queue is loaded.

The queue holds up to 100 recipes. If a recipe is requested when the
queue is full, it will not be queued. When this occurs, the following
alarm message is displayed on screen and logged in the alarm sum-
mary:

"Recipe Queue Exceeded"

Creating a New Recipe

You can create new recipes by selecting the Data Editor command on the
Tools menu or using the Application Navigator form, shown in Figure 9-1.
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} Aﬁupli(-;‘alio; N::i;—.ﬂor: ne(.:ip(-;:w

No StartUp Screen

Figure 9-1. Application Navigator Form

To create a new recipe from the Application Navigator form...

1. Select Recipes from the Data drop-down list box.

2. Type a unique recipe name in the Data text box. See Chapter 3 for in-
formation on creating tag names.
If you have created a default screen template, this screen will incorpo-
rate all elements of that template.

3. Press ENTER. The Recipe Editor form opens, with the name of the new
recipe in its title bar.

To create a new recipe using the Data Editor command...

1. Select the Data Editor command on the Tools menu or the Data Editor
button. The Select Data Form dialog box opens, as shown in Figure 9-2.

214



Chapter 9 — Configuring Recipes

Application

Figure 9-2. Select Data Form Dialog Box

Select Recipes from the Type drop-down list box.

Type a unique recipe name in the Name text box. See Chapter 3 for in-
formation on creating tag names.

If you want to create this recipe based on an existing screen template,
select the template from the Create from Template drop-down list. Refer
to Chapter 8 for more information on templates. The Preview window
displays the elements on the selected template, and the Description box
provides a description of the template, if there is one.

Press ENTER to open the Recipe Editor form, shown in Figure 9-3.
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9-4

9.

w» Data Editor: Tutorial { Rcipe Rei] T

Figure 9-3. Recipe Editor Form

Specify thé amount of time, from 0 to 4294967 seconds, to wait for data
validation. The default is 3.

Type a name in the Destination Tag Name text box. The value of the
source tag will be assigned to this tag.

Type a name in the Source Tag Name text box. The value of this tag will
be assigned to the Destination tag.

Click Add to add the assignment to the Assignments list box.

You have now specified a recipe. If you want to configure posted and failed
assignments, you must configure these on the associated pages.

Posted and failed assignments are based on the status of the recipe. If the
recipe is posted, the posted assignment is loaded. If the recipe fails, the
failed assignment is loaded.
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When a recipe has been successfully posted it means that the run-time
engine has ensured that the addresses read from/written to contain
valid values. It then “posts™ the recipe. When a recipe is successfully
posted it does not mean that the values were written from the recipe
source to the recipe destination. When a recipe fails, it means that the
run-time engine was unable to validate the values at the addresses be-
ing read from/written to, so the recipe is not “posted.”

Technical Note

To specify a posted assignment...

1.

Select the Posted tab on the bottom of the Recipe Editor form to access
the Posted Assignment page, as shown in Figure 9-4.

= Data Editor ] Recipel )

Figure 9-4. Posted Assignment Page

2. Specify a display time. The range is 0 to 4294967 seconds (the default is

3). This is the amount of time the associated recipe shape will display on
the target workstation during run-time when the recipe is posted. If no
recipe shape is created, this value has no meaning during run-time.

Type a name in the Destination Tag Name text box. The source tag value
will be assigned to the Destination tag if the recipe is posted.

Type a name in the Source Tag Name text box. The value of this tag will
be assigned to the Destination tag if the recipe is posted.
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5. Click Add to add the assignment to the Assignments list box.
These assignments will occur if the recipe is posted.
To specify a failed assignment...

1. Select the Failed tab on the bottom of the Recipe Editor form to access
the Failed Assignment page, as shown in Figure 9-5.

= Data E ( Recipe: Re

Figure 9-5. Failed Assignment Page

2. Specify a display time. The range is 0 to 4294967 seconds (the default is
3). This is the amount of time the associated recipe shape will display on
the target workstation during run-time if the recipe fails. If no recipe
shape is created, this value has no meaning during run-time.

3. Type a name in the Destination Tag Name text box. The source tag value
will be assigned to this tag if the recipe fails.

4. Type a name in the Source Tag Name text box. The value of this tag will
be assigned to the Destination tag if the recipe fails.

5. Click Add to add the assignment to the Assignments list box.

These assignments will occur if the recipe fails.
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Creating Recipe Shapes

You must create a recipe shape if you want a visible indicator on screen
during run-time that a recipe was posted or failed. Recipe shapes are created
in the Graphic Editor.

To create a recipe shape...

1.

Select Recipes from the Graphic drop-down list in the Application
Navigator form.

If you have already configured a recipe in the Data Editor, double-click
on the recipe name in the Graphic list box.

or

If you have yet to configure a recipe in the Data Editor, type a unique
name in the associated text box, then click OK. If you have created a de-
fault screen template, this screen will incorporate all elements of that
template.

Draw a shape. Refer to Chapter 6, Creating Screens, for information on
drawing shapes.

Choose the Selection tool on the Drawing Palette.

Double-click on the shape to access the Shape Properties dialog box, as
shown in Figure 9-6.

Shape Properties

Figure 9-6. Recipe Shape Properties Dialog Box

6. Select a Show Shape option. Table 9-1 defines these options.
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Table 9-1. Show Shape Options

Option Definition

Recipe Posted Displays when the recipe is posted (this is
the default setting)

Recipe Failed Displays when the recipe fails

Recipe Posted and Displays when the recipe is posted and

Failed displays when the recipe fails

If you configure it as “recipe posted,” the shape will display during run-
time for the amount of time specified on the Posted assignment page. If
it is configured as “recipe failed,” the shape will display during run-time

for the amount of time specified on the Failed assignment page.
7. Click OK or press ENTER to accept the settings in this dialog box.

8. Repeat steps 3 through 6 to create additional recipe shapes.

Recipe shapes will display during run-time when the associated recipe is

posted or failed.

Once you have configured a recipe, you must assign an event/action that
loads it during run-time. Refer to Chapter 11 for information on assigning

event/actions.

Copying and Pasting Recipes

To copy and paste recipes...

1. From the Application Navigator, select Recipes from the Graphic list

box.

2. Select the recipe you want to copy, and then select Copy from the Edit

menu.

Open the application where you want to place the recipe.

4. Inthe Application Navigator, select the Paste command on the Edit

menu. The Change Paste Names dialog box appears, as shown in Figure

9-7.
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Figure 9-7. Change Paste Names Dialog Box

5. To avoid a conflict with a tag name in the new application, type a new
recipe name in the New text box.

6. Click OK. The recipe graphic screen has been added to your application
with the name you specified in the New text box.
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This chapter describes how to set alarms. Alarms signal that an analog
value has gone below or exceeded defined limits, or a discrete value has
been turned on or off.

Alarms consist of a data element (alarm settings) and an optional
graphical element (alarm shape). Alarm settings are specified in the
Data Editor. Alarm shapes are configured in the Graphic Editor. Every
displayable alarm must have its own shape, unless the Master Alarm
Shape has been enabled.

Technical Note

See Chapter 5 for Alarm Priority Configuration, Master Alarm
Shape Configuration, and Alarm Display Window Configuration.

Creating a New Alarm

You can create new alarms by selecting the Data Editor command on the
Tools menu or using the Application Navigator form, shown in Figure
10-1.

10-1

223



SoftScreen Development System for Windows User’s Guide

: Application Navigator: alarm

}]{Master_Template

Figure 10-1. Application Navigator Form

To create a new alarm from the Application Navigator form...
1. Select Alarms from the Data drop-down list box.

2. Type a unique alarm name in the Data text box. See Chapter 3 for
information on creating tag names. If you have created a default
screen template, this screen will incorporate all elements of that
template.

3. Press ENTER. The Alarm Editor form opens, with the name of the
new alarm in its title bar.

To create a new alarm using the Data Editor command...

1. Select the Data Editor command on the Tools menu or the Data
Editor button. The Select Data Form dialog box opens, as shown in
Figure 10-2.

10-2
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Figure 10-2. Select Data Form Dialog Box

2. Select Alarms from the Type drop-down list box.

3. Type a unique alarm name in the Name text box. See Chapter 3 for
information on creating tag names.

4. If you want to create this screen based on an existing screen tem-
plate, select the template from the Create from Template drop-down
list. Refer to Chapter 8 for more information on templates. The Pre-
view window displays the elements on the selected template, and the
Description box provides a description of the template, if there is
one.

5. Press ENTER to open the Alarm Editor form, shown in Figure 10-3.

10-3
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Figure 10-3. Alarm Editor Form

Once you have created an alarm and the Alarm Editor form is displayed
on your screen, you can specify analog and discrete alarms.

Specifying Analog Alarms

To specify an analog alarm...

1.

10-4

In the Alarm Editor form, type a unique tag name in the Tag Name
text box. You must specify a tag name or you will receive an error
when you generate the application.

Select a priority level.

If you want to use Master Alarm Shape, check the box. (See Chapter
5, “Master Alarm Shape Configuration” for more information.)

Select Analog as the Alarm Type.

Choose Hi or Lo and specify a value. If you select Hi, the alarm will
occur when the value of the attached tag rises above the specified
value. If you select Lo, the alarm will occur when the value of the
attached tag drops below the specified value.
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6. Specify a Deadband. The deadband sets the value that the attached

tag must be equal to or greater than before the alarm will be reset if
a Hi alarm is specified. If a Lo alarm is specified, the deadband sets
the value that the attached tag must be equal to or less than before
the alarm will be reset.

For example, if you specify 45 as the Hi alarm value and 5 as the
deadband, the value of the attached tag must be equal to or less than
40 to reset the alarm. If you specify 50 as the Lo alarm value and 5
as the deadband, the value of the attached tag must be equal to or
greater than 55 to reset the alarm.

Specifying Discrete Alarms

To specify a discrete alarm...

1.

In the Alarm Editor form, type a unique name in the Tag Name text
box. You must specify a tag name or you will receive an error when
you generate the application.

Select Discrete as the Alarm Type.
Select a priority level.

Next, specify when the alarm will occur: when the value of the tag
transitions from 0 to non-zero (on) or non-zero to 0 (off).

A non-zero value is any value equal to or greater than 1. A value of
0 is any value less than 1, including negative numbers.

Technical Note

10-5
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Once you have specified an alarm, you can configure Into and Out of
alarm settings if you want the alarm to be logged during run-time in the
alarm summary. You can also trigger an action when a value goes into
or out of alarm.

Into alarm settings occur when the value of the attached tag goes into
alarm. Out of alarm settings occur when the value of the attached tag
goes out of alarm.

Specifying Into and Out of Alarm Settings

10-6

Once you have configured an alarm, you can specify settings based on
the value going into or out of alarm.

To specify Into Alarm settings...

1. Select the Into tab on the bottom of the Alarm form to access the
Into alarm page, as shown in Figure 10-4.

Data Eg”igm: recipe (

Figure 10-4. Into Alarm Page

2. Type a message in the Message text box. This message identifies the
alarm in the alarm summary, which can be displayed during run-
time. You can also display this message during run-time if you cre-
ate an animated text box that is configured to display when the at-
tached value goes into alarm.
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You must specify a message or configure an associated alarm
shape to log the alarm in the alarm summary when the attached
value goes into alarm.

Technical Note

3.

Specify a time in the Display Time text box. This is the amount of
time you want the associated alarm shape to display when the value
goes into alarm. If there is no alarm shape associated with this
alarm, this value has no meaning. If “Use Master Alarm Shape” is
checked, the time reflects the Master Shape Display time.

Check Requires Acknowledgment if you want the alarm to have to
be acknowledged. Then you must specify an event/action to ac-
knowledge the alarm (refer to Chapter 11). If the alarm requires ac-
knowledgment, the into alarm shape will display until the alarm is
acknowledged. If you specify an acknowledgment, but do not create
an alarm shape, the alarm will.not have to be acknowledged during
run-time.

Choose an action from the Action drop-down list box if you want to
trigger an action when the attached value goes into alarm. Refer to
the Assigning Actions section, below, for more information on ac-
tions.

6. Click Add to add the action to the Actions list box.
To specify Out of Alarm settings...

Select the Out of tab on the Alarm Editor form. Then follow steps 1
through 6 described above for the Into Alarm section. The dialog box
will look the same as the one shown in Figure 10-4.

10-7
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Assigning Actions

You can assign actions to alarms that will occur when the alarm is trig-
gered. Table 10-1 defines the actions you can configure.

Table 10-1. Action Descriptions

source tag to the destination
tag

Action Description User Input during
Run-time
Acknowledge alarm Do not specify this action in N/A
the Alarm Editor. Use
event/actions to acknowledge
alarms (see Chapter 11).
Assignment Assigns the value of the N/A

Change password
level

Changes the password level
of the run-time engine

Type the new password
level in the dialog box.

Enable data entry

Allows you to enter data into
data entry shapes

Type data into the data entry
shapes.

alarm at a time) down

Go to alarm summary | Displays the alarm summary, N/A
in which all alarms are logged

Go to previous Returns to the previous screen | N/A

screen

Go to screen Displays the specified screen N/A

Load recipe Loads the specified recipe N/A

Scroll Up Scrolls alarm display (one N/A
alarm at a time) up

Scroll Down Scrolls alarm display (one N/A

For example, you may want to assign a 1 to register 30 to indicate that
an alarm has occurred. Or you may want to go to another screen to allow

Assigning Multiple Actions

10-8

you to correct the problem that caused the value to go into alarm.

An alarm can trigger multiple actions. However, there are several
rules that must be followed when you configure multiple actions for

an alarm:

You can configure the following actions in any order:
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e Assignment
e Load Recipe
e Ack Alarm

You can configure only one of the following actions for an alarm.
These actions can be preceded or followed by the actions above.

e Change password
e Enable data entry

You can configure one of the following actions for an alarm. These
actions can be preceded, but not followed, by any of the actions
listed above.

e (o to screen
e Go to Previous Screen

e Go to Alarm Summary

Creating Alarm Shapes

Every displayable alarm must have its own shape. Alarm shapes are
necessary if you want a visible indicator of an alarm on screen during
run-time. If you do not create an alarm shape, there will be no on-screen
display associated with an alarm. However, all alarms are logged in the
alarm summary, and/or alarm display window during run-time provided
a message is configured. You can access the alarm summary during run-
time by configuring an event/action. (Refer to Chapter 14, Using the
Run-time Engine, for more information on the alarm summary.)

If “Use Master Alarm Shape” is enabled, there is no need to create
an alarm shape. Refer to Chapter 14, “Master Alarm Shape.”

Technical Note

To create an alarm shape...

1.

Select Alarms from the Graphic drop-down list in the Application
Navigator form.

If you have already configured an alarm in the Data Editor, double-
click on the alarm name in the Graphic list box.

10-9
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10-10

or

If you have yet to configure an alarm in the Data Editor, type a
unique name in the associated text box to open the Alarm Editor. If
you have created a default screen template, this screen will incorpo-
rate all elements of that template.

Draw a shape or shapes. Refer to Chapter 6, Creating Screens, for
information on creating shapes.

Create a text box if you want to display a message when an alarm
occurs during run-time. Select Animated Text as the Type option.
Then click OK or press ENTER.

Do not configure any text animations for this shape, as they will
not be performed.

Technical Note

The message configured for this alarm will be displayed in this text
box when the alarm occurs, as shown in Figure 10-5. If it is an “into
alarm” message, it will display for the amount of time specified on
the Into alarm page. If it is an “out of alarm” message, it will display
for the amount of time specified on the Out of alarm page.

Figure 10-5. Alarm Text Example

Refer to the previous section, Configuring Alarm Settings, for in-
formation on specifying a message.

Choose the Selection tool on the Drawing Palette.

Double-click on the shape to access the Shape Properties dialog box,
as shown in Figure 10-6.
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Figure 10-6. Alarm Shape Properties Dialog Box

Select a Show Shape option. Table 10-2 defines these options.
Table 10-2. Show Shape Options

Option Definition
Into Alarm Displays when a value goes into alarm
Out of Alarm Displays when a value goes out of alarm

Into and Out of Alarm | Displays when a value goes into alarm and
displays when a value goes out of alarm

If you configure an “into alarm” shape, it will display during run-
time for the amount of time specified on the Into alarm page. If you
configure an “out of alarm” shape, it will display during run-time for
the amount of time specified on the Out of alarm page.

An example of an alarm shape without text is shown in Figure 10-7.

Figure 10-7. Alarm Shape without Text Example

An example of an alarm shape with text is shown in Figure 10-8.

10-11
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Figure 10-8. Alarm Shape with Text Example

8. Click OK or press ENTER to accept the settings in this dialog box.
9. Repeat steps 3 through 7 to create additional alarm shapes.

These shapes will display during run-time when the attached value goes
into or out of alarm.

Copying and Pasting Alarms

To copy and paste an alarm graphic screen...

1. From the Application Navigator, select Alarms from the Graphic
drop-down list box.

2. Highlight the name of the alarm you want to copy, then select the
Copy command on the Edit menu.

3. Open the application in which you want to copy the alarm.

4. Inthe Application Navigator, select the Paste command on the Edit
menu. The Change Paste Names dialog box appears, as shown in
Figure 10-9.

Change Paste N

Figure 10-9. Change Paste Names Dialog Box

5. To avoid a conflict with a tag name in the new application, type a
new alarm name in the New text box.

10-12
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6. Click OK. The alarm graphic screen has been added to your appli-
cation with the name you specified in the New text box.

10-13
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Event/actions are powerful and flexible events which occur during run-time,
triggering specific actions.

For instance, you can configure a key press (event) to go to another screen in
your application (action) during run-time. Or alarms can be acknowledged
(action) when the attached tag is true (event).

Technical Note

Event/actions are assigned to a particular screen and can only occur
when that screen is visible during run-time. The exceptions are
event/actions configured in the Master Template. You can specify
whether these are local to the Master Template or application wide.

Defining Events

Events are what cause actions to occur. The run-time engine evaluates
events approximately every quarter second.

Technical Note

Refer to Chapter 3, Configuring Tags, for information on how tags are
evaluated.

Table 11-1 defines the events you can configure.

1141
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Table 11-1. Event Descriptions

Event

Definition

User Input
during
Run-time

Trigger
Type*

Condition becomes true

Action occurs when the condition of the attached
tag goes from false (zero) to true (non-zero)

N/A

Edge

Condition is true

Action occurs when the condition of the attached
tag is true (non-zero). Note: You may want to use
the Condition becomes true event instead of the
Condition is true event. This event may cause the
action to occur more often than necessary, and, as
a result, degrade performance.

N/A

State

Condition becomes false

Action occurs when the condition of the attached
tag goes from true (non-zero) to false (zero).

N/A

Edge

Condition is false

Action occurs when the condition of the attached
tag is false (zero). Note: You may want to use the
Condition becomes false event instead of this the
Condition is false event. This event may cause the
action to occur more often than necessary, and, as
a result, degrade performance.

N/A

State

Key press

Action occurs when the configured key is pressed.
Function keys F11-F16 are accessed using SHIFT +
F1-F6. Note: This event is in no way associated
with the keyboard driver configurations. Event
Actions will not occur anytime the Alarm Summary,
Data Entry or Password Entry are in use.

Warning: Target workstations (serial numbers
xxxxxx-4H7 and above) will not recognize multiple
keys pressed at the same time.

Press the config-
ured key.

Edge

Key release

Action occurs when the configured key is released.
Function keys F11-F16 are accessed using SHIFT +
F1-F6. Note: This event is in no way associated with
the keyboard driver configurations. Event Actions
will not occur anytime the Alarm Summary, Data
Entry or Password Entry are in use.

Release the con-
figured key.

Edge

Periodic timeout

Action occurs every time the specified amount of
time (in msecs) elapses during run-time. These
times are accurate to approximately a quarter sec-
ond. This period begins when the screen is first
displayed.

N/A

Edge

Time

Action occurs at the time specified in hour:minute
format (hh:mm)

N/A

Edge

Timeout

Action occurs once when the specified amount of
time (in msecs) elapses during run-time. These
times are accurate to approximately a quarter sec-
ond. The timer starts when the screen is first dis-
played.

N/A

Edge

Touch zone press

Action occurs when specified touch zone is pressed

Press the config-
ured touch zone.

Edge

11-2
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Event Definition User Input Trigger
during Type*
Run-time
Touch zone release Action occurs when specified touch zone is re- Release the con- Edge
leased figured touch
zone.

*Technical Note

An action associated with an edge-triggered event takes place only

once when the event occurs. For example, a key press only triggers the
action once. The action does not continuously occur as long as the key
is pressed.

An action associated with a state-triggered event occurs as long as the
event condition remains true.

Defining Actions

Actions are what occur when the configured event takes place. Table 11-2
defines the actions you can configure.

Table 11-2. Action Descriptions

tination tag

Action Description User Input during
Run-time

Acknowledge alarm Acknowledges the currently displayed alarm N/A

Note: While in Alarm Summary, you can also

perform this action during run-time by pressing

a touch button that displays at the bottom of

the alarm summary screen (if you have a tar-

get workstation that incorporates a touch

screen), or by pressing the function key that is

located below this touch button.
Alarm window scroll to top Shows the top of the alarm display window on the N/A

screen
Alarm Window Scroll Up Scrolls alarm display (one alarm at a time) up N/A
Alarm Window Scroll Down Scrolls alarm display (one alarm at a time) down N/A
Assignment Assigns the value of the source tag to the des- | N/A

Change password level

Changes the security level of the run-time
engine

Type the password associated
with the new level in the pass-
word text box.
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Action Description User Input during
Run-time
Enable data entry Allows you to enter data into data entry shapes. You Type data into the data entry shapes.

can only specify this as a local event, not a global one.
Note: Refer to Chapter 6 for more information on data

entry shapes.
Go to alarm summary Displays the alarm summary screen N/A
Go to previous screen Returns to the screen that was previously displayed N/A
Go to screen Displays the specified screen N/A
Load recipe Loads the specified recipe N/A

Print alarm log

Prints the information contained in the alarm summary | N/A

Note: While in the Alarm Summary, you can also
perform this action during run-time by pressing a
touch button that displays at the bottom of the alarm
summary screen (if you have a target workstation that
incorporates a touch screen), or by pressing the func-
tion key that is located below this touch button.

Print current screen Prints the contents of the current screen. N/A
Prepare for download Shuts the engine down so the bootloader can begin N/A
execution.

Note: It is highly recommended that this action be
password protected since it stops the engine execution
(regardless of what is occurring).

Configuring an Event/Action

To configure an event/action...

1.

11-4

Select Screens from the Data drop-down list box in the Application
Navigator. In the associated list box, double-click on the name of the
screen for which you want to configure event/actions.

or

Select the Data Editor command on the Tools menu to open the Select
Data Form dialog box.

Select Screen as the Type.

In the Name list box, double-click on the name of the screen for which
you want to configure event/actions.

The Event/Actions form opens, as shown in Figure 11-1.
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- Data Editor: Project] [ Screen: Screenl

ondition becomes false

Figure 11-1. Event/Actions form

In the Event drop-down list box, select the event that will trigger the ac-
tion. Refer to Table 11-1 for event descriptions.

You must provide additional information for each event, as described in
Table 11-3.

Table 11-3. Event Information

Event Additional Information Needed
Condition becomes true Tag name

Condition is true Tag name
Condition becomes false Tag name
Condition is false Tag name
Key press/release Key to press or release

Period timeout, Timeout Time period (in msecs)

Time Time in 24-hour format (hh:mm)

Touch zone press/release | Name of touch zone to press or
release (as defined on General
Properties page of Shape Proper-
ties form for each touch zone)

11-56
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11-6

5. Specify an action. Refer to Table 11-2 for action descriptions. Some ac-
tions require additional information, as defined in Table 11-4.

Table 11-4. Action Information

Action Additional Information Needed
Assignment Source and destination tag names

Go to screen | Screen name

Load recipe Recipe name

6. If you configure an event/action for the Master Template, specify
whether the scope is Application wide or specific to the Master Tem-
plate. If you specify Application, the event/action will take place when
any screen is visible. If you specify Master Template, the event/action
will take place only when the Master Template is visible (this would
only occur if you configure the Master Template as the application’s
startup screen).

7. Once you provide all the necessary information, click Add to add the
event/action to the Event/Actions list box.

During run-time, the action will occur when the configured event takes
place.

The Move Up and Move Down buttons in this form allow you to change the
order of selected event/actions in the list. This is important because the order
of event/actions can have an impact on what occurs during run-time.

For example, if several event/actions evaluate true at the same time during
run-time, then they are performed in the order in which they appear in the
Event/Action list box. However, if an action changes the screen (on local
event/actions only), then any event/actions configured for the original screen
will not be performed.

For example, the following actions configured for screen 1 are each to occur
after five seconds has elapsed.:

1. Write 20 to #30.
2. Go to screen “MAINT.”
3. Load recipe “STARTUP.”

The Load Recipe action will not take place because you exited screen_1.
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Technical Note

Event/Actions specific to each screen can be configured in the Data
Editor. These tools allow you to control your application from any
screen. Event/actions configured on the master template can be config-
ured globally or locally.

Configuring Multiple Actions

You can configure an event that triggers multiple actions. However, there
are several rules that must be followed when you configure multiple actions.

You can configure the following actions in any order:
e Assignment
e TLoad Recipe
e Ack Alarm

You can configure only one of the following actions for a single event.
These actions can be preceded or followed by the actions in rule 1.

¢ Change password
e Enable data entry

You can configure one of the following actions for a single event. These ac-
tions can be preceded, but should not be followed, by any of the actions
listed in the rules above.

e Go to screen
e Go to Previous Screen
e  Go to Alarm Summary

e Go to top of alarm display

11-7
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Chapter 12 — Generating & Downloading
Applications

Once you have configured an application, you must generate it before you
can download it to the run-time engine. Generating allows SoftScreen to
“translate” the application into a form the run-time engine can understand.

Once you have successfully generated an application, you can download it to
the run-time engine.

Generating an Application

To generate an application...

1.

Select the Generate command on the Tools menu or click the Generate
button.

You will get an error message if you have not specified a startup
screen in the Application Navigator. Specify a startup screen, and then
regenerate.

You will also receive an error message if you do not specify a unique
tag name for an alarm. Specify a tag name, and then regenerate.

Technical Note

2.

If there are unresolved references in the application, a message states
this. Unresolved references refer to undefined tags, and forward and cir-
cular references. You cannot download an application until you have
corrected all unresolved references.

Click OK and the Generate window will display.

To print the listing in the Generate window, select the Print command on
the File menu or press the Print button.

121
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5. Select Cross Reference from the Tools menu to obtain a listing of unde-
fined tags.

6. Choose the Tag Names Listed option and a list of all tags used in your
application appears in the Referenced Tag Names form, as shown in
Figure 12-1.

- Referenced Tag Names: *

INeede_value UNDEFINED . Screen: Screenl
jone Constants A Line Width Animation AGrou.. Screen: Screenl

e

Figure 12-1. Referenced Tag Names Form

Table 12-1 defines the fields in the Referenced Tag Names form.
Table 12-1. Fields in the Referenced Tag Names Form

Field

Definition

Tag Name Referenced | Displays the tag name

Defined In Specifies where the tag is defined or undefined
Used In Indicates where the tag is used: in an animation, event, action, or
expression
Object Specifies the shape (if the tag is used in an animation)
In Specifies if the tag is in a screen, recipe, or alarm
7. Locate the undefined tags. Undefined tags must be defined in the Data
Editor in one of six places:
o PLC driver
o Internal driver
o Keyboard driver
« Constants
« Expressions
o Strings
12-2
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8. Once all unresolved references are resolved, generate the application
again.

You may receive a message that states that “Possible memory problems
were detected.” This message indicates one of two things:

« Flash usage by the application is greater than or equal to the Flash
available for the application or

« RAM usage by the application is greater than or equal to the RAM
available for the application

9. Click OK, and the Successful Generation message displays.

10. Click OK again. The Memory Analysis window displays, as shown in
Figure 12-2.

Project1:2

{ —— Workstation memory analysis ——-—
{Total flash: 1024K

{Flash available for application: 485K
{Flash usage by application: 1K .

Total RAM: 512K
RAM available for application: 380K
Maxinum RAM usage by application: 109K
Haster Template: 1K
Largest screen: Screenl 1K
No recipes
No PrintScreens

Please refer to your user's manual for information
on how to use these estimates.

Figure 12-2. Memory Analysis Window

To determine where the memory problem is, compare the Flash usage by
the application to the Flash available for the application and RAM usage
by the application and the RAM available for the application.

Once you determine the problem, make changes to the application to
correct it. For more information on the memory analysis tool, refer to
Chapter 13.

11. Once all problems have been corrected, regenerate the application. You
will receive a Successful Generation message. Click OK.

You are now ready to download the application. If you have not done so al-
ready, connect the development system to the target workstation. Refer to
Chapter 2 for cabling information.

12-3
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Downloading an Application

To download an application...

1. Select the Download command on the Tools menu or click on the
Download button to access the File Download dialog box, as shown in

Figure 12-3.

File Download

Figure 12-3. File Download Dialog Box

2. Select the Target Workstation button to change the target workstation
address or verify the link between a target workstation and the develop-
ment system workstation. This opens the Target Workstation Address
dialog box, as shown in Figure 12-4.

T get W“oikslalion Aii‘dressw

Figure 12-4. Target Workstation Address Dialog Box
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If you receive an error that says the COM port you have selected cannot
be opened, it may be because

e The port is in use
e Another version of Download is open, causing a conflict

Resolve these problems, then close and re-open the File Download dia-
log box.

Select Point to Point if there is only one target workstation.

If more than one workstation is attached, select the Specific Workstation
Address button, then specify the address of the workstation to which you
want to communicate, from 1 to 254. Choose the Verify Link button to
verify that the run-time engine is attached to the station you have speci-
fied. If it is attached, a message indicates this. If the station does not ex-
ist, you will be asked to choose another address.

Select the Change Current Address button if you want to renumber the
station address of the workstation to which you are communicating. This
opens the Change Current Address dialog box, as shown in Figure 12-5.

Figure 12-5. Change Current Address Dialog Box

Specify a new number, from 1 to 254, in the New Address text box, then
click OK.

Click on the Configure Serial Port button to open the Configure Down-
load Port dialog box, as shown in Figure 12-6.

Configure Download Port

Figure 12-6. Configure Download Port Dialog Box
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Select a Download Port. Choices are COM 1, COM 2, COM 3, or COM
4. The default is COM 1.

Select a baud rate. If you want to set all attached workstations to the de-
fault baud rate (57600), select the Force Default Baud Rate button.

Some PCs may have problems communicating at baud rates higher
than 9600. If you have trouble downloading an application, select a
slower baud rate.

Technical Note

10. Click Close once you have changed the download port settings.

11.

The app_name.download file associated with the current application will
be specified in the File Download dialog box. If you want to download
another application, select the Browse button, then double-click on the
desired application’s .download file.

Click on the Start File Download button.

If the connection between the development system workstation and the
target workstation is working properly, you will see the message
“Shutting down drivers, please wait...” on the engine.

Some drivers may take a long time to shut down or may not respond. If
it appears that the engine is not responding, cycle the target worksta-
tion’s power. You may want to configure the “Prepare for Download”
action for drivers with this problem. Refer to Chapter 11 for more in-
formation on actions.

Technical Note

Once the workstation is ready for you to download, a green OK splash
screen will appear.

After a successful download, a list of the files downloaded will display
in the Successful download window on the development system. At the
same time, the application’s start-up screen will appear on the run-time
engine.

12. Click OK to close the Successful download window.

If the files are not successfully downloaded, a failure message will appear in
the dialog box. If you receive a failure message, try downloading the appli-
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cation again. If it does not successfully download this time, cycle the target
workstation’s power.

Using the Download Utility

The Download utility that comes with SoftScreen handles downloading ap-
plications in Windows 95/NT, as well as configuring applications so they
can be downloaded from MS-DOS. It is incorporated as part of the Soft-
Screen Development System, but you can use it as a separate utility if you
want to view the files associated with the engine.

To access the SoftScreen Download utility...

Double-click on the SoftScreen Download utility icon or the download.exe
file to access the SoftScreen Download window, as shown in Figure 12-7.

Figure 12-7. SoftScreen Download Window

If you want to download an application, select the Download command from
the File menu. Once the File Download dialog box is open, follow the in-
structions in the Downloading an Application section earlier in this chapter.

Hold Station

Select the Hold Station command on the Target Workstation menu to stop
execution of the application and drivers on the run-time engine. You must
stop the run-time engine before listing memory.

12-7
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Start Station

Select the Start Station command on the Target Workstation menu after you
have halted application and driver execution with the Hold Station com-
mand. Once you select this command, application and driver execution will
resume.

List Memory

To display and print a listing of the target workstation’s memory...
1. Select the List Memory command on the Target Workstation menu.

You will receive a message that states that the workstation’s power must
be cycled, which will halt execution of the current application and driv-
ers on the run-time engine. If you want to do this, click Yes to start the
Bootloader.

The Target Workstation Memory List dialog box lists all the files in the
target workstation’s memory, and their size, version number (or date),
and type. Use this dialog box to determine if you have the latest version
of engine files.

Target Workstation #2 Memory List

347K 2.04.005
ne- Application 5K 127471997 9:31
ycom color palette 0K 10/27/193512:20
one- Keyboard Cfg 0K 12/4/1997 8:54
i 3K 107371895 8:43
11/25/1996 12:41
11/25/139613.0
11/25/1996 1241
12/ 411997 8:54
ycom Real Time 0S 11/21/1397 16:47
weom Popup Touch ... 11/5/1997 14:09
ycom Video (3100) 11/16/1995 16:53
yeom OK Splash Scr... 7/9/1997 10:33

Application
memory used
and free
Figure 12-8. Target Workstation Memory List Dialog Box
2. Click the Print button to print this memory listing.
3. Click Close when you are ready to close this dialog box.
12-8

252



Chapter 12 — Generating & Downloading Applications

Screen Contrast

To adjust screen contrast...

1. Select the Screen Contrast command on the Target Workstation menu to
open the Adjust Target Workstation Contrast dialog box, as shown in
Figure 12-9.

Adjust Target Workstation

Figure 12-9. Adjust Target Workstation Contrast Dialog Box

2. Click on the Decrease Contrast button to decrease contrast on the target
workstation’s screen.

3. Click on the Increase Contrast button to increase contrast on the target
workstation’s screen.

4. Click OK when you have finished adjusting the contrast.

Time/Date

To synchronize time and date with system time...

1. Select the Time/Date command on the Target Workstation menu to open
the Workstation Time/Date dialog box, as shown in Figure 12-10.

Figure 12-10. Workstation Time/Date Dialog Box

2. Click on the Synchronize With System Time button to synchronize all
target workstations’ date and time with Windows 95/NT system time.

3. Click OK to close the dialog box.
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Technical Note

If you do not close the Download window, a conflict will occur when
you try to download an application using SoftScreen’s Download
command.

Creating and Using the DOS Download Utility

SoftScreen provides the ability to download applications from MS-DOS. It
does this through the DOS Download utility.

Creating a DOS Download Disk

The DOS Download disk configures and saves all the files necessary to
download an application from MS-DOS. To create this disk,

1. Double-click on the SoftScreen Download utility icon to access the
SoftScreen Download window, as shown in Figure 12-11.

x SoftScreen Download
I

Figure 12-11. SoftScreen Download Window

2. Select the Create DOS Download Disk command on the Utilities menu
to access the dialog box shown in Figure 12-12.

12-10

254



Chapter 12 — Generating & Downloading Applications

9.

10.

Create DOS Download Disk

Figure 12-12. Create DOS Download Disk Dialog Box

Select the source file for which you want to create the DOS download
disk. If the file you want does not appear in the Source File box, select
the Browse button to locate the appropriate file.

Select the Destination Directory to which you want the file saved. If the
destination directory you want does not appear in the Destination Di-
rectory box, click on the Browse button to select the appropriate direc-
tory. This can be a directory on your hard drive or you can save directly
to a floppy disk. If you save to your hard drive, you will need to copy
the files to a floppy disk.

If you want to create a subdirectory in which to save the download files,
click on the Add Subdirectory button.

Add the name of the subdirectory you want to create in the New Subdi-
rectory text box, then click OK.

Click OK once you have chosen a destination directory.

Click the Create Disk button. A completed message displays after the
application is saved to the destination directory you specified.

Click OK.

You can create another DOS download disk at this time, or click Close
to end the procedure.

Once you have created a DOS download disk, you can use it to download
from DOS.

12-11
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Using the DOS Download Utility

Once you have created the DOS download disk, insert it in the system from
which you want to download the application. You can download from the
floppy disk or you can copy the files onto the system’s hard drive.

You can perform some of the same functions in DOS download that you do
in the SoftScreen Development System for Windows Download. Table 12-2
lists the valid commands and parameters to perform these functions.

Table 12-2. Syntax and Commands

Syntax
(these commands are not
case sensitive)

Command

-B baud_rate Sets the host computers baud rate to 9600, 57600, or 119200K.
-C com_port Uses 1 for COM1 or 2 for COM2; COM3 and COM4 are not supported.
- station_id Sets the station ID to which you want to talk. Valid IDs are 1-254 or 255 for point

to point.

-7 or no parameters

Displays valid commands and command syntax.

-DEFAULT_BAUD

Resets all attached workstation(s) to 57600 baud.

-GET_DATE Reads the date and time from the Focal Point engine.

-LIST_ITEMS Lists the items in the engine’s memory. This command will stop execution of the
current application and drivers on the run-time engine. After the memory listing
is complete, use the -START_EXEC command to restart the run-time engine.

-PING Checks to see if a station is responding.

-SET_DATE Sets the engine’s time and date to match DOS’s time and date.

-SET-BAUD baud

Sets the workstation’s baud rate to 9600, 57600, or 119200K.

-SET_ADDR addr

Sets the engine’s address. Valid addresses are 1-254.

-START_EXEC Starts execution of the run-time engine.
APPNAME.LST Downloads the application files to the run-time engine. APPNAME is the name
of your application.
To use the DOS download commands, type “download” and the appropri-
ate command at the C: prompt (or the A: prompt if your DOS download files
are on floppy).
1212
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Following are some DOS download command examples. They assume that
the download files are saved in the softwin directory on drive C.

e To download an application to the run-time engine, type the following:
C:\softwin\download appname.lst

Press ENTER and the utility downloads the necessary files to the run-
time engine. The startup screen for the downloaded application should
appear on the target workstation screen.

e Toread the engine’s date and time, type the following:
C:\softwin\download -get_date

Press ENTER, and you will receive an on-screen response similar to the
following:

Slave station’s Date 6/30/1997, Time 10:44:46
e To change the address of the target workstation, type the following:
C:\softwin\download -set_addr 3

Press ENTER, and you will receive the following on-screen response in-
dicating that the station address has been set to 3:

Command (SET_ADDR) completed successfully.

1213
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Chapter 13 — Analyzing an Application’s
Memory Usage

The SoftScreen Development System for Windows allows you to create ap-
plications of varying sizes. However, you must be careful to ensure that an
application you create on the development system does not exceed the
boundaries imposed by memory restrictions on the target workstation.

Calculating an Application’s Memory Requirements

Target workstations have two types of memory: Flash and RAM. When you
download an application, it is stored in Flash memory.

As the application executes, the run-time engine transfers screens, as needed,
into RAM, along with the tags required by screens, alarms, recipes, expres-
sions, and event/actions.

It is possible to create an application that will download to the target work-
station, but will not execute once downloaded. That is because an applica-
tion may fit in the target workstation’s Flash memory, but require more
RAM than is available.

Determining the Impact of Application Elements

Application size is determined by examining engine RAM usage; size of the
Master Template, the two largest screens, and the largest recipe; and the
RAM usage of print screen functions.

Once you’ve downloaded an application to the target workstation, a portion
of RAM will always be occupied by engine functions and the Master Tem-
plate (everything on the Master Template is considered global, and therefore
is active at all times).

RAM usage by the other application elements—screens, recipes, and print
screen functions—occurs only when the specific element is active. Also,
when switching between screens, part of the screen being replaced remains

1341
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Screens

Alarms

13-2

in RAM for a short time. That is because when the run-time engine loads a
new screen into memory, it removes everything related to the previous
screen except for its data points. The data points are scanned, and, if not
used by the new screen, they are removed.

Screen size is based on the number of objects and tags placed on the screen.
An application’s ability to fit within available RAM is directly related to
screen size.

Technical Note

A screen object is a symbol, line, circle, etc. that is displayed on the
screen during run time. Some symbols are made up of many different
objects (objects within objects) which affects the total amount of
memory used.

During run time, objects are broken down into their basic components.
Therefore, simply grouping objects will not reduce the screen’s RAM
requirement.

If an application has too many objects on a screen to execute on the target
workstation, create a bitmap that incorporates the screen’s static objects,
then import it into SoftScreen. You can then place active objects—such as
data displays, data entry points, and animated objects—on top of the bitmap
to complete the screen. As bitmaps are stored in Flash, you will decrease the
application’s RAM requirement, which may allow an application with large
RAM requirements to execute.

Alarms are global functions within SoftScreen. An alarm is always being
scanned no matter what screen is active, thus requiring RAM. Therefore, the
number of alarms has a significant impact on application size in terms of
RAM usage.
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Recipes

Although recipes only require RAM when they are active, they are important
because, once activated, they can have a large impact on the target worksta-
tion’s RAM. In fact, it is possible to have an application that is able to exe-
cute until a recipe is activated. Activating the recipe could subsequently use
enough RAM to exceed the RAM available.

Analyzing an Application’s Memory Usage

SoftScreen provides a tool to help you analyze the memory usage of an ap-
plication. Before using this tool, you should have successfully generated the
application. Generate will also do a memory analysis. A message box will
appear if a problem occurs during generate. Refer to Chapter 12 for more in-
formation on generating an application.

To analyze an application’s memory usage,
1. Select the Memory Analysis command on the Tools menu.

2. If the analysis is successfully completed you will receive a Successful
Analysis message. Press OK to continue. A window similar to the one in
Figure 13-1 will display.

If the memory analysis is unsuccessful, refer to Step 3.

P

{ — VWorkstation memory analysis —-
Total flash: 1024K

Flash available for application: 485K
{Flash usage by application: 1K

{Total RAM: S12K
{RAM available for application: 380K
Maximum RAM usage by application: 109K
Master Template: 1K
Largest screen: Screenl 1K
{No recipes
{No PrintScreens

|Please refer to your user's manual for information
ifon how to use these estinates.

L N %,

Figure 13-1. Memory Analysis Window

This window provides the following information (in Kbytes) about the
target workstation:
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e Total Flash

¢ Flash available for the application

o Flash usage by the application

e Total RAM

e RAM available for the application

e Maximum RAM usage by the application

e Size of the master template

e Size of the largest screen

e Size of the second largest screen (if there is one)
e Size of the largest recipe

e RAM usage by print screen functions (if there are any)

You should be able to download the application to the target workstation
if the Flash usage by the application is less than the Flash available for
the application.

Once downloaded, the application should execute if maximum RAM us-
age by the application is less than the RAM available for the application.

3. If the memory analysis is unsuccessful, you will receive the following
message:

SoftScreen for Windows

Possible memoary problems were detected.
Please refer to pour user's manual for more information.

Figure 13-2. Memory Problems Message

4. Press OK and refer to the Memory Analysis window to determine
whether it is a Flash or RAM memory problem.

5. Resolve the memory problem, then analyze the application again.
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Application Examples

Table 13-1 describes a typical application that will run on a target worksta-
tion. Table 13-2 and Table 13-3 provide application examples to help you
determine if your application will run on the target workstation.

Table 13-1. Typical Application Size

Elements 3100 3200/3300
Screens 30 (with 20 objects) 60 (with 40 objects)
Event/Actions | 125 (up to 10 per screen) | 250

Constants 25 50

Expressions 25 50

Recipes 5 (with 15 assignments) 10

PLC Tags 200 400

Internal Tags 50 ‘ 75

Alarms 75 150

Table 13-2. 3100 Applications

Elements Application that Will Fit Application that Will Be Too
Large

Screens 59 (two largest screens have 15 12 (two largest screens have 150
and 20 objects) and 200 objects)

Event/Actions | 241 (two largest screens have 15 101 (two largest screens have 12
and 21 event/actions) and 14 event/actions)

Constants 23 15

Expressions 121 113

Recipes - 7 0

PLC Tags 427 357

Internal Tags 93 18

Alarms 45 60
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The application in the second column of Table 13-2 has more screens,
event/actions, constants, expressions, PLC tags, and internal tags than the
application in the third column. Both applications will fit in the target work-
station’s Flash memory (which means you will be able to download them),
but the larger application will exceed available RAM (which means it will

not execute).

Table 13-3. 3200/3300 Applications

Elements Application that Will Fit Application that Will Be Too
Large
Screens 12 (two largest screens have 150 3 (two largest have 57 and 100
and 200 objects) objects)
Event/Actions 101 (two largest screens have 12 7
and 14 event/actions)
Constants 15 2
Expressions 113 0
Recipes 0 0
PLC Tags 357 1584
Internal Tags 18 1
Alarms 60 1584
If you need additional help in determining an application’s size, contact the
Application Engineering Department at 1-800-AT-XYCOM.
13-6

264




Chapter 14 — Using the Run-time Engine

This chapter discusses the functions you can perform on the run-time engine
once you have downloaded an application.

Technical Note

When you press a key or a touch zone configured to go to another
screen, SoftScreen erases the key and touch zone buffers.

Entering Data

Data entry shapes allow you to enter data during run-time. If an application
contains data entry shapes, an event must be configured to enable data entry
(for example, a key press or a timeout). It is recommended that you specify
the I-bar key to enable data entry.

When the configured data entry event occurs, a block-shaped cursor will ap-
pear at the first data entry shape on the screen.

To enable the Pop-Up keypad...

If the pop-up keypad for data entry is enabled and the engine has a touch
screen, you must press the screen on top of the data entry to enable the pop-
up keypad, which will then appear on the screen. Once enabled, you may
enter data from the touch screen.

To enter data...

1. Type a floating point value or a string (data entry shapes are configured
for either a float or string value) in the data entry shape.

Technical Note

Although you can type in all the ASCII characters on the development
system, the run-time engine will only display ASCII characters from
20h (32 decimal) to 7Eh (126 decimal).
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14-2

Technical Note

You can enter values using scientific notation.

Use the backspace key if you want to delete digits or characters in the
data entry shape. Press ESC if you want to abort the data entry before it
is sent to the attached tag.

Technical Note

While in alarm summary, user-defined event actions tied to key press
and key release will not function. The state of the keys for a screen will
be reset to 0 when the alarm summary is activated.

Technical Note

You can enter data using the keypad, an external PC-compatible key-
board or touch screen.

If more than one data entry shape is configured, press an arrow key or
use the touch screen to move the cursor to the next data entry shape.
Once you press the arrow key, the data in the current field will be writ-
ten to the attached tag.

Technical Note
When the pop-up touch pad is active, the arrow keys will not function.

If the data entry shapes have retained their default links, you will be able
to move between the shapes in the order in which they were placed on
the screen. If data entry link settings were changed in the development
system (refer to the Creating Data Entry Shapes section in Chapter 6 for
more information), the order in which you can move between shapes
will be based on those settings.
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Technical Note

If you press an arrow key that is not linked to another data entry shape,
the cursor will not move to another shape. Instead, the data in the cur-
rent shape will be written to the attached tag, and the data entry field
will be cleared and ready for another entry.

3. Press ENTER when you have finished entering data. This will write the
data in the last data entry shape to the attached tag.

Using Function Keys

Function keys F1 through F10 correspond to function keys F1 through F10
on the 3000 target workstation keypad, as well as to function keys F1
through F10 on a PC-compatible keyboard. Function keys F11 through F20
are accessed by selecting SHIFT + F1 through F10.

Changing the Security Level

The default security level of the run-time engine is 0, the lowest level of se-
curity. At this level, you can access any screens that have not been config-
ured with a security level.

Technical Note

When entering data, event actions tied to key press and key release will
not function. The state of the keys for a screen will be reset to 0 when
the alarm summary is activated.

Technical Note

When you enter a password associated with a security level, you are
changing the security level of the run-time engine.

14-3
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To enter a password...

1. When the password text box appears, type in a password. This password
must be attached to a security level that is the same as, or greater than,
the security level of the screen you want to access.

If you make a mistake, use the BACKSPACE key to erase the password,
and then retype it.

2. Press ENTER.

Technical Note

Once you press enter, the password text box disappears. It will reap-
pear only if there is an event configured that allows you to change the
security level.

The security level of the run-time engine is reset to the one attached to the
password you entered. You can now access any screens with security levels
less than or equal to the current security level. If you enter an incorrect
password, the current screen will continue to display.

For example, when you first start the run-time engine, it is set to security
level 0. If a “Go to Screen” action attempts to open a screen set to level 10, a
password text box will be provided. You must enter a password that is set
for security level 10 or above to open the screen. If you enter the password
for level 15, then the run-time engine’s new security level will be 15. This
means that any screens set to security levels from 0-15 can be opened with-
out providing a password.

Technical Note

Zero is the default security level on the run-time engine. If you enter 0
in the password box during run-time, the security level of the run-time
engine will be reset to 0.
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Queuing Recipes

When a recipe is loaded, the run-time engine places it in an internal queue.
When the current recipe has completed, the next recipe in the queue is
loaded.

The queue will hold up to 100 recipes. If a recipe request is received when
the queue already contains 100 recipes, the recipe will not be queued. When
this occurs, the following alarm message is displayed on screen and logged
in the alarm summary:

"Recipe Queue Exceeded"

Alarm Priorities

There are 16 alarm priorities with a choice of up to 16 corresponding colors
for each priority. When an alarm is sent to the Alarm Summary, or Alarm
Display Window (if enabled), the alarm is displayed in its configured prior-
ity color. If an alarm is tied to a custom shape, it will be displayed in the
custom shape’s configured priority color.

Master Alarm Shape

Master alarms are alarms that come from drivers or alarms that are config-
ured to use the master alarm shape. These alarms are displayed if you have
configured the alarm to use the master alarm shape and/or configured the
alarm for a custom shape(s) as well. When the alarm display window is dis-
abled, the master alarm shape appears at the bottom of the screen and when
enabled, appears just above the alarm display window.

Technical Note

Shapes from the Master Alarm screen can be displayed on any screen
you are editing. The shapes are not editable but are shown for posi-
tional information.
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Alarm Display Window

The Alarm Display window gives a scrollable view of the active alarm(s) in
the engine. The view includes the message, displayed in configured color,
accompanied by a date and time for the configured alarms. The number of
alarms, that can be viewed at one time in this window, can be from 2 to 12
for the 3100 target workstation, and from 1 to 24 for 3200/3300 target work-
stations. The depth of the Alarm Display window is configurable (refer to
Chapter 5, Table 5-4). You can move up or down in the Alarm window by
assigning the actions to the alarms for “Scroll Up” or “Scroll Down.”

Using the Alarm Summary

The alarm summary is a screen that displays a log of the configured alarms

that occurred in the current application. An event/action is configured in the
development system (see Chapter 11) that opens the alarm summary during
run-time, allowing you to view the alarm log.

Technical Note

While in alarm summary, event actions tied to key press and key re-
lease will not function. The state of the keys for a screen will be reset

to 0 when the alarm summary is activated

Information in the Alarm Summary

14-6

The alarm summary displays the following information:

e Message associated with the alarm (“Boiler Temperature Returned to
Normal”)

e Value at which the alarm was triggered (“1500”)
e Time and date when the alarm occurred (“18:18:53; 02/18/95”)
e Choice of color/priority level for each alarm

e State of acknowledgment. If an alarm requires an acknowledgment, and
it has not yet been acknowledged, a W (for waiting) appears at the end
of the log entry. If the alarm has been acknowledged, an A appears at the
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end of the log entry (an event/action must be configured to acknowledge
an alarm).

An “*” at the end of the line signifies that the alarm is active. No asterisk
indicates that the alarm is inactive.

Once the number of configured alarms has been reached, and a new alarm
occurs, an alarm is deleted from the alarm summary to make room for the
new alarm. The order in which the alarms are scanned to find the one to de-
lete is as follows:

1.

The oldest inactive alarm that is not waiting for an acknowledgment
(either the alarm doesn’t require an acknowledgment or it has already
been acknowledged).

The oldest active alarm that is not waiting for an acknowledgment
(either the alarm doesn’t require an acknowledgment or it has already
been acknowledged).

The oldest inactive alarm that is waiting for an acknowledgment.

The oldest active alarm that is‘waiting for an acknowledgment.

Navigating in the Alarm Summary

You can move around in the alarm summary using the keyboard keys, alarm
summary touch buttons, and function keys located directly below the touch
zone labels.
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Using Keyboard Keys
Key Description
Up Arrow Moves up one line in the alarm log
Down Arrow | Moves down one line in the alarm log
Page Up Returns to the previous page
Page Down | Moves to the next page
Home Moves to the beginning of the alarm log
End Moves to the end of the alarm log
Esc Exits the alarm summary

Using Alarm Summary Touch Buttons and Function Keys

If the target workstation for which you are configuring an application incor-
porates a touch screen, ten touch buttons (four of the six keys on 3100 target

workstations and ten on the 3200 target workstation) will display at the bot-
tom of the Alarm Summary screen and perform the following functions:
Table 14-1. Alarm Summary Touch Buttons

Touch Button

Description

Print

Prints the alarms displayed in the alarm summary
(The Print touch zone does not appear on the
3100, as the 3100 does not have printing capabili-
ties.)

Ack

Acknowledges the highlighted alarm

Del

Deletes the highlighted alarm

Up

Moves up one line in the alarm log

Down

Moves down one line in the alarm log

PgUp

Returns to the previous page

PgDwn

Moves to the next page

Home

Moves to the beginning of the alarm log

End

Moves to the end of the alarm log

Esc

Exits the alarm summary

14-8

272




Chapter 14 — Using the Run-time Engine

If your target workstation doesn’t have a touch screen, the Alarm Summary
buttons will still display on the bottom of your screen. The function keys lo-
cated below these buttons will perform the same functions when pressed.

Deleting Alarms

If you want to delete an alarm before the run-time engine does, use the up

and down arrow keys to highlight the log entry you want to delete. Then
press the DEL key.

Technical Note

You cannot delete an alarm that is waiting to be acknowleciged. You
must acknowledge it first, then delete it.

Any alarm with an “*” is active and cannot be deleted.

Acknowledging Alarms

To acknowledge an alarm while in the alarm summary, highlight the alarm
and press the Ack key. This will cause the alarm acknowledgment action.

Exiting the Alarm Summary

Press the ESC key to close the alarm summary screen.

Calculating the Number of Data Points

Each driver has a list of data points that it must scan. At any time, the num-
ber of driver data points can be calculated by combining data points used in

e Alarms
e Current screens and the Master Template

e The current recipe request (if a recipe has been requested)

14-9
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Exporting and Importing Data Points

This section provides details on how to export Comma Separated Variable
(CSV) files from the Development System and the steps for importing CSV
files into the Development System.

To export files...

1. Press the Export button.

2. A dialog box comes up for you to pick the file name you want to export.
3. Each data point is output to the chosen file.
4

Once the export is complete, you may edit the data points with an editor
that supports the CSV format..

To import files...
1. Press the Import button.

2. Double-click on the file name from the dialog box (default extension is
.CSV).

3. Verification process of the fields in the data point begins. If the data
point is illegal, processing will automatically terminate.

If a tag name is in use on this device, a dialog box comes up and asks if you
want to replace the tag. The dialog box choices are: Yes, Yes to All, and No
(default is Yes). If you choose No, the process is terminated.

If the tag is valid, it is added to the data point list.

Updating Data Points

14-10

Most driver data points have an associated update rate. The driver will only
update a data point after its scheduled update time has elapsed. The excep-
tion to this rule occurs when the user changes screens or issues a recipe re-
quest. When either of these situations occur, the drivers update all of their
data points for the new screen or recipe. This ensures that all data points for
the new screen or recipe are updated. Once this update has been completed,
the drivers revert to the configured update rate for each data point.
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Deleting Data Points

Each screen, alarm, and recipe in an application has a list of scanned data
points associated with it. The engine builds a scan table with screen, alarm,
and recipe data points. When a new screen is selected, the old screen data
points are removed from the scan table and the new screen data points are
added to the scan table.

Because data points cannot be deleted while they are being read, a delay may
occur when you change screens or issue recipe requests. This could be the
result of a PLC that is communicating very slowly, or, if a PLC is not con-
nected, the process of reading the data point may take as long as the timeout
configured for the PLC.

Understanding Error Codes

The run-time engine returns error codes associated with data display objects,
as defined in Table 14-2.

Table 14-2. Data Display Error Codes

Code | Definition

1 This is a permanent numerical error that the run-time engine cannot
resolve. For instance, you may have specified a PLC data point
value as an IEEE floating point and the attached PLC does not
specify values in this format.

M7 This indicates a temporary error. For example, the tag has not been
read yet or there is a communication error.

el This indicates the display fields are not large enough to display the
number. For example, if you set the data display shape to display 2
left digits and 2 right digits (##.##), and the PLC returns a value of
117.333, you will see **.** on the run-time engine screen.

1411
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Appendix A — Using Windows 95/NT

This appendix provides information on using the Windows 95/NT Operating
System with SoftScreen. For more detailed information, refer to your Win-

dows 95/NT documentation.

Keyboard and Mouse Conventions
Table A-1 defines the keyboard conventions used throughout the SoftScreen

manual.

Table A-1. Keyboard Conventions

Keyboard Convention

What It References

KEY+KEY

A key combination. To execute a key combi-
nation, press and hold the first key indicated
while you press the second key indicated.

KEY,KEY

A key sequence. In a key sequence, you
press and release the first key, then press
and release the second key.

Shortcut keys

Keyboard shortcuts. These make it possible
to access most menus and commands in
SoftScreen without having to use your
mouse. Keyboard shortcuts usually require
that keys be used in combinations such as
CTRL+S.

A-1
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Windows 95/NT Features

Windows

Table A-2 defines the mouse conventions used throughout this manual.

Table A-2. Mouse Conventions

Mouse Convention

What It Refers To

Mouse button

The primary mouse button. On a mouse with
multiple buttons, the left mouse button is con-
sidered the primary button. If you have config-
ured your mouse differently, use the button you
have designated as primary to execute most
mouse commands.

Occasionally, the secondary button may be
used to execute commands. The secondary
button will be referred to as “the right mouse
button.”

Point

Position the tip of the mouse pointer over what-
ever you want to point to on the screen.

Click

Quickly press and release the primary mouse
button one time. Occasionally you may be
asked to “double click” the mouse button. To do
this, press and release the primary mouse but-
ton two times in rapid succession.

Drag

Point, press, and hold down the primary mouse
button as you move the mouse. This command
is frequently used to select multiple items on the
screen.

This section defines Windows 95/NT features you will encounter when us-

ing SoftScreen.

When you start SoftScreen, the SoftScreen main window opens. This pro-
vides the menu options allowing you to create or open an application.

There are also windows associated with each of the tools within SoftScreen.
These windows contain the menus and menu commands associated with the
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tool you select. For instance, when you create or open an application, the
Application Navigator window displays on your computer screen. When you
open the Graphic Editor, the Graphic Editor window displays on your com-
puter screen.

Menus
Menus display a list of commands from which you can select. Click on a
menu command to select it.

Commands

Menus consist of drop-down lists of commands. There are several different
types of menu commands, which are identified by certain features, as de-
scribed in Table A-3.

Table A-3. Menu Command Features

Command Feature Definition

Grayed text Means the command is currently unavailable

Ellipsis (...) Accesses a dialog box. You must provide more
information in the dialog box before the com-
mand can be executed.

Arrow (») Accesses a submenu with more menu com-
mands
Check mark (v') Turns a feature on and off. A check mark indi-

cates the feature is selected. When selected,
the command performs an action immediately.

When a command has a keyboard shortcut, it appears to the right of the
menu name. For example, the keyboard shortcut for the Open command is
CTRL+O.

Dialog Boxes and Forms

To access a dialog box, click on a menu command followed by an ellipsis
(...). Dialog boxes are used when more information is needed to complete a

279



SoftScreen Development System for Windows User’s Guide

command. When a dialog box is active, you cannot perform any other func-
tion in SoftScreen until you exit it.

Forms generally access pages on which you must provide more information.
When forms are active, you can move among other SoftScreen elements.

Dialog boxes and forms contain a combination of buttons, check boxes, list
boxes, radio buttons, and text boxes, as described in Table A-4.

Table A-4. Dialog Box and Forms Features

Windows Feature Description

Buttons Initiate actions. Click on a button or press ALT+
the underlined letter in the name of the button to
perform its associated action.

Check boxes Turn on or off options. All, a few, or none of the
check boxes may be selected at one time. When
a check box is selected, an X appears. Click on
a check box to select or deselect an option.

List boxes Display a list of choices. You can choose one list
item in single-selection list boxes; you can
choose several or all list items in multiple-
selection list boxes.

Radio buttons Provide a related list of options. Radio buttons
are mutually exclusive; only one can be selected
at a time. A filled button indicates an option is
selected. Another option must be selected to
deselect the current option.

Text boxes Accept user-entered information.

The Window Menu

The Window menu is common to all SoftScreen tools. The commands on
this menu are described in Table A-5.
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Table A-5. Window Menu Commands

Command Definition
New Window Allows you to open a new window in the current tool
Cascade Arranges windows so they overlap, with their title

bars visible. This makes it easy to select any open
window. To switch between cascaded windows,
click on the window you want to view. This will bring
the selected window to the forefront.

Tile Horizontally Arranges open windows from the top edge of the
screen to the bottom edge of the screen, so that all
are visible and none overlap

Tile Vertically Arranges open windows side by side, so that all are
visible and none overlap

Arrange lcons Arranges icons in a row, so that none overlap

List of Open Windows | Appears at the bottom of the Window menu. The
windows are numbered in the order in which they
were opened (when you close a window, the list is
renumbered). The list holds up to 9 open windows.
If more than 9 are open, the More Windows com-
mand opens the Select Window dialog box, which
accesses all the open windows. A check mark indi-
cates the active window.

A-5
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You can create and customize up to 10 toolbars in SoftScreen. SoftScreen
ships with five default toolbars: Application, Data, Draw, Screen, and Stan-
dard. You can also create five custom toolbars.

SoftScreen also allows you to change the visibility, position, and orientation
of all toolbars.

Using Toolbar Buttons

Toolbar buttons allow you to access SoftScreen functions with the click of a
button. This section describes the toolbar buttons available in SoftScreen and
what features of the software they access.

When you place your cursor on any of the buttons, without pushing them,
you will receive a tool tip, as well as a description of the button on the status
bar. Tool tips provide a one- or two-word description of the button, helping
you to identify its function.

Application Toolbar

The Application toolbar provides the following buttons. Some of these but-
tons are available only when the Application Navigator is active.

Button | Description

Application Navigator
Graphic Editor

Data Editor

Configure Engine. This button is only available when Application Navi-
gator is active.

Cross Reference
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Button | Description

= Generate

Download

== Drivers. This button is only available when the Application Navigator is
: active.

Tag Browser

Data Toolbar

The Data Toolbar provides the following buttons:

Button | Description

Insert Symbol. This button is available only when you are able to
insert symbols.

Create Symbol. This button is available only when a symbol is se-
lected.

Passwords. This button is available only when the Application Navi-
gator is active.

Shape Properties. This button is available only when the Graphic
Editor is active and a shape is selected.

7 Animations. This button is available only when the Graphic Editor is
: active and a shape is selected.

Drawing Palette

The Drawing Palette is active only when the Graphic Editor is active. This
toolbar provides the following buttons.

Button | Description

Selection

@ Ellipse
Line
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Button

Description

Pie

Polyline

Arc

Square

Text Box

Rectangle

Touch Zone. This button is available only if you
have a target workstation that is configured with a
touch screen.

Polygon

Data Entry

Circle

Bitmap
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Screen Toolbar

The Screen Toolbar provides the following buttons:

Description
Select All

Flip Vertical

Grid

Align

Visibility

Group

Zoom In

Ungroup

Zoom Out

Bring to Front

Zoom Selected

Send to Back

Zoom to Window

Bring Forward

Rotate

Push Backward

Flip Horizontal

=3 ) ) e e
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Standard Toolbar

The Standard Toolbar provides the following buttons:

Viewing Toolbars

Description

New Application

Paste

m
@EE@
=1

Open

Undo

Close

Tl H

Delete

——

Exit

(@]

Print

Save Application

Help Topics

Cut

Using Help

Copy

About SoftScreen

You can show or hide toolbars, depending on your needs in the current ap-

plication.

To show or hide toolbars...

1. Select the Toolbars command on the View menu. The Toolbars dialog
box opens, as shown in Figure BB-11.
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Figure B-1. Toolbars Dialog Box

2. Click on the toolbars you want to show or hide. An x appears in the
checkbox when a toolbar is displayed.

3. Click on Close or press ENTER to return to the development system
screen.

Adding and Deleting Toolbar Buttons

SoftScreen allows you to choose which buttons you want to include on your
toolbars. The buttons are active in the tool in which they can be used and
grayed if they cannot be used in the current tool. For instance, the Draw
toolbar buttons (line, circle, square, etc.) are active in the Screen Editor, but
grayed in the other tools.

To add and delete toolbar buttons...

1. Select the Customize Toolbars command on the Options menu. The
Customize Toolbars form opens, as shown in Figure BB-22.
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Text Box.
Touch Zone..
Data Entry.

Figure B-2. Customize Toolbars Form

2. Click on the tab with the name of the toolbar you want to reconfigure.
For instance, if you want to reconfigure the Draw toolbar, click on the
Draw tab at the top of the form. The page associated with this toolbar
opens.

The Current Tool Buttons box lists the buttons currently on the selected
toolbar. The Available Tool Buttons box lists the buttons you can add to
the selected toolbar.

Technical Note

The buttons in the Available Tool Buttons box remain the same; the
buttons in the Current Tool Buttons box vary depending on the toolbar
selected. However, all toolbars have a separator button available. This
button separates groups of common buttons (for example, cut, copy,
and paste) from other buttons on the toolbar. You may use the separa-
tor button on a toolbar as many times as you want.

3. To remove a button currently on the toolbar, click on the name of the
button in the Current Tool Buttons box, then click on the Remove but-
ton. The selected button is removed from the Current Tool Buttons box.

B-7
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4. To add a button to the toolbar, click on the name of the button in the
Available Tool Buttons box, then click on the Add button. The selected
button is added to the Current Tool buttons box.

Technical Note

A new button is always added above the button highlighted in the Cur-
rent Tool Buttons list box.

5. Click on the Revert to Default button if you want to revert to the tool-
bar’s default settings. You can use this feature even after you have ac-
cepted the changes and exited the form.

6. If you want to see how the toolbar looks before configuring another
toolbar or before exiting the Customize Toolbars form, click on the Ap-
ply button. This applies the changes you have made to the toolbar. (You
may have to move the Customize Toolbars form to a new location in
your application window to view the toolbar.)

If you select the Apply button, you cannot cancel out of this form. The
Cancel button is dimmed and the OK button changes to a Close button.

7. Press ENTER to accept changes to the toolbar.

Positioning Toolbars in the Application Window

There are several ways you can position toolbars in the application window.
You can “dock” them on the top, bottom, or sides of the application window,
or you can “float” them anywhere in the application window. You can also
change their orientation, from vertical to horizontal or horizontal to vertical.

Docking Toolbars

To dock toolbars in the application window...

1. Click on the toolbar you want to dock and drag it to the side, top, or
bottom of the application window until it turns into an outline box. You
will not be able to move the toolbar unless you click on the gray area
surrounding the buttons, not on the buttons.
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Technical Note

If you place a horizontal toolbar against the side of the application
window, it will change its orientation from horizontal to vertical.
However, it will retain its orientation if you press CTRL while moving
it.

2. Release the mouse button to dock the toolbar in its new position.

Floating Toolbars

To float toolbars in the application window...

1. Click on the toolbar that you want to move, and drag it anywhere within
the application window. You will not be able to move the toolbar unless
you click on the gray area surrounding the buttons, not on the buttons.

2. Release the mouse button once you have found the ideal location. A
window, with a title bar, appears around the toolbar.
Changing Toolbar Orientation
To change the orientation of a toolbar (from horizontal to vertical or vertical

to horizontal), press SHIFT while clicking on the toolbar window. This
changes the toolbar to its new orientation.
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Index

A

actions
acknowledge alarm, 11-3
assignment, 11-3
change password level, 11-3
enable data entry, 11-4
go to alarm summary, 11-4
load recipe, 11-4
triggered by an alarm, 10-8
triggered by an event, 11-3
undoing, 6-11
addressing
data points, 3-2
internal register, 3-5
system clock, 3-5
system performance variables, 3-7
testing and debugging variables, 3-6
alarm display, 5-9
Alarm Display Window, 5-9, 14-6
alarm priorities, 5-7, 14-5
alarm shapes, example, 10-10, 10-11, 10-12
alarm summary, 5-9
alarm status, 14-6
configuring event/action to go to, 11-4
deleting alarms, 14-6
exiting, 14-9
viewing, 14-6
alarms
acknowledging, 14-6
actions, specifying, 4-40, 10-7
alarm shapes, creating, 10-9
analog, 10-4
configuring, 5-7
creating, 4-39

alarms (continued)
definition, 5-1, 10-1
deleting, 14-6
discrete, 10-5
into alarm settings, 10-6
logging, 14-6
out of alarm settings, 10-7
printing during run-time, 5-10
shape properties, 10-11
aligning shapes, 6-40
analog alarms, 10-4
animated text boxes, 6-20
animating shapes, 4-27
animations
background color, 7-3
fill pattern, 7-7
fill percent, 4-30, 7-12
foreground color, 4-28, 7-3
line color, 7-3
line type, 7-6
Line Width, 7-5
non-spatial, 7-1
ordering, 7-24
position, 4-34, 7-16
rotate, 4-32, 7-21
scale, 7-18
spatial, 7-1, 7-11
sweep angle, 4-34, 7-14
text, 7-8
visibility, 4-29, 7-10
applications
analyzing memory usage, 13-3
calculating memory requirements, 13-1
closing, 4-42, 5-15
converting, 2-2, 5-13

Index-1
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A (continued)

applications (continued)
creating, 5-2
downloading, 4-23
generating, 4-20, 4-42, 12-1
layering, 5-1
maximizing, 4-1
minimizing, 4-1
renaming, 5-4
saving, 4-4, 5-3, 6-47
arcs, drawing, 6-18
assigning event/actions, 4-16
assignments, recipe
failed, 9-6
posted, 9-5

background color

animating, 7-4

specifying, 6-34
backup copies, making, 2-1
baud rate, setting for download, 12-6
bitmaps

importing, 6-30

inserting, 4-5, 6-30

limitations, 6-30

target workstation, 6-37
bounding box, using to select shapes, 6-43
buttons, A-4

Cc

character limitations
engine, 6-20
expressions, 3-16
tag names, 3-1
check boxes, A-4
circles, drawing, 6-17
circular reference in expressions, 3-21

Index-2
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closing
applications, 4-42, 5-15
SoftScreen, 4-42
COM port errors, 4-25, 12-5
configuring
Alarm Display Window, 5-9
alarms, 5-7
constants, 3-11
data display shapes, 4-37
data entry shapes, 4-37
download port, 12-5
drivers, 5-12
keypad for event/actions, 4-17
master alarms, 5-8
run-time engine, 5-6
tags, 4-11
touch zones, 4-18
constants
configuring, 3-11
form, 3-12
indexing, 3-18
symbols, 8-28
contrast adjustment, 3-8
control graphic symbols, 8-18
conventions
dialog boxes, A-3
Windows, A-2
converting
applications, 5-13
customized SoftScreen symbols, 2-3
copying
applications, 5-3
screens, 6-6
shapes, 6-46
text, 4-1
creating
applications, 5-2
screen templates, 8-14
screens, 6-1
symbols, 8-7
cross reference tool, 3-23



Index

customizing symbol palette, 8-1
cutting

shapes, 6-46

text, 4-1

D

data display shapes, 6-22
Advanced properties, 6-23
configuring, 4-37
minimum/maximum values, 6-24
data, entering on run-time engine, 14-1

data entry, enabling through event/action, 114

data entry shapes
configuring, 4-37
displaying, 6-26, 6-29
drawing, 6-25
links, 6-27, 14-2
properties, 6-31
data points
addressing, 3-2
calculating number of in driver, 14-9
deleting during run-time, 14-11
resolving conflicts, 8-5
updating during run-time, 14-10
Data toolbar, B-2
deadband, setting for alarms, 10-5
deleting
drivers, 5-13
passwords, 6-8
screens, 6-49
symbols, 8-11
text, 4-1
description, providing for a shape, 6-36
development system
connecting to the target workstation
RS-232C connection, 2-4
RS-485 connection, 2-4
features, 1-1

dialog boxes, A-3
Alarm Shape Properties, 10-11
Align, 4-9, 6-40
Animations Ordering, 7-24
Change Current Address, 12-5
Configure Download Port, 4-25, 12-5
Configure Passwords, 6-8
Configure Physical Drivers, 5-12
Create Symbol, 8-7
Delete Symbol, 8-12, 8-13
File Download, 4-24, 12-4
Grid Settings, 6-38
Insert Symbol, 4-8, 8-4
Open, 6-30
Open Application, 5-5
Recipe Shape Properties, 9-7
Resolve Tag Names, 4-13, 8-5
Save Application As, 4-4, 5-3
Screen Properties, 6-6
Select Data Form, 10-3
Select New Target Workstation, 4-2, 5-14
Set Tag Name Notes, 8-8
Set Visibility, 6-25, 6-26, 6-29
Target Workstation Address, 4-24, 12-4
Target Workstation Memory List, 12-8
Toolbars, B-6
Zoom Settings, 6-12
discrete alarms, specifying, 10-5
DOS download disk, creating, 12-10
DOS download utility, using, 12-12
download
creating a DOS download disk, 12-10
port, configuring, 12-5
utility, 12-7
window, 12-7
drawing
animated text boxes, 6-20
arcs, 6-18
circles, 6-17
data display shapes, 6-22
data entry shapes, 6-25

Index-3
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D (continued) exiting SoftScreen, 4-42
expression symbols, 8-30
drawing (continued) expressions
ellipses, 6-17 characters, maximum number, 3-16
lines, 6-15 circular reference, 3-21
pies, 6-17 configuring, 3-15
polygons, 6-16 form, 3-16
polylines, 6-15 forward reference, 3-21
rectangles, 6-16 operators
squares, 6-15 numeric, 3-17
static text boxes, 6-19 string, 3-18
touch zones, 6-29
drivers F
configuring, 5-12
deleting, 5-13 features
development system, 1-1
E run-time engine, 1-2
Windows 95/NT, A-2
editing shapes, 6-46 ‘ fill pattern animation, 7-7
ellipses, drawing, 6-17 fill percent animation, 4-30, 7-12
engine and alarm configuration, 5-6 flipping shapes, 6-45
errors, run-time engine, 14-11 floating point numbers, IEEE 32-bit, 6-24, 7-2
evaluating tags, 3-20 foreground color
events animation, 4-28, 7-4
condition becomes false, 11-2 property, 6-34
condition becomes true, 11-2 forms, A-3
condition is false, 11-2 Application Navigator, 6-1
condition is true, 11-2 Configure Toolbars, B-7
key press, 11-2 Constants, 3-12
key release, 11-2 Expressions, 3-16
periodic timeout, 11-2 Internal Driver, 3-3
time, 11-2 Keyboard Driver, 3-9
timeout, 11-2 Strings, 3-14
touch zone forward reference in expressions, 3-21
press, 11-2
release, 11-3 G
event/actions
assigning, 4-16 general properties, shapes, 6-31
configuring multiple, 11-7 generating applications, 4-20, 4-42, 12-1
definition, 5-1, 11-1 global tags, 3-20
global, 11-1 graphic symbols, 8-21
local, 11-1
Index-4
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grid
displaying, 6-38
settings, changing, 6-39
turning on, off, 6-38
grouping shapes, 6-41

H
help. See on-line help

|
indexing

constants, 3-18

strings, 3-18
indicator symbols, 8-22
inserting

bitmaps, 4-5

symbols, 4-7, 8-2
installing SoftScreen, 2-1
internal address, setting, 3-4
internal driver

address, setting, 3-4

string access, setting, 3-4

tags, configuring, 3-3
internal names, shapes, 6-31

internal register addressing, 3-5
internal system variables, configuring, 3-11

constants, 3-11
expressions, 3-15
strings, 3-13

Internet address, technical support, 2-6

into alarm settings, 10-6
ISA symbols, 8-23

K

key press, 14-1
key press warning, 11-2

keyboard
conventions, A-1
shortcuts, A-1
using to enter data, 14-2
keyboard driver, 3-9
keypad, 4-17
configuring for event/actions, 4-17
pop-up, 5-6, 14-1
using to enter data, 14-2

L

limitations
bitmaps, 6-30
screens, 6-3
line color animation, 7-4
line type animation, 7-6
line width animation, 7-5
lines, drawing, 6-15
links, data entry shapes
configuring, 6-27
on the run-time engine, 14-2
list boxes, A-4
logging alarms, 14-6

master alarm shape, 14-5
master alarms, 5-8
master template
configuring, 4-5
definition, 4-5, 5-1
opening, 6-4
memory
allocation, 1-2
application requirements, 13-1
application usage, analyzing, 13-3
meter symbols, 8-21
minimum/maximum values, data display, 6-24
mistakes, undoing, 6-11
multi-drop connection, 2-4

Index-5
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N

naming
symbols, 8-8, 8-10
tags, 3-1

non-spatial animations
definition, 7-1
ordering, 7-24

0

on-line help, using, 1-2
opening
applications, 5-5
master template, 6-4
screens, 6-3
SoftScreen, 4-2
operators, using in expressions
numeric, 3-16
string, 3-18
ordering animations
non-spatial, 7-24
spatial, 7-25
ordering shapes
Bring Forward, 6-43
Bring to Front, 6-43
Push Backward, 6-43
Send to Back, 6-43
out of alarm settings, 10-7

P

passwords

changing, 6-8

configuring, 6-7

configuring event/action to change, 11-3

deleting, 6-8

entering on run-time engine, 14-3
pasting

screens, 6-6

shapes, 6-47

text, 4-1

Index-6
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pies, drawing, 6-17
pilot light symbols, §8-22
polygons, drawing, 6-16
polylines, drawing, 6-15
pop-up keypad

configuring, 5-6

using on run-time engine, 14-1
ports

RS-232C, 2-4

RS-485, 2-4
position animation, 4-34, 7-16
positioning shapes, 6-45
previewing screen before printing, 6-48
printing

alarms during run-time, 5-10

screens, 6-49
properties

alarm shapes, 10-11

default shape, 6-35

recipe shapes, 9-7

screen, 6-5

shape, 6-30
push button symbols, 8-27

R

radio buttons, A-4
readme.txt file, 2-2
recipe shapes, creating, 9-7
recipes
assignment, 9-4
failed, 9-6
posted, 9-5
definition, 5-1, 9-1
loading through an event/action, 11-4
queuing on the run-time engine, 14-5
rectangles, drawing, 6-16
rotating shapes, 6-44
registering SoftScreen, 2-7
renaming applications, 5-4
resolving data point conflicts, 8-5
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resources
on-line help, 1-2
technical support, 1-3
right mouse button, 4-1
rotate animation, 4-32, 7-21
run-time engine
alarm summary, viewing, 14-6
alarms
acknowledging, 14-9
deleting, 14-9
logging, 14-6
data points
calculating, 14-9
deleting, 14-11
updating, 14-10
data, entering, 14-1
errors, 14-11
passwords, entering, 14-3
recipes, queuing, 14-5
security level, changing, 14-3
using, 4-27
RS-232C port, 2-4
RS-485 port, 2-4
run-time engine features, 1-2

S

saving
applications, 5-3, 6-47
screens, 6-47
scale animation, 7-18
scientific notation, 14-2
screen color, changing, 6-5
screen properties, 6-5
screen color, changing, 6-5
security level, assigning, 6-9
Screen toolbar, B-4
screens
copying, 6-6
creating, 6-1
creating templates for, 8-14
custom zoom percentage, setting, 6-12

screens (continued)
deleting, 6-49
limitations, 6-3
magnification, changing, 6-12
opening, 6-3
pasting, 6-6
previewing before printing, 6-48
printing, 6-49
providing a description, 6-10
saving, 6-47
security level, assigning, 6-9
startup, specifying, 6-47
security level
assigning to a screen, 6-9
changing on run-time engine, 14-3
selecting shapes, 6-13
settings
into alarm, specifying, 10-6
out of alarm, specifying, 10-7
printer, 6-48
shape properties
data entry, 6-31
general, 6-31
style, 6-30
text, 6-31
shapes :
aborting drawing action, 6-14
alarm, 10-9
aligning, 6-40
animating, 4-27, 7-1
bounding box, 6-43
copying, 6-46
cutting, 6-46
default properties, setting, 6-35
definition, 6-13
deselecting, 6-14
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i shapes (continued)
S (continued) rotating, 6-44
shapes (continued) selecting, 6-13
drawing sizing, 6-43
animated text boxes, 6-20 ungrouping, 6-42
arcs, 6-18 X and Y coordinates, 6-10
circles, 6-17 shortcuts, keyboard, A-1
data display, 6-22 SoftScreen
data entry, 6-25 exiting, 4-42
ellipses, 6-17 installing, 2-1
lines, 6-15 opening, 4-2
pies, 6-17 registering, 2-7
polygons, 6-16 uninstalling, 2-3
polylines, 6-15 spatial animations
rectangles, 6-16 definition, 7-1
squares, 6-15 ordering, 7-25
static text boxes, 6-19 squares, drawing, 6-15
touch zones, 6-29 Standard toolbar, B-5
editing, 6-46 ’ startup screen, specifying, 6-47
flipping, 6-45 static text boxes, drawing, 6-19
grouping, 6-41 string symbols, 8-30
internal names, 6-31 strings
ordering, 6-42 characters, maximum number, 3-14
Bring forward, 6-43 configuring, 3-13
Bring to Front, 6-43 indexing, 3-18
Push Backward, 6-43 sweep angle animation, 4-34, 7-14
Send to Back, 6-43 symbol groups
pasting, 6-47 creating, 8-8, 8-10
positioning, 6-45 deleting, 8-11
properties symbol libraries, 8-17
background color, 6-34 constants, 8-28
data entry, 6-25 control graphics, 8-18
default, 6-35 expressions, 8-30
fill pattern, 6-34 graphics, 8-21
foreground color, 6-34 indicators, 8-22
general, 6-36 ISA symbols, 8-23
line color, 6-32 meters, 8-21
line type, 6-32 push buttons, 8-27
line width, 6-32 strings, 8-30
text, 6-19 symbol palette
providing a description, 6-36 customizing, 8-1
recipe, 9-7 inserting symbols with, 8-2
Index-8
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symbols
converting customized, 2-3
creating, 8-7
definition, 8-1
deleting, 8-11
inserting, 4-7, 8-2
naming, 8-8, 8-10
undoing, 8-12
system
recommendations, 1-1
requirements, 1-1
system clock, addressing, 3-5
system performance variables
addressing, 3-7
contrast, 3-8
evaluate cycle, 3-7
render cycle, 3-7
service cycle, 3-8

T

tag browser, 3-22
tag name guidelines, 3-1
tags
configuring, 3-1, 4-11
internal driver, 3-3
internal register, 3-5
system clock, 3-5
system performance variables, 3-7
testing and debugging variables, 3-6
copying, 3-22
defining as global, 3-20
drag and drop, 3-22
evaluating, 3-20
naming, 3-1
ordering, 3-20
type ahead feature, 3-21
types, 3-20
unresolved, 4-13, 8-5

target workstation
bitmap, turning on/off, 6-37
connecting to the development system, 2-
4
specifying, 4-2, 5-13
technical support, contacting
Internet address, 2-6
telephone number, 2-6
telephone number, technical support, 2-6
templates, 8-14
creating for screens, 8-14
deleting, 8-16
testing and debugging variables, 3-6
addressing, 3-6
OscCos, 3-7
OscSin, 3-7
rampdown, 3-6
rampup, 3-6
rampupdown, 3-7
random, 3-6
text
animated, 6-20
copying, 4-1
cutting, 4-1
data display, 6-22
deleting, 4-1
pasting, 4-1
properties, 6-31
size, 6-19
static, 6-19
text animation, 7-8
text boxes, A-4
tool tips, B-1
toolbars, B-1
buttons, B-1
adding, B-6
deleting, B-6
changing orientation, B-9
Data, B-2
hiding, B-5
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T (continued)

toolbars (continued)
positioning, B-8
docking, B-8
floating, B-9
Screen, B-4
showing, B-5
Standard, B-5
touch zones
configuring, 4-18
drawing, 6-29
using on run-time engine, 14-1
tutorial, 4-1

U

ungrouping shapes, 6-42
uninstalling SoftScreen, 2-3
unresolved tags, 4-13
utility, download, 12-7

Vv

values, entering
floating point, 7-2
scientific notation, 14-2
visibility animation, 4-29, 7-10
virtual memory allocation, 1-2

w

windows
closing, 4-7
list of open, A-5
Windows conventions
commands, A-3
dialog boxes, A-3
forms, A-3
menus, A-3
windows, A-2
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Windows features
buttons, A-4
check boxes, A-4
list boxes, A-4
radio buttons, A-4
text boxes, A-4

X

X and Y coordinates, screens, 6-10

Y4

zoom, percentages, changing, 6-12



	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	

