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The Pro-face/Xycom Profibus slave communication module, (from now on referred to
as the "COM-DPS"), allows OpenHMI to communicate on a Profibus network supporting
up to 255 bytes of I/O to and from the network.  The COM-DPS is only capable of
solicited communication. This means that the master controller, (PLC), provides
information displayed on the OpenHMI screen and requests the information required to
interact with the process.  The states of inputs and outputs at other nodes are acquired
passively, where the master controller issues these states to the COM-DPS.  This data
gathering function is not automatic. Therefore, logic must be created in the master
controller, directing information to both the intended I/O device and the COM-DPS.

This quick start will guide the user through the following processes:

1. Configuring the COM-DPS for the desired number of inputs and
outputs

2. Using SyCon, setup the SMSI Server

3. Generate a simple screen in Intouch to graphically display the
results

The configuration of the COM-DPS (using SyCon) is done on the Runtime Workstation.
Defining Tagnames in the SMSIServer and the Intouch application is typically done in the
development system environment.

Let us assume that a block of I/O exists at MacID (node address) 15.  This I/O block has 1
byte of input (produced) data and 1 byte of output (consumed) data.  The master
controller is programmed to read and write data to and from this I/O block in a polled
fashion.  The controller is also programmed to send the same data previously sent to the
I/O block, and the data it reads from the I/O block, to the COM-DPS, at MacID 9, for
representation on the screen.  In this way, the COM-DPS has an image of the inputs and
outputs of the I/O block.

Initial Configuration of Runtime Workstation

The first step is to configure the Slave Module for the correct number of inputs and
outputs.  This is done using a utility called SyCon (System Configurator).  SyCon is
provided free of charge as a demo version.  The only limitation of demo mode is that only
two network nodes can be configured.  Since the Slave module is the only node we need
to configure for the HMI application, demo mode is sufficient.
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Start SyCon by selecting it from the Program Group < SyCon System Configurator > in
the Start Menu.  From the Toolbar select File - New and from the bus selections pick
Profibus.  A blank (network configuration) page will appear on the screen.  SyCon is
designed such that a Master must be present on the network to allow slave devices to be
added.  For the purposes of configuring the Slave Module, a Profibus master must exist
on the network.

The Tool Button  is used to insert a master.

Move the insertion point to the upper left of the screen and click the left mouse button to
place the Master.  A selection window will appear containing various master modules.
Select “COM-DPM / PKV20-DPM” by clicking on it, then click on Add followed by OK.
The Profibus-Master should appear at the top of the display connected to the black
vertical bar representing the Profibus network.

Now the Slave Module can be added to the network.  Click on the Tool Button  or use
Insert - Slave.

Once done, an insertion point cursor will appear on the screen, representing the target
position where the Slave Module will exist on the network.  Move the insertion point
below the Profibus-Master and click the left mouse button to place the Slave Module.  A
selection window should appear on the screen containing various types of slave modules.
Select COM-DPS by double clicking on it or by single clicking on it, then clicking Add,
followed by OK.



Pro-face/Xycom Profibus Slave Communication Module (COM-DPS)

1-4

The COM-DPS should appear on the screen connected to the Profibus network as shown
below.

Right click on the COM-DPS and then select Slave Configuration, or (optionally) double
click on the COM-DPS to bring up the Slave Configuration window.
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Change the Station address to 9, (which is what we previously chose for this application).
Since the I/O block on the Profibus network, has 1 byte of input and 1 byte of output, the
COM-DPS will be set up for 2 bytes of output to allow the master controller to write the
input and output images of the I/O block to the COM-DPS.  Scroll down the table of
available Modules until you find “2 byte output [0x21]”.  Double click on it or select it
and then click on "Append Module", to add this data type to the configured modules in
the table below.  The changes to the configuration should look like the following screen.
Press enter now or click on the OK.

The COM-DPS is now configured for two bytes of output and Station address 9.  This
configuration must be downloaded to the flash memory within the COM-DPS.  Once
done, the COM-DPS will always power up running this configuration.

Right click on the COM-DPS and click on "Select as actual slave" in the pop up
window.  A blue box should appear around the icon for the COM_DPS.  This box
indicates that the device plugged into the computer is the actual device to be downloaded
to.  From the menu, select Online then Download.  A window will pop up asking if you
really want to download.  Select Yes.
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A board assignment window will pop up requiring Board 0 to be defined.  Pick the pull
down menu arrow for Board 0.  There should be at least two choices, "No device" and
"COM-DPS".  Pick COM-DPS.  Download of the configuration to the COM-DPS should
commence.

Now that the COM-DPS has been configured, save the session by choosing File - Save
from the menu bar.
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SMSI Server

The SMSI Server is the link between Intouch and the Device Driver for the COM-DPS
board.  Intouch communicates through a DDE link with the server.  The server shares the
same Tagname as Intouch and conveys the translation to the proper addresses at the Dual
Port Memory on the COM-DPS card.  The server must therefore be set up with Tagnames
and their appropriate offsets.  These Tagnames will likely be pre-established in the
development system environment.  The SMSI Server must read the COM-DPS directly to
gather the configuration information.  This information is saved as a file and can be later
transferred to and edited in the development system environment.

Invoke the SMSI Server from Start - Programs - SMSIServer - SMSIServer.  The
following window should appear on the screen.
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From the File menu, select New Board to bring up the following window.

Notice that under the Board Configured Device Listing, the COM-DPS appears in the
table.  The SMSIServer has automatically interrogated the COM-DPS to determine its
configuration.  Verify that it is set for Address 9, and that the Inputs are set to two and the
outputs are zero.

Any data that Intouch receives from the server is considered an input.  Data from Intouch
to the server is considered output.

Remember that the COM-DPS was configured for two bytes of output.  During this
configuration, SyCon uses the reference point of the master controller.  Therefore, data
sent to the COM-DPS from the controller is treated as output.  This same data from the
Intouch point of view is treated as input data.  This is why the server reports that there are
two bytes of input, rather than the 2 bytes of output that was previously configured.
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Click OK to accept this new board.  The following window should appear.  Click on Save
& Exit to save this configuration to a file.  Give it the name Example1.
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After Saving & Exiting, the screen below will appear. The SMSI Server automatically
generates status tags for the board, some of which will say unused if it is inappropriate for
the type of communication card plugged in.  Definitions for these status tags can be found
in the Help menu for the SMSI Server.
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Before exiting the server, it is necessary to set it up to automatically load Example1.io
whenever the SMSIServer is launched.  This will avoid any manual intervention.  Select
Settings – Startup Mode – Auto. This automatically loads the last file, (in this case
Example1.io).  Now exit the server.

The file Example1.io can now be transferred to the development system.  On the
development system, the file Example1.io should be placed in the folder C:\Program
Files\Synergetic\SMSIServer.
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Development System
Invoke the SMSI Server from Start - Programs - SMSIServer - SMSIServer.  The
following window should appear on the screen.
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From the File menu, select Open Board and pick Example.io to bring up the following
window.
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From the Edit menu, select Edit Board.  When the window pops up, click on the "+" sign
for Board0 to expand the tree as shown below.  Addr9 should now be seen, which
represents the COM-DPS at Station address 9.  Click on the icon for Addr9 to highlight it
then select Add.



Pro-face/Xycom Profibus Slave Communication Module (COM-DPS)

1-15

  A "Create Tag" window will appear as shown below.

We will call the input data, from the I/O block, "Data_In" and the output data to the I/O
block, "Data_Out".  Of these images of the I/O block’s inputs and outputs both are
written to the COM-DPS from the master controller and appear as inputs to Intouch.
Type in the first Tag name "Data_In".  You can optionally type in a meaningful
description for the Tag.  Leave the "Area" defaulted to Input, and select BYTE for "Data
type".  Click OK to accept this new Tag.  We should now be back at the Board0 edit
window with "Data_In" shown as a Tag under Addr9.
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Now click on the Addr9 icon again to highlight it and select "Add" to add the Tag
"Data_out".  Go through the same process as for the "Data_In" but since this is the second
of the two bytes, which will be sent to the COM-DPS, change the "Byte offset" from 0 to
1.  If there had been three bytes to be sent to the COM-DNS, the third byte would be Byte
offset 2, and so on.  Then select OK to accept this Tag.
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Now both Tags appear below Addr9.  Now click on Save & Exit to save the server's Tags
to the Example1 file.

After the Save & Exit the screen shown below appears. Scroll down the list of Tagnames
and note that the “Data_In” and “Data_Out” Tagnames just entered appear at the bottom.
Now exit the server.  The file, Example1.io should be found in the folder C:\Program
Files\Synergetic\SMSIServer. This file must be downloaded to the Runtime Workstation
system into the folder of the same name, C:\Program Files\Synergetic\SMSIServer.
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OpenHMI

Launch OpenHMI from Start - Programs - WonderWare FactorySuite - OpenHMI.
Create a new application and start Window Maker.  Create a new window by clicking on
the new window icon or by selecting "New Window" from the File menu.  Choose a
name for the window and window color then select OK.

Now we will create two value displays in the newly created window by utilizing the

"Wizards" tool.

Click on the Wizards tool to bring up the following selections.  Choose the "Value
Displays" and from the possible selections pick "Analog Tagname Display with Tagname
Text" followed by OK.
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Position the cursor in the application window where you want the Value Display and left
click the mouse to place it.  Intouch generates a temporary Tagname for the Value
Display, which must be changed.

Double click on the temporary Tagname to bring up the following window. Change the
temporary tagname to "Data_In", (previously entered into the SMSI Server).  The
Tagnames are case sensitive and must be entered in exactly as they were in the SMSI
Server.  Otherwise, communication between Intouch and the SMSI Server will be
impossible.  Change the "Number Format" to an integer value by clicking on the pull
down menu arrow and scrolling up to the single "0".  Select it and click on OK.
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A question will pop up asking if you want to define the Tagname "Data_In".  Click OK to
bring up the Tagname Dictionary.

Click on the Type button to define the Tag Type.  Click on I/O Integer followed by OK.
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Notice that additional information is now available at the bottom of the Tagname
Dictionary window.  The Access Name is used by Intouch to reference realtime I/O data
from a server such as the SMSI Server.

Click on the Access Name button and when the "Access Names" window appears, click
on "Add" to bring up the "Add Access Names" window. Type in "COM-DPS" as the
Access Name.  This name can be arbitrary, but try to make it meaningful by describing
the information linked to the Tagnames.  Fill in the Application Name with "smsiserver"
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and the Topic Name with "board0" followed by OK.  Unlike the Tagnames, the
Application Name and the Topic Names are not case sensitive.

Back at the Access Names window click on Close to return to the Tagname Dictionary"
window.  Click on the checkbox, "Use Tagname as Item Name" and note that the Item is
filled in automatically with the Tagname from above.

Click on Close to accept all the entries and to exit the Tagname Dictionary.  Now notice
that the Tagname, which Intouch pre-assigned to the Value Display now, reflects the
"Data_In" text.
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Create another Value Display as before but give it the Tagname "Data_Out".  The Access
name in the Tagname Dictionary should already indicate COM-DPS, so no further setup
is required.  When finished, the application window should look as follows.  From the
File menu, select Save Window to save the application.  Now exit Window Maker.  The
application can now be transferred to the Runtime Workstation using the techniques
previously described.

 A batch file must be set up to automatically launch the SMSI Server and
WindowViewer.
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