[Communication Drivers] ODVA EtherNet/IP Explicit Messaging Driver

Summary

Last Updated: May. 30, 2019

Details

Caution
Precautions for adding a new driver onto Windows Vista/7
Precautions for adding a new driver at Daylight Saving Time
Title ODVA EtherNet/IP Explicit Messaging Driver
Version Ver. 1.15.16
Supported Software The required versions of software for this driver installer are as follows.
GP-Pro EX Ver. 2.10.000 or later
Pro-Server EX Ver. 1.30.000 or later

You can check your version by "Help" function -> "Version Info".
Supported Devices
  • EtherNet/IP Explicit message server for External device
* The Implicit messaging has been evaluated with 8 external devices at the same time in our test environment.
  We support only evaluated devices. If you want to connect other device, please evaluate connectivity before use your system.
Supported Units Required versions depend on models.
Please check "Supported Models / Version" for the required versions of GP-Pro EX.

Required driver versions for different models are listed below
Model Required driver version
GP3000 Series Ver. 1.11.00 or later
LT3000 Series Ver. 1.11.00 or later
GP4100 Series (GP4104) Ver. 1.12.00 or later
GP4100 Series (GP4114) Ver. 1.14.07 or later
GP4000M Series Ver. 1.12.01 or later
GP4000 Series Ver. 1.12.00 or later
LT4000M Series Ver. 1.12.01 or later
SP5000 Series Ver. 1.13.01 or later
IPC Series for WinGP Ver. 1.11.00 or later
General PCs for WinGP Ver. 1.11.00 or later
Device/PLC
Connection Manual
For details, please read the "Device/PLC Connection Manual" in the lower part of this page.
For general information regarding Device connection and documentation conventions please refer to "Device/PLC Connection Manual".
Updated Content

[Ver. 1.15.16] (May 30, 2019)

The following defect is fixed:
  • When using 1:n connection of Implicit Messaging with a specified device, sometimes Input Data could not be read correctly.
 

How to install (This is a self-extracting file.)

Prior to installation, be sure to close all software applications that are running.
  1. Click on the file name in the lower part of this page to start downloading the file.
  2. After download is complete, double-click on the downloaded file to start installation.
  3. Follow the instructions on the screen.
  4. After installation, start GP-Pro EX.
  5. Select [ODVA] for "Manufacturer" and [EtherNet/IP Explicit Messaging] for "Series" in [Device/PLC] settings of [System Settings] on the [Project] menu.
When using the driver, be sure to refer to the Device Connection Manual PDF.
Also, for general information regarding Device connection and documentation conventions please refer to "Device/PLC Connection Manual".

Terms of use / Cautions

Please be acknowledged of the following terms of use before you use our download service.
Download of any file signifies your agreement to the terms of use.
Terms and conditions

Download file

Installer :
1.06 MB (1,112,496Byte)
Last update: 2019/05/30
Device/PLC Connection Manual :
696.99 KB (713,719Byte)
Last update: 2019/04/26

Update history

[Ver. 1.15.16] (May 30, 2019)

The following defect is fixed:
  • When using 1:n connection of Implicit Messaging with a specified device, sometimes Input Data could not be read correctly.

[Ver. 1.15.15] (Apr. 26, 2019)

The following setting was added:
  • When there are many "Individual Device Settings”, GP-Pro EX may be crashes when setting in “Individual Devices Setting” UI.
 

[Ver. 1.15.14] (Feb. 1, 2019)

The following defect is fixed:
  • Going offline on the display unit while running Implicit Messaging communication sometimes caused the sending of invalid commands.
 

[Ver. 1.15.12] (Jun. 28, 2018)

The following functionality was added:
  • Added Real Time Format selection.
  • Added Customer Explicit Message setting.
The following defect is fixed:
  • When using Implicit Messaging with a specified device, on stopping communication sometimes a socket error would display.
 

[Ver. 1.14.12]

The following defect is fixed:
  • When using Implicit Messaging with a specified device, the display unit would sometimes stop unexpectedly.
 

[Ver. 1.14.11]

The following defect is fixed:
  • Cannot communicate after Socket error occurs.

[Ver. 1.14.10]

The following defect is fixed:
  • Reading display unit information from the Transfer Tool sometimes failed.
 

[Ver. 1.14.09]

The following defect is fixed:
  • The use of Ethernet 2 port functionality by SP5000 series (SP-5B10) could result in communication errors.
 

[Ver. 1.14.08] (Feb. 9, 2017)

The following issue was fixed:
  • Transfer error is happened if user configured assembly instance over 256.
 

[Ver. 1.14.07]

The following issue was fixed:
  • Improve socket error indication handle.
 

[Ver. 1.14.06]

The following issue was fixed:
  • Cannot re-connect Implicit Messaging.
 

[Ver. 1.14.05]

The following issue was fixed:
  • Explicit Messaging custom feature is not working.
 

[Ver. 1.14.04] (Aug. 29, 2014)

The following functionality was added:
  • Support Implicit Messaging.
    * To use a Implicit Messaging Ver. 4.02.000 or later of GP-Pro EX is necessary.
  • Support Custom Explicit message.
 

[Ver. 1.13.01]

The following function was added:
  • The number of connectable devices was increased to 64.
 

[Ver. 1.12.01]

The following issues were fixed:
  • When the text with 103 words or more is written, a communication error can occur.
  • If the text with 52 words or more is written, with "StringPrefix" entered the value other than "0”, illegal data is written.
 

[Ver. 1.12.00]

The following functionality was added:
  • GP4104 is supported.
    * To use GP4104, Ver. 2.70.000 or later of GP-Pro EX is necessary.
  • GP4100 Series is supported.
    * To use a GP4000 series, Ver. 3.00.000 or later of GP-Pro EX is necessary.
 

[Ver. 1.11.00] (Nov. 13, 2009)

  • New