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Introduction

This manual describes how to connect the Display and the External Device (target PLC).

In this manual, the connection procedure will be described by following the below sections:

1 System Configuration

This section shows the types of External 

Devices which can be connected and SIO 

type.

"1 System Configuration" (page 3)

2 Selection of External Device

Select a model (series) of the External 

Device to be connected and connection 

method.

"2 Selection of External Device" (page 8)

3 Example of Communication Settings

This section shows setting examples for 

communicating between the Display and 

the External Device.

"3 Example of Communication Setting" 
(page 9)

4 Setup Items

This section describes communication 

setup items on the Display.

Set communication settings of the Display 

with GP-Pro Ex or in offline mode.

"4 Setup Items" (page 43)

5 Cable Diagram

This section shows cables and adapters 

for connecting the Display and the 

External Device.

"5 Cable Diagram" (page 48)

Operation
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1 System Configuration

The system configuration in the case when the External Device of LS ELECTRIC Co., Ltd. and the Display are 

connected is shown.

Series CPU*1 Link I/F SIO Type
Setting

Example

Cable 

Diagram

XGT

XGK-CPUE
XGK-CPUS
XGK-CPUA
XGK-CPUH
XGK-CPUU

CH1 port on XGL-C22A RS232C
"Setting Example 1" 
(page 9)

"Cable Diagram 1" 
(page 48)

CH2 port on XGL-C22A RS232C
"Setting Example 2" 
(page 11)

"Cable Diagram 1" 
(page 48)

CH1 port on XGL-C42A
RS422/485
(4 wire)

"Setting Example 3" 
(page 13)

"Cable Diagram 2" 
(page 51)

CH1 port on XGL-C42A
RS422/485
(2 wire)

"Setting Example 5" 
(page 17)

"Cable Diagram 3" 
(page 59)

CH2 port on XGL-C42A
RS422/485
(4 wire)

"Setting Example 4" 
(page 15)

"Cable Diagram 2" 
(page 51)

CH2 port on XGL-C42A
RS422/485
(2 wire)

"Setting Example 6" 
(page 19)

"Cable Diagram 3" 
(page 59)

CH1 port on XGL-CH2A RS232C
"Setting Example 1" 
(page 9)

"Cable Diagram 1" 
(page 48)

CH2 port on XGL-CH2A
RS422/485
(4 wire)

"Setting Example 4" 
(page 15)

"Cable Diagram 2" 
(page 51)

CH2 port on XGL-CH2A
RS422/485
(2 wire)

"Setting Example 6" 
(page 19)

"Cable Diagram 3" 
(page 59)

XGI-CPUU
XGI-CPUH
XGI-CPUS
XGI-CPUE
XGI-CPUU/D
XGI-CPUUN

CH1 port on XGL-C22A RS232C
"Setting Example 
12" (page 31)

"Cable Diagram 1" 
(page 48)

CH2 port on XGL-C22A RS232C
"Setting Example 
13" (page 33)

"Cable Diagram 1" 
(page 48)

CH1 port on XGL-C42A
RS422/485
(4 wire)

"Setting Example 
14" (page 35)

"Cable Diagram 2" 
(page 51)

CH1 port on XGL-C42A
RS422/485
(2 wire)

"Setting Example 
16" (page 39)

"Cable Diagram 3" 
(page 59)

CH2 port on XGL-C42A
RS422/485
(4 wire)

"Setting Example 
15" (page 37)

"Cable Diagram 2" 
(page 51)

CH2 port on XGL-C42A
RS422/485
(2 wire)

"Setting Example 
17" (page 41)

"Cable Diagram 3" 
(page 59)

CH1 port on XGL-CH2A RS232C
"Setting Example 
12" (page 31)

"Cable Diagram 1" 
(page 48)

CH2 port on XGL-CH2A
RS422/485
(4 wire)

"Setting Example 
15" (page 37)

"Cable Diagram 2" 
(page 51)

CH2 port on XGL-CH2A
RS422/485
(2 wire)

"Setting Example 
17" (page 41)

"Cable Diagram 3" 
(page 59)
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 Connection Configuration

• 1:1 Connection

• 1:n Connection

XGB

XBM-DR**S
XBM-DN**S
XBC-DR**H
XBC-DN**H

CH1 port on CPU RS232C
"Setting Example 7" 
(page 21)

"Cable Diagram 4" 
(page 66)

CH2 port on CPU
RS422/485
(2 wire)

"Setting Example 8" 
(page 23)

"Cable Diagram 5" 
(page 68)

XBL-C21A RS232C
"Setting Example 9" 
(page 25)

"Cable Diagram 1" 
(page 48)

XBL-C41A
RS422/485
(4 wire)

"Setting Example 
10" (page 27)

"Cable Diagram 2" 
(page 51)

XBL-C41A
RS422/485
(2 wire)

"Setting Example 
11" (page 29)

"Cable Diagram 3" 
(page 59)

*1 The CPU must be one of the following versions to use the link I/F module.
XGK: V2.0 or later
XGI: V2.1 or later
XBM: V3.03 or later
XBC H type: V2.02 or later
XBC S type: V1.1 or later

• Check the combination of the CPU version and the link I/F version with the external device 

manufacturer. When you use versions that are not supported, some features may not work 

properly. Check the version on the label of the unit or with the manufacturer's software.

Series CPU*1 Link I/F SIO Type
Setting

Example

Cable 

Diagram

Display
External Device

Display

External Device External Device External Device

The max number of Display: 16
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 IPC COM Port

When connecting IPC with an External Device, the COM port used depends on the series and SIO type. Please 

refer to the IPC manual for details.

Usable port

Series
Usable Port

RS-232C RS-422/485(4 wire) RS-422/485(2 wire)

PS-2000B
COM1*1 , COM2, 
COM3*1, COM4

*1 The RI/5V can be switched. Use the IPC’s switch to change if necessary.

- -

PS-3450A, PS-3451A,
PS3000-BA, PS3001-BD

COM1, COM2*1*2 COM2*1*2 COM2*1*2

PS-3650A (T41 model),
PS-3651A (T41 model)

COM1*1 - -

PS-3650A (T42 model),
PS-3651A (T42 model)

COM1*1*2, COM2 COM1*1*2 COM1*1*2

PS-3700A (Pentium®4-M)
PS-3710A

COM1*1, COM2*1, 
COM3*2 , COM4

*2 Set up the SIO type with the DIP Switch. Please set up as follows according to SIO type to be used.

COM3*2 COM3*2

PS-3711A COM1*1, COM2*2 COM2*2 COM2*2

PS4000*3 COM1, COM2 - -

PL3000
COM1*1*2, COM2*1, 
COM3, COM4

COM1*1*2 COM1*1*2

PE-4000B Atom N270 COM1, COM2 - -

PE-4000B Atom N2600 COM1, COM2
COM3*4 , COM4*4, 
COM5*4, COM6*4

COM3*4, COM4*4, 
COM5*4, COM6*4

PS5000 (Slim Panel Type 
Core i3 Model) *5 *6 COM1, COM2*4 COM2*4 COM2*4

PS5000 (Slim Panel Type 
Atom Model) 
*5 *6

COM1, COM2*7 COM2*7 COM2*7

PS5000 (Enclosed Panel 
Type)*8 COM1 - -

PS5000 (Modular Type 
PFXPU/PFXPP)*5 *6

PS5000 (Modular Type 
PFXPL2B5-6)

COM1*7 COM1*7 COM1*7

PS5000 (Modular Type 
PFXPL2B1-4)

COM1, COM2*7 COM2*7 COM2*7

PS6000 (Advanced Box)
PS6000 (Standard Box)

COM1*9 *10 *10

PS6000 (Basic Box) COM1*9 COM1*9 COM1*9
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DIP Switch settings (PL3000 / PS3000 Series)

RS-232C

*3 When making communication between an External Device and COM port on the Expansion slot,             
only RS-232C is supported. However, ER (DTR/CTS) control cannot be executed because of the             
specification of COM port.
For connection with External Device, use user-created cables and disable Pin Nos. 1, 4, 6 and 9.
Please refer to the IPC manual for details of pin layout.

*4 Set up the SIO type with the BIOS. Please refer to the IPC manual for details of BIOS.

*5 When setting up communication between an External Device and the RS-232C/422/485 interface           
module, use the IPC (RS-232C) or PS5000 (RS-422/485) cable diagrams. However, when using            
PFXZPBMPR42P2 in a RS-422/485 (4-wire) configuration with no flow control, connect 7.RTS+           
and 8.CTS+, and connect 6.RTS- and 9.CTS-.
When using RS-422/485 communication with External Devices, you may need to reduce the            
transmission speed and increase the TX Wait time.

*6 To use RS-422/485 communication on the RS-232C/422/485 interface module, the DIP Switch           
setting is required. Please refer to "Knowledge Base" (FAQs) on the support site. (http://www.pro-             
face.com/trans/en/manual/1001.html)

*7 Set up the SIO type with the DIP Switch. Please refer to the IPC manual for details of DIP Switch.
The BOX Atom has not a switch to set the RS-232C, RS-422/485 mode. Use the BIOS for the                 
setting.

*8 For the connection with the External Device, on the user-created cable read as if the connector on                
the Display-side is a M12 A-coding 8 pin socket. The pin assignment is the same as described in                 
the cable diagram. For the M12 A-coding connector, use PFXZPSCNM122.

*9 In addition to COM1, you can also use the COM port on the optional interface.

*10 Install the optional interface in the expansion slot.

DIP Switch Setting Description

1 OFF*1

*1 When using PS-3450A, PS-3451A, PS3000-BA and PS3001-BD, turn ON the set value.

Reserved (always OFF)

2 OFF
SIO type: RS-232C

3 OFF

4 OFF Output mode of SD (TXD) data: Always output

5 OFF Terminal resistance (220)  insertion to SD (TXD): None

6 OFF Terminal resistance (220)  insertion to RD (RXD): None

7 OFF Short-circuit of SDA (TXA) and RDA (RXA): Not available

8 OFF Short-circuit of SDB (TXB) and RDB (RXB): Not available

9 OFF
RS (RTS) Auto control mode: Disabled

10 OFF

Settings FAQ ID

PFXZPBMPR42P2, RS422/485 change method FA263858

PFXZPBMPR42P2 termination resistor setting FA263974

PFXZPBMPR44P2, RS422/485 change method FA264087

PFXZPBMPR44P2 termination resistor setting FA264088
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RS-422/485 (4 wire)

RS-422/485 (2 wire)

DIP Switch Setting Description

1 OFF Reserved (always OFF)

2 ON
SIO type: RS-422/485

3 ON

4 OFF Output mode of SD (TXD) data: Always output

5 OFF Terminal resistance (220)  insertion to SD (TXD): None

6 OFF Terminal resistance (220)  insertion to RD (RXD): None

7 OFF Short-circuit of SDA (TXA) and RDA (RXA): Not available

8 OFF Short-circuit of SDB (TXB) and RDB (RXB): Not available

9 OFF
RS (RTS) Auto control mode: Disabled

10 OFF

DIP Switch Setting Description

1 OFF Reserved (always OFF)

2 ON
SIO type: RS-422/485

3 ON

4 OFF Output mode of SD (TXD) data: Always output

5 OFF Terminal resistance (220)  insertion to SD (TXD): None

6 OFF Terminal resistance (220)  insertion to RD (RXD): None

7 ON Short-circuit of SDA (TXA) and RDA (RXA): Available

8 ON Short-circuit of SDB (TXB) and RDB (RXB): Available

9 ON
RS (RTS) Auto control mode: Enabled

10 ON
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2 Selection of External Device

Select the External Device to be connected to the Display.

Setup Items Setup Description

Number of Devices/
PLCs

Enter an integer from 1 to 4 to define the number of Devices/PLCs to connect to the display.

Manufacturer Select the manufacturer of the External Device to connect. Select "LS ELECTRIC Co., Ltd.".

Series

Select the External Device model (series) and the connection method. Select "XGT/XGB 
Series Cnet".
In System configuration, make sure the External Device you are connecting is supported by 
"XGT/XGB Series Cnet".

"1 System Configuration" (page 3)

Port Select the Display port to connect to the External Device.

Use System Area

Check this option to synchronize the system data area of the Display and the device (memory) 
of the External Device. When synchronized, you can use the External Device’s ladder program 
to switch the display or display the window on the Display.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"
This feature can also be set in GP-Pro EX or in the Display's offline mode.

Cf. GP-Pro EX Reference Manual "System Settings [Display Unit] - [System Area] 
Settings Guide"

Cf. Maintenance/Troubleshooting Guide "Main Unit - System Area Settings"
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3 Example of Communication Setting

The following shows examples of communication settings of the Display and the External Device, which is 

recommended by Pro-face.

3.1 Setting Example 1

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG-PD Editor) to configure communication settings for the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 Select base and slot which using module is connected from [Standard settings] tab in offline, and [Communication 

Module Settings] dialog box is displayed.

3 Select “Cnet” from [Type], and click [OK].

4 Select [Connect] from [Online] menu.

5 Select [Read IO Information] from the [Online] menu.

6 Double click [Cnet] from the [Standard settings] tab, and [Standard Settings-Cnet] dialog box is displayed.

7 Set [Channel 1] setup items as follows, and click [OK].

8 Select [Write Parameter] from the [Online] menu, and [Write Parameter] dialog box is displayed.

9 Select using module, and click [OK].

10 Select [Reset] from the [Online] menu.

Setup Item Setting Value

Type RS232C

Speed 38400

Data Bit 8

Stop Bit 1

Parity Bit NONE

Modem Type Null Modem

Station 0

Active mode XGT server
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3.2 Setting Example 2

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG-PD Editor) to configure communication settings for the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 Select base and slot which using module is connected from [Standard settings] tab in offline, and [Communication 

Module Settings] dialog box is displayed.

3 Select “Cnet” from [Type], and click [OK].

4 Select [Connect] from [Online] menu.

5 Select [Read IO Information] from the [Online] menu.

6 Double click [Cnet] from the [Standard settings] tab, and [Standard Settings-Cnet] dialog box is displayed.

7 Set [Channel 2] setup items as follows, and click [OK].

8 Select [Write Parameter] from the [Online] menu, and [Write Parameter] dialog box is displayed.

9 Select using module, and click [OK].

10 Select [Reset] from the [Online] menu.

Setup Item Setting Value

Type RS232C

Speed 38400

Data Bit 8

Stop Bit 1

Parity Bit NONE

Modem Type Null Modem

Station 0

Active mode XGT server



XGT/XGB Series Cnet Driver   

GP-Pro EX Device/PLC Connection Manual 13

3.3 Setting Example 3

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

• When the link unit you are using is before O/S version 2.3, you need to set the [Wait To Send] 

to 1 millisecond or longer.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG-PD Editor) to configure communication settings for the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 Select base and slot which using module is connected from [Standard settings] tab in offline, and [Communication 

Module Settings] dialog box is displayed.

3 Select “Cnet” from [Type], and click [OK].

4 Select [Connect] from [Online] menu.

5 Select [Read IO Information] from the [Online] menu.

6 Double click [Cnet] from the [Standard settings] tab, and [Standard Settings-Cnet] dialog box is displayed.

7 Set [Channel 1] setup items as follows, and click [OK].

8 Select [Write Parameter] from the [Online] menu, and [Write Parameter] dialog box is displayed.

9 Select using module, and click [OK].

10 Select [Reset] from the [Online] menu.

Setup Item Setting Value

Type RS485

Speed 38400

Data Bit 8

Stop Bit 1

Parity Bit NONE

Modem Type Null Modem

Station 0

Active mode XGT server
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3.4 Setting Example 4

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

• When the link unit you are using is before O/S version 2.3, you need to set the [Wait To Send] 

to 1 millisecond or longer.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG-PD Editor) to configure communication settings for the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 Select base and slot which using module is connected from [Standard settings] tab in offline, and [Communication 

Module Settings] dialog box is displayed.

3 Select “Cnet” from [Type], and click [OK].

4 Select [Connect] from [Online] menu.

5 Select [Read IO Information] from the [Online] menu.

6 Double click [Cnet] from the [Standard settings] tab, and [Standard Settings-Cnet] dialog box is displayed.

7 Set [Channel 2] setup items as follows, and click [OK].

8 Select [Write Parameter] from the [Online] menu, and [Write Parameter] dialog box is displayed.

9 Select using module, and click [OK].

10 Select [Reset] from the [Online] menu.

Setup Item Setting Value

Type RS485

Speed 38400

Data Bit 8

Stop Bit 1

Parity Bit NONE

Modem Type Null Modem

Station 0

Active mode XGT server
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3.5 Setting Example 5

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

• When the link unit you are using is before O/S version 2.3, you need to set the [Wait To Send] 

to 1 millisecond or longer.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG-PD Editor) to configure communication settings for the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 Select base and slot which using module is connected from [Standard settings] tab in offline, and [Communication 

Module Settings] dialog box is displayed.

3 Select “Cnet” from [Type], and click [OK].

4 Select [Connect] from [Online] menu.

5 Select [Read IO Information] from the [Online] menu.

6 Double click [Cnet] from the [Standard settings] tab, and [Standard Settings-Cnet] dialog box is displayed.

7 Set [Channel 1] setup items as follows, and click [OK].

8 Select [Write Parameter] from the [Online] menu, and [Write Parameter] dialog box is displayed.

9 Select using module, and click [OK].

10 Select [Reset] from the [Online] menu.

Setup Item Setting Value

Type RS485

Speed 38400

Data Bit 8

Stop Bit 1

Parity Bit NONE

Modem Type Null Modem

Station 0

Active mode XGT server
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3.6 Setting Example 6

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

• When the link unit you are using is before O/S version 2.3, you need to set the [Wait To Send] 

to 1 millisecond or longer.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG-PD Editor) to configure communication settings for the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 Select base and slot which using module is connected from [Standard settings] tab in offline, and [Communication 

Module Settings] dialog box is displayed.

3 Select “Cnet” from [Type], and click [OK].

4 Select [Connect] from [Online] menu.

5 Select [Read IO Information] from the [Online] menu.

6 Double click [Cnet] from the [Standard settings] tab, and [Standard Settings-Cnet] dialog box is displayed.

7 Set [Channel 2] setup items as follows, and click [OK].

8 Select [Write Parameter] from the [Online] menu, and [Write Parameter] dialog box is displayed.

9 Select using module, and click [OK].

10 Select [Reset] from the [Online] menu.

Setup Item Setting Value

Type RS485

Speed 38400

Data Bit 8

Stop Bit 1

Parity Bit NONE

Modem Type Null Modem

Station 0

Active mode XGT server
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3.7 Setting Example 7

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG-PD Editor) to configure communication settings for the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 From the [File] menu, select [New File], and create the XGB project.

3 From the [Online] menu, select [Connect].

4 From the [Online] menu, select [Read IO Information].

5 In the [Standard settings] tab, double-click [Embedded Cnet] to display the [Standard Settings-Cnet] dialog box.

6 Set the [Channel 1] setup items as follows, and click [OK].

7 From the [Online] menu, select [Write Parameter] to display the [Write Parameter] dialog box.

8 Select the module to use, and click [OK].

9 From the [Online] menu, select [Reset].

• To read the project from the External Device, select [Open from PLC...].

Setup Item Setting Value

Type RS232C

Speed 38400

Data Bit 8

Stop Bit 1

Parity Bit NONE

Modem Type Null Modem

Station 0

Active mode XGT server
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3.8 Setting Example 8

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG-PD Editor) to configure communication settings for the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 From the [File] menu, select [New File], and create the XGB project.

3 From the [Online] menu, select [Connect].

4 From the [Online] menu, select [Read IO Information].

5 In the [Standard settings] tab, double-click [Embedded Cnet] to display the [Standard Settings-Cnet] dialog box.

6 Set the [Channel 2] setup items as follows, and click [OK].

7 From the [Online] menu, select [Write Parameter] to display the [Write Parameter] dialog box.

8 Select the module to use, and click [OK].

9 From the [Online] menu, select [Reset].

• To read the project from the External Device, select [Open from PLC...].

Setup Item Setting Value

Type RS485

Speed 38400

Data Bit 8

Stop Bit 1

Parity Bit NONE

Modem Type Null Modem

Station 0

Active mode XGT server
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3.9 Setting Example 9

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.



XGT/XGB Series Cnet Driver   

GP-Pro EX Device/PLC Connection Manual 26

 Settings of External Device

Use the LS ELECTRIC setting tool (XG-PD Editor) to configure communication settings for the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 From the [File] menu, select [New File] and create the XGB project.

3 From the [Online] menu, select [Connect].

4 From the [Online] menu, select [Read IO Information].

5 In the [Standard settings] tab, double-click [Cnet] to display the [Standard Settings-Cnet] dialog box.

6 Set the [Channel 2] setup items as follows, and click [OK].

7 From the [Online] menu, select [Write Parameter] to display the [Write Parameter] dialog box.

8 Select the module to use, and click [OK].

9 From the [Online] menu, select [Reset].

• To read the project from the External Device, select [Open from PLC...].

Setup Item Setting Value

Type RS232C

Speed 38400

Data Bit 8

Stop Bit 1

Parity Bit NONE

Modem Type Null Modem

Station 0

Active mode XGT server
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3.10 Setting Example 10

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG-PD Editor) to configure communication settings for the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 From the [File] menu, select [New File], and create the XGB project.

3 From the [Online] menu, select [Connect].

4 From the [Online] menu, select [Read IO Information].

5 In the [Standard settings] tab, double-click [Cnet] to display the [Standard Settings-Cnet] dialog box.

6 Set the [Channel 2] setup items as follows, and click [OK].

7 From the [Online] menu, select [Write Parameter] to display the [Write Parameter] dialog box.

8 Select the module to use, and click [OK].

9 From the [Online] menu, select [Reset].

• To read the project from the External Device, select [Open from PLC...].

Setup Item Setting Value

Type RS485

Speed 38400

Data Bit 8

Stop Bit 1

Parity Bit NONE

Modem Type Null Modem

Station 0

Active mode XGT server
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3.11 Setting Example 11

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG-PD Editor) to configure communication settings for the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 From the [File] menu, select [New File], and create the XGB project.

3 From the [Online] menu, select [Connect].

4 From the [Online] menu, select [Read IO Information].

5 In the [Standard settings] tab, double-click [Cnet] to display the [Standard Settings-Cnet] dialog box.

6 Set the [Channel 2] setup items as follows, and click [OK].

7 From the [Online] menu, select [Write Parameter] to display the [Write Parameter] dialog box.

8 Select the module to use, and click [OK].

9 From the [Online] menu, select [Reset].

• To read the project from the External Device, select [Open from PLC...].

Setup Item Setting Value

Type RS485

Speed 38400

Data Bit 8

Stop Bit 1

Parity Bit NONE

Modem Type Null Modem

Station 0

Active mode XGT server
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3.12 Setting Example 12

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG5000) to configure communication settings on the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 From the [Project] menu, select [New Project].

3 Set "PLC Series" and "CPU type", and click [OK].

4 In the tree view, double-click [I/O Parameter].

5 Set the link I/F you are using and click [Apply].

6 In the tree view, right-click [Network Configuration] and from the shortcut menu select [Add Item]-[Network].

7 For the [Network type] select "Cnet", and click [OK].

8 Right-click the newly created network and from the shortcut menu select [Add Item]-[Communication Module].

9 For the [PLC type] select the newly created PLC, and click [OK].

10 From the tree view, in the newly created network double-click PLC to display the [Standard Settings - Cnet] 

dialog box.

11 Set [Channel 1] setup items as follows, and click [OK].

[Standard Settings] tab

[Advanced Settings] tab

12 From the [Online] menu, select [Write].

13 Select the External Device, and click [OK].

14 Restart the External Device.

Setup Item Setting Value

Type RS232C

Speed 38400

Station No. 0

Operation Mode XGT server

Setup Item Setting Value

Data Bit 8

Stop Bit 1

Parity Bit NONE
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3.13 Setting Example 13

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG5000) to configure communication settings on the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 From the [Project] menu, select [New Project].

3 Set "PLC Series" and "CPU type", and click [OK].

4 In the tree view, double-click [I/O Parameter].

5 Set the link I/F you are using and click [Apply].

6 In the tree view, right-click [Network Configuration] and from the shortcut menu select [Add Item]-[Network].

7 For the [Network type] select "Cnet", and click [OK].

8 Right-click the newly created network and from the shortcut menu select [Add Item]-[Communication Module].

9 For the [PLC type] select the newly created PLC, and click [OK].

10 From the tree view, in the newly created network double-click PLC to display the [Standard Settings - Cnet] 

dialog box.

11 Set [Channel 2] setup items as follows, and click [OK].

[Standard Settings] tab

[Advanced Settings] tab

12 From the [Online] menu, select [Write].

13 Select the External Device, and click [OK].

14 Restart the External Device.

Setup Item Setting Value

Type RS232C

Speed 38400

Station No. 0

Operation Mode XGT server

Setup Item Setting Value

Data Bit 8

Stop Bit 1

Parity Bit NONE
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3.14 Setting Example 14

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

• When the link unit you are using is before O/S version 2.3, you need to set the [Wait To Send] 

to 1 millisecond or longer.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG5000) to configure communication settings on the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 From the [Project] menu, select [New Project].

3 Set "PLC Series" and "CPU type", and click [OK].

4 In the tree view, double-click [I/O Parameter].

5 Set the link I/F you are using and click [Apply].

6 In the tree view, right-click [Network Configuration] and from the shortcut menu select [Add Item]-[Network].

7 For the [Network type] select "Cnet", and click [OK].

8 Right-click the newly created network and from the shortcut menu select [Add Item]-[Communication Module].

9 For the [PLC type] select the newly created PLC, and click [OK].

10 From the tree view, in the newly created network double-click PLC to display the [Standard Settings - Cnet] 

dialog box.

11 Set [Channel 1] setup items as follows, and click [OK].

[Standard Settings] tab

[Advanced Settings] tab

12 From the [Online] menu, select [Write].

13 Select the External Device, and click [OK].

14 Restart the External Device.

Setup Item Setting Value

Type RS485

Speed 38400

Station No. 0

Operation Mode XGT server

Setup Item Setting Value

Data Bit 8

Stop Bit 1

Parity Bit NONE
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3.15 Setting Example 15

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

• When the link unit you are using is before O/S version 2.3, you need to set the [Wait To Send] 

to 1 millisecond or longer.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG5000) to configure communication settings on the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 From the [Project] menu, select [New Project].

3 Set "PLC Series" and "CPU type", and click [OK].

4 In the tree view, double-click [I/O Parameter].

5 Set the link I/F you are using and click [Apply].

6 In the tree view, right-click [Network Configuration] and from the shortcut menu select [Add Item]-[Network].

7 For the [Network Type] select "Cnet", and click [OK].

8 Right-click the newly created network and from the shortcut menu select [Add Item]-[Communication Module].

9 For the [PLC type] select the newly created PLC, and click [OK].

10 From the tree view, in the newly created network double-click PLC to display the [Standard Settings - Cnet] 

dialog box.

11 Set [Channel 2] setup items as follows, and click [OK].

[Standard Settings] tab

[Advanced Settings] tab

12 From the [Online] menu, select [Write].

13 Select the External Device, and click [OK].

14 Restart the External Device.

Setup Item Setting Value

Type RS485

Speed 38400

Station No. 0

Operation Mode XGT server

Setup Item Setting Value

Data Bit 8

Stop Bit 1

Parity Bit NONE
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3.16 Setting Example 16

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

• When the link unit you are using is before O/S version 2.3, you need to set the [Wait To Send] 

to 1 millisecond or longer.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG5000) to configure communication settings on the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 From the [Project] menu, select [New Project].

3 Set "PLC Series" and "CPU type", and click [OK].

4 In the tree view, double-click [I/O Parameter].

5 Set the link I/F you are using and click [Apply].

6 In the tree view, right-click [Network Configuration] and from the shortcut menu select [Add Item]-[Network].

7 For the [Network type], select "Cnet", and click [OK].

8 Right-click the newly created network and from the shortcut menu select [Add Item]-[Communication Module].

9 For the [PLC type] select the newly created PLC, and click [OK].

10 From the tree view, in the newly created network double-click PLC to display the [Standard Settings - Cnet] 

dialog box.

11 Set [Channel 1] setup items as follows, and click [OK].

[Standard Settings] tab

[Advanced Settings] tab

12 From the [Online] menu, select [Write].

13 Select the External Device, and click [OK].

14 Restart the External Device.

Setup Item Setting Value

Type RS485

Speed 38400

Station No. 0

Operation Mode XGT server

Setup Item Setting Value

Data Bit 8

Stop Bit 1

Parity Bit NONE
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3.17 Setting Example 17

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

• When the link unit you are using is before O/S version 2.3, you need to set the [Wait To Send] 

to 1 millisecond or longer.
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 Settings of External Device

Use the LS ELECTRIC setting tool (XG5000) to configure communication settings on the External Device.

Refer to your External Device manual for details.

1 Start up the setting tool.

2 From the [Project] menu, select [New Project].

3 Set "PLC Series" and "CPU type", and click [OK].

4 In the tree view, double-click [I/O Parameter].

5 Set the link I/F you are using and click [Apply].

6 In the tree view, right-click [Network Configuration] and from the shortcut menu select [Add Item]-[Network].

7 For the [Network type] select "Cnet", and click [OK].

8 Right-click the newly created network and from the shortuct menu select [Add Item]-[Communication Module].

9 For the [PLC type] select the newly created PLC, and click [OK].

10 From the tree view, in the newly created network double-click PLC to display the [Standard Settings - Cnet] 

dialog box.

11 Set [Channel 2] setup items as follows, and click [OK].

[Standard Settings] tab

[Advanced Settings] tab

12 From the [Online] menu, select [Write].

13 Select the External Device, and click [OK].

14 Restart the External Device.

Setup Item Setting Value

Type RS485

Speed 38400

Station No. 0

Operation Mode XGT server

Setup Item Setting Value

Data Bit 8

Stop Bit 1

Parity Bit NONE
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4 Setup Items

Set communication settings of the Display with GP-Pro EX or in offline mode of the Display.

The setting of each parameter must be identical to that of External Device.

"3 Example of Communication Setting" (page 9)

4.1 Setup Items in GP-Pro EX

 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Setup Items Setup Description

SIO Type Select the SIO type to communicate with the External Device.

Speed Select speed between the External Device and the Display.

Data Length Select data length.

Parity Select how to check parity.

Stop Bit Select stop bit length.

Flow Control
Select the communication control method to prevent overflow of transmission and 
reception data.

Timeout
Use an integer from 1 to 127 to enter the time (s) for which the Display waits for the 
response from the External Device.

Retry
In case of no response from the External Device, use an integer from 0 to 255 to enter how 
many times the Display retransmits the command.

Wait To Send
Use an integer from 0 to 255 to enter standby time (ms) for the Display from receiving 
packets to transmitting next commands.
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 Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

RI/VCC
You can switch RI/VCC of the 9th pin when you select RS232C for SIO type.
It is necessary to change RI/5V by changeover switch of IPC when connect with IPC. 
Please refer to the manual of the IPC for more detail.

• Refer to the GP-Pro EX Reference Manual for Indirect Device.

Cf. GP-Pro EX Reference Manual "Changing the Device/PLC at Runtime (Indirect 
Device)"

Setup Items Setup Description

Series Select the series of the External Device.

Station No.
Use an integer from 0 to 31 to enter the Station No. of the External Device. (Initial value 
[0])

Setup Items Setup Description
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4.2 Setup Items in Offline Mode

 Communication Settings

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings] in offline mode. Touch the 

External Device you want to set from the displayed list.

• Refer to the Maintenance/Troubleshooting guide for information on how to enter offline mode 

or about the operation.

Cf. Maintenance/Troubleshooting Guide "Offline Mode"

• The number of the setup items to be displayed for 1 page in the offline mode depends on the 

Display in use. Please refer to the Reference manual for details.

Setup Items Setup Description

SIO Type

Select the SIO type to communicate with the External Device.

To make the communication settings correctly, confirm the serial interface specifications of 
Display unit for [SIO Type].
We cannot guarantee the operation if a communication type that the serial interface does not 
support is specified.
For details concerning the serial interface specifications, refer to the manual for Display 
unit.

Speed Select speed between the External Device and the Display.

Data Length Select data length.

Parity Select how to check parity.

Stop Bit Select stop bit length.

Flow Control
Select the communication control method to prevent overflow of transmission and reception 
data.
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 Device Setting

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Equipment Settings]. Touch the 

External Device you want to set from the displayed list, and touch [Device].

Timeout (s)
Use an integer from 1 to 127 to enter the time (s) for which the Display waits for the 
response from the External Device.

Retry
In case of no response from the External Device, use an integer from 0 to 255 to enter how 
many times the Display retransmits the command.

Wait To Send (ms)
Use an integer from 0 to 255 to enter standby time (ms) for the Display from receiving 
packets to transmitting next commands.

Setup Items Setup Description

Device/PLC name
Select the External Device to set. The device name is set up in GP-Pro EX. (Initial value 
[PLC1])

Series Display the series of the External Device.

Station No.
Use an integer from 0 to 31 to enter the Station No. of the External Device. (Initial value 
[0])

Setup Items Setup Description
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 Option

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Equipment Settings]. Touch the 

External Device you want to set from the displayed list, and touch [Option].

Setup Items Setup Description

RI/VCC
Switches RI/VCC of the 9th pin.
It is necessary to change RI/5V by changeover switch of IPC when connect with IPC. 
Please refer to the manual of the IPC for more detail.

• GP-4100 series, GP-4*01TM, GP-Rear Module, LT-4*01TM and LT-Rear Module do not 

have the [Option] setting in the offline mode.
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5 Cable Diagram

The cable diagram shown below may be different from the cable diagram recommended by LS ELECTRIC Co., 

Ltd. Please be assured there is no operational problem in applying the cable diagram shown in this manual.

• The FG pin of the External Device body must be D-class grounded. Please refer to the manual of the External 

Device for more details.

• SG and FG are connected inside the Display. When connecting SG to the External Device, design the system 

not to form short-circuit loop.

• Connect the isolation unit, when communication is not stabilized under the influence of a noise etc.

Cable Diagram 1

Display

(Connection Port)
Cable Notes

GP3000 (COM1)
GP4000*1 (COM1)
SP5000*2 (COM1/2)
SP-5B00 (COM1)
ST3000 (COM1)
ST6000 (COM1)
STM6000 (COM1)
STC6000 (COM1)
ET6000 (COM1)
LT3000 (COM1)
IPC*3

PC/AT

*1 All GP4000 models except GP-4100 Series and GP-4203T

*2 Except SP-5B00

*3 Only the COM port which can communicate by RS-232C can be used.
" IPC COM Port" (page 5)

1A User-created cable Cable length: 15m or less

GP-4105 (COM1)
GP-4115T (COM1)
GP-4115T3 (COM1)

1B User-created cable Cable length: 15m or less

LT-4*01TM (COM1)
LT-Rear Module (COM1) 1C

RJ45 RS-232C Cable (5m) by Pro-face
PFXZLMCBRJR21 Cable length: 5m or less
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1A)

1B)

Display

Display side

D-Sub 9pin (socket)

Signal namePin

1

2

3

4

5

6

7

8

CD

RD(RXD)

SD(TXD)

ER(DTR)

SG

DR(DSR)

RS(RTS)

CS(CTS)

External Device side

D-Sub 9pin (plug)

Signal namePin

1

3

2

4

5

6

7

8

CD

TxD

RxD

DTR

SG

DSR

RTS

CTS

Shell

Shield

Display

Signal name

CD

RD(RXD)

SD(TXD)

ER(DTR)

SG

DR(DSR)

RS(RTS)

CS(CTS)

External Device side
D-Sub 9pin (plug)

Signal namePin

1

3

2

4

5

6

7

8

CD

TxD

RxD

DTR

SG

DSR

RTS

CTS

Shell

Shield
Display side 

Terminal block
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1C)

Number Name Notes

(1)
RJ45 RS-232C Cable (5m) by Pro-face

PFXZLMCBRJR21

External Device side
D-Sub 9pin (plug)

Signal namePin

1

3

2

4

5

6

7

8

CD

TxD

RxD

DTR

SG

DSR

RTS

CTS

Shell

Display

GND

TXD

RXD

(1)
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Cable Diagram 2

Display

(Connection Port)
Cable Notes

GP3000*1 (COM1)
AGP-3302B (COM2)
GP-4*01TM (COM1)
GP-Rear Module (COM1)
ST3000*2 (COM2)
LT3000 (COM1)
IPC*3

*1 All GP3000 models except AGP-3302B

*2 Except AST-3211A and AST-3302B

*3 Only the COM port which can communicate by RS-422/485 (4 wire) can be used.  (Except PE-4000B, PS5000,                 
and PS6000)
" IPC COM Port" (page 5)

2A

COM port conversion adapter by Pro-face
CA3-ADPCOM-01 

+
Terminal block conversion adapter by Pro-face

CA3-ADPTRM-01
+

User-created cable

Cable length: 
500m or less

2B User-created cable

GP3000*4 (COM2)

*4 All GP3000 models except GP-3200 series and AGP-3302B

2C

Online adapter by Pro-face
CA4-ADPONL-01

+
Terminal block conversion adapter by Pro-face

CA3-ADPTRM-01
+

User-created cable

Cable length: 
500m or less

2D

Online adapter by Pro-face
CA4-ADPONL-01

+
User-created cable

GP-4106 (COM1)
GP-4116T (COM1)

2E User-created cable
Cable length: 
500m or less

GP4000*5 (COM2)
GP-4201T (COM1)
SP5000*6 (COM1/2)
SP-5B00 (COM2)
ST6000*7 (COM2)
ST-6200 (COM1)
STM6000 (COM1)
STC6000 (COM1)
ET6000*8 (COM2)
PS6000 (Basic Box) 
(COM1/2)

*5 All GP4000 models except GP-4100 Series, GP-4*01TM, GP-Rear Module, GP-4201T and GP-4*03T

*6 Except SP-5B00

*7 Except ST-6200

2F

RS-422 Terminal Block Conversion Adapter by Pro-face
PFXZCBADTM1*9

+
User-created cable

Cable length: 
500m or less

2B User-created cable

PE-4000B*10

PS5000*10

PS6000 (Optional 
Interface)*10

2G User-created cable
Cable length: 
500m or less
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2A)

• 1:1 Connection

• 1:n Connection

*8 Due to the COM port specifications, flow control is not possible. Omit wiring the control pins on the Display                  
side of the cable diagram.

*9 When using a Terminal Block Conversion Adapter (CA3-ADPTRM-01) instead of the RS-422 Terminal Block             
Conversion Adapter, refer to Cable Diagram 2A.

*10 Only the COM port which can communicate by RS-422/485 (4 wire) can be used.
" IPC COM Port" (page 5)

Signal name

RDB

SDB
SG
FG

CA3-ADPCOM-01

CA3-ADPTRM-01

Display

Shield Terminal block
External Device

RDA

SDA

Signal name
TX+

TX-

RX+

TERM

RX-

SG

User-created cable

120 Ω (1/2W)

Terminal
resistance

Display side 
Terminal block

120 Ω (1/2W)

Terminal
resistance

120 Ω (1/2W)

Terminal
resistance

Signal name

RDB

SDB
SG
FG

CA3-ADPCOM-01

CA3-ADPTRM-01

Display

Shield Terminal block
External Device

RDA

SDA

Signal name
TX+

TX-

RX+

TERM

RX-

SG

User-created cable

Display side 
Terminal block

120 Ω (1/2W)

Terminal
resistance

Shield Terminal block
External Device

Signal name
TX+

TX-

RX+
RX-

SG

120 Ω (1/2W)

Terminal
resistance

120 Ω (1/2W)

Terminal
resistance
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2B)

• 1:1 Connection

• 1:n Connection

Display

Signal name

3

7

1

2

5

4

8

9

6

SDA

SDB

RDA

RDB

SG

ERA

CSA

ERB

CSB

Pin

Display side

D-Sub 9pin (socket)
External Device side

Terminal Block

RX+

Signal name

RX-

TX+

TX-

SG

Shell

Shield

Display

Signal name

3

7

1

2

5

4

8

9

6

SDA

SDB

RDA

RDB

SG

ERA

CSA

ERB

CSB

Pin

Display side

D-Sub 9pin (socket)
External Device side

Terminal Block

External Device side

Terminal Block

RX+

Signal name

RX-

TX+

TX-

SG

Shell

Shield

RX+

Signal name

RX-

TX+

TX-

SG

Shield
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2C)

• 1:1 Connection

• 1:n Connection

Signal name

RDB

SDB
SG
FG

CA4-ADPONL-01

CA3-ADPTRM-01

Display

Shield Terminal block
External Device

RDA

SDA

Signal name
TX+

TX-

RX+

TERM

RX-

SG

User-created cable

120 Ω (1/2W)

Terminal
resistance

Display side 
Terminal block

120 Ω (1/2W)

Terminal
resistance

120 Ω (1/2W)

Terminal
resistance

Signal name

RDB

SDB
SG
FG

CA4-ADPONL-01

CA3-ADPTRM-01

Display

Shield Terminal block
External Device

RDA

SDA

Signal name
TX+

TX-

RX+

TERM

RX-

SG

User-created cable

Display side 
Terminal block

120 Ω (1/2W)

Terminal
resistance

Shield Terminal block
External Device

Signal name
TX+

TX-

RX+
RX-

SG

120 Ω (1/2W)

Terminal
resistance

120 Ω (1/2W)

Terminal
resistance
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2D)

• 1:1 Connection

• 1:n Connection

Display

Signal name

9

3

8

2

7

1

5

TERMTX

SDA

SDB

RDA

RDB

TERMRX

SG

Pin

Display side
D-Sub 9pin (plug)

External Device side
Terminal Block

RX+

Signal name

RX-

TX+

TX-

SG

Shell

Shield

CA4-ADPONL-01

User-created cable

Display

Signal name

9

3

8

2

7

1

5

TERMTX

SDA

SDB

RDA

RDB

TERMRX

SG

Pin

Display side
D-Sub 9pin (plug)

External Device side
Terminal Block

External Device side
Terminal Block

RX+

Signal name

RX-

TX+

TX-

SG

Shell

Shield

RX+

Signal name

RX-

TX+

TX-

SG

Shield

CA4-ADPONL-01

User-created cable
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2E)

• 1:1 Connection

• 1:n Connection

*1 The resistance in the Display is used as the termination resistance. Set the value of the DIP Switch on the 
rear of the Display as shown in the table below.  

DIP Switch No. Set Value

1 ON

2 ON

3 ON

4 ON

Display

Signal name

SDA

SDB

RDA

RDB

SG

ERA

CSA

ERB

CSB

External Device side
Terminal Block

RX+

Signal name

RX-

TX+

TX-

SG

Shield
Display side 

Terminal block

Termination
 resistance*1

Termination
 resistance*1

Display

Signal name

SDA

SDB

RDA

RDB

SG

ERA

CSA

ERB

CSB

External Device side
Terminal Block

External Device side
Terminal Block

RX+

Signal name

RX-

TX+

TX-

SG

Shield

RX+

Signal name

RX-

TX+

TX-

SG

Shield
Termination

 resistance*1

Termination
 resistance*1

Display side 
Terminal block
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2F)

• 1:1 Connection

• 1:n Connection

Signal name

RDB

SDB
SG
FG

PFXZCBADTM1

Display

Shield Terminal block
External Device

RDA

SDA

Signal name
TX+

TX-

RX+

TERM

RX-

SG

User-created cable

120 Ω (1/2W)

Terminal
resistance

Display side 
Terminal block

120 Ω (1/2W)

Terminal
resistance

120 Ω (1/2W)

Terminal
resistance

Signal name

RDB

SDB
SG
FG

PFXZCBADTM1

Display

Shield Terminal block
External Device

RDA

SDA

Signal name
TX+

TX-

RX+

TERM

RX-

SG

User-created cable

Display side 
Terminal block

120 Ω (1/2W)

Terminal
resistance

Shield Terminal block
External Device

Signal name
TX+

TX-

RX+
RX-

SG

120 Ω (1/2W)

Terminal
resistance

120 Ω (1/2W)

Terminal
resistance
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2G)

• 1:1 Connection

• 1:n Connection

Display

Signal name

2

1

3

4

5

7

8

9

6

Tx+

Tx-

Rx+

Rx-

GND

NC

NC

NC

NC

Pin

Display side
D-Sub 9pin (socket)

External Device side
Terminal Block

RX+

Signal name

RX-

TX+

TX-

SG

Shell

Shield

Display

Signal name

2

1

3

4

5

7

8

9

6

Tx+

Tx-

Rx+

Rx-

GND

NC

NC

NC

NC

Pin

Display side
D-Sub 9pin (socket)

External Device side
Terminal Block

External Device side
Terminal Block

RX+

Signal name

RX-

TX+

TX-

SG

Shell

Shield

RX+

Signal name

RX-

TX+

TX-

SG

Shield
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Cable Diagram 3

Display

(Connection Port)
Cable Notes

GP3000*1 (COM1)
AGP-3302B (COM2)
GP-4*01TM (COM1)
GP-Rear Module (COM1)
ST3000*2 (COM2)
LT3000 (COM1)

3A

COM port conversion adapter by Pro-face
CA3-ADPCOM-01 

+
Terminal block conversion adapter by Pro-face

CA3-ADPTRM-01
+

User-created cable

The cable length 
must be 500m or less.

3B User-created cable

GP3000*3 (COM2)

3C

Online adapter by Pro-face
CA4-ADPONL-01

+
Terminal block conversion adapter by Pro-face

CA3-ADPTRM-01
+

User-created cable
The cable length 
must be 500m or less.

3D

Online adapter by Pro-face
CA4-ADPONL-01

+
User-created cable

IPC*4
3E

COM port conversion adapter by Pro-face
CA3-ADPCOM-01 

+
Terminal block conversion adapter by Pro-face

CA3-ADPTRM-01
+

User-created cable

The cable length 
must be 500m or less.

3F User-created cable

GP-4106 (COM1)
GP-4116T (COM1)

3G User-created cable The cable length 
must be 500m or less.

GP-4107 (COM1)
GP-4*03T*5 (COM2)
GP-4203T (COM1)

3H User-created cable The cable length 
must be 500m or less.

GP4000*6 (COM2)
GP-4201T (COM1)
SP5000*7 (COM1/2)
SP-5B00 (COM2)
ST6000*8 (COM2)
ST-6200 (COM1)
STM6000 (COM1)
STC6000 (COM1)
ET6000*9 (COM2)
PS6000 (Basic Box) 
(COM1/2)

3I

RS-422 terminal block conversion adapter by Pro-face
PFXZCBADTM1*10

+
User-created cable

The cable length 
must be 500m or less.

3B User-created cable

LT-4*01TM (COM1)
LT-Rear Module (COM1) 3J

RJ45 RS-485 Cable (5m) by Pro-face
PFXZLMCBRJR81 The cable length 

must be 5m or less.
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3A)

PE-4000B*11

PS5000*11

PS6000 (Optional 
Interface)*11

3K User-created cable The cable length 
must be 500m or less.

*1  All GP3000 models except AGP-3302B

*2 Except AST-3211A and AST-3302B

*3  All GP3000 models except GP-3200 series and AGP-3302B

*4 Only the COM port which can communicate by RS-422/485 (2 wire) can be used.  (Except PE-4000B, PS5000,                 
and PS6000)
" IPC COM Port" (page 5)

*5 Except GP-4203T

*6 All GP4000 models except GP-4100 series, GP-4*01TM, GP-Rear Module, GP-4201T and GP-4*03T

*7 Except SP-5B00

*8 Except ST-6200

*9 Due to the COM port specifications, flow control is not possible. Omit wiring the control pins on the Display                  
side of the cable diagram.

*10 When using a Terminal Block Conversion Adapter (CA3-ADPTRM-01) instead of the RS-422 Terminal Block             
Conversion Adapter, refer to Cable Diagram 3A.

*11 Only the COM port which can communicate by RS-422/485 (2 wire) can be used.
" IPC COM Port" (page 5)

Display

(Connection Port)
Cable Notes

Signal name

SDA

SDB

TERMRX
SG
FG

CA3-ADPCOM-01

CA3-ADPTRM-01

Display

Display side
Terminal block

Shield

External Device side
Terminal block

RDA

RDB

Signal name
RX+

TX+

RX-
TX-

SG

User-created cable

Terminal
resistance
120Ω (1/2W)
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3B)

3C)

Terminal
resistance

120Ω (1/2W)

Display

Signal name Signal name

1

3

2

7

5

4

8

9

6

RDA

SDA

RDB

SDB

SG

ERA

CSA

ERB

CSB

Pin

Display side
D-Sub 9pin (socket)

External Device side
Terminal block

Shell

Shield

RX+

TX+

RX-

TX-

SG

Terminal
resistance
120Ω (1/2W)

User-created cable

Signal name

SDA

SDB

TERMRX
SG
FG

CA4-ADPONL-01

CA3-ADPTRM-01

Display

Display side
Terminal block

Shield

External Device side
Terminal block

RDA

RDB

Signal name
RX+

TX+

RX-
TX-

SG

User-created cable

Terminal
resistance
120Ω (1/2W)
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3D)

3E)

Display

Signal name

2

3

7

8

1

5

RDA

SDA

RDB

SDB

TERMRX

SG

Pin

Display side
D-Sub 9pin (plug)

External Device side
Terminal block

Shell

Shield

RX+

Signal name

TX+

RX-

TX-

SG

Terminal
resistance
120Ω (1/2W)

User-created cable

CA4-ADPONL-01

Signal name

SDA

SDB

TERMRX
SG

Shell

CA3-ADPCOM-01

CA3-ADPTRM-01

Display

Display side
Terminal block

Shield

External Device side
Terminal block

RDA

RDB

Signal name
TX+

RX+

TX-
RX-

SG

User-created cable

Terminal
resistance
120Ω (1/2W)
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3F)

3G)

*1 The resistance in the Display is used as the termination resistance. Set the value of the DIP Switch on the 
rear of the Display as shown in the table below.  

DIP Switch No. Set Value

1 OFF

2 OFF

3 ON

4 ON

Terminal
resistance

120Ω (1/2W)

Display

Signal name

1

2

3

7

5

4

8

9

6

DATA+

DATA-

NC

NC

SG

ERA

CSA

ERB

CSB

Pin

Display side
D-Sub 9pin (socket)

External Device side
Terminal block

Shell

Shield

TX+

Signal name

RX+

TX-

RX-

SG

Terminal
resistance
120Ω (1/2W)

User-created cable

Signal name

RDB

SDB

SG
ERA
CSA

ERB
CSB

Display

Display side
Terminal block

Shield

External Device side
Terminal block

RDA

SDA

Signal name
TX+

TX-

RX+
RX-

SG

User-created cable

Terminal
resistance
120Ω (1/2W)

Terminal
resistance *1
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3H)

3I)

Terminal
resistance

120Ω (1/2W)

Display

Signal name

3

8

1

2

5

4

6

7

9

LINE+

LINE-

NC

NC

SG

RS

SV

NC

NC

Pin

Display side
D-Sub 9pin (socket)

External Device side
Terminal block

Shell

Shield

TX+

Signal name

TX-

RX+

RX-

SG

Terminal
resistance
120Ω (1/2W)

User-created cable

Signal name

RDB

SDB

SG
TERM

FG

Display

Display side
Terminal block

Shield

External Device side
Terminal block

RDA

SDA

Signal name
TX+

TX-

RX+
RX-

SG

User-created cable

Terminal
resistance
120Ω (1/2W)

Terminal
resistance

120Ω (1/2W)

PFXZCBADTM1
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3J)

3K)

Number Name Notes

(1)
RJ45 RS-485 Cable (5m) by Pro-face

PFXZLMCBRJR81

External Device side
Terminal block

TX+

Signal name

RX+

TX-

RX-

SG

Terminal
resistance
120Ω (1/2W)Display

GND

D0

D1

(1)

Terminal
resistance

120Ω (1/2W)

Display

Signal name

2

1

3

7

5

4

8

9

6

DATA+

DATA-

NC

NC

GND

NC

NC

NC

NC

Pin

Display side
D-Sub 9pin (socket)

External Device side
Terminal block

Shell

Shield

TX+

Signal name

RX+

TX-

RX-

SG

Terminal
resistance
120Ω (1/2W)

User-created cable
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Cable Diagram 4

4A)

Display

(Connection Port)
Cable Notes

GP3000 (COM1)
GP4000*1 (COM1)
SP5000*2 (COM1/2)
SP-5B00 (COM1)
ST3000 (COM1)
ST6000 (COM1)
STM6000 (COM1)
STC6000 (COM1)
ET6000 (COM1)
LT3000 (COM1)
IPC*3

PC/AT

*1 All GP4000 models except GP-4100 Series and GP-4203T

*2 Except SP-5B00

*3 Only the COM port which can communicate by RS-232C can be used.
" IPC COM Port" (page 5)

4A User-created cable Cable length: 15m or less

GP-4105 (COM1)
GP-4115T (COM1)
GP-4115T3 (COM1)

4B User-created cable Cable length: 15m or less

LT-4*01TM (COM1)
LT-Rear Module 
(COM1)

4C
RJ45 RS-232C Cable (5m) by Pro-face

PFXZLMCBRJR21 Cable length: 5m or less

Display

Signal name

1

2

3

4

5

6

7

8

CD

RD

SD

ER

SG

DR

RS

CS

Pin

Display side
D-Sub 9pin (socket)

External Device side
Terminal block

Shell

Shield

-

Signal name

TX

RX

+

SG

User-created cable
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4B)

4C)

Number Name Notes

(1)
RJ45 RS-232C Cable (5m) by Pro-face

PFXZLMCBRJR21

Display

External Device side
Terminal blockShield

TX

Signal name

RX

SG

-

+

Display side
Terminal block

RD

Signal name

SD

SG

RS

CS

User-created cable

External Device side
Terminal block

-

Signal name

TX

RX

+

SG

Display

GND

TXD

RXD

(1)
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Cable Diagram 5

Display

(Connection Port)
Cable Notes

GP3000*1 (COM1)
AGP-3302B (COM2)
GP-4*01TM (COM1)
GP-Rear Module (COM1)
ST3000*2 (COM2)
LT3000 (COM1)

5A

COM port conversion adapter by Pro-face
CA3-ADPCOM-01 

+
Terminal block conversion adapter by Pro-face

CA3-ADPTRM-01
+

User-created cable

The cable length 
must be 500m or less.

5B User-created cable

GP3000*3 (COM2)

5C

Online adapter by Pro-face
CA4-ADPONL-01

+
Terminal block conversion adapter by Pro-face

CA3-ADPTRM-01
+

User-created cable
The cable length 
must be 500m or less.

5D

Online adapter by Pro-face
CA4-ADPONL-01

+
User-created cable

IPC*4
5E

COM port conversion adapter by Pro-face
CA3-ADPCOM-01 

+
Terminal block conversion adapter by Pro-face

CA3-ADPTRM-01
+

User-created cable

The cable length 
must be 500m or less.

5F User-created cable

GP-4106 (COM1)
GP-4116T (COM1)

5G User-created cable The cable length 
must be 500m or less.

GP-4107 (COM1)
GP-4*03T*5 (COM2)
GP-4203T (COM1)

5H User-created cable The cable length 
must be 500m or less.

GP4000*6 (COM2)
GP-4201T (COM1)
SP5000*7 (COM1/2)
SP-5B00 (COM2)
ST6000*8 (COM2)
ST-6200 (COM1)
STM6000 (COM1)
STC6000 (COM1)
ET6000*9 (COM2)
PS6000 (Basic Box) 
(COM1/2)

5I

RS-422 terminal block conversion adapter by Pro-face
PFXZCBADTM1*10

+
User-created cable

The cable length 
must be 500m or less.

5B User-created cable

LT-4*01TM (COM1)
LT-Rear Module (COM1) 5J

RJ45 RS-485 Cable (5m) by Pro-face
PFXZLMCBRJR81 The cable length 

must be 5m or less.
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5A)

PE-4000B*11

PS5000*11

PS6000 (Optional 
Interface)*11

5K User-created cable The cable length 
must be 500m or less.

*1  All GP3000 models except AGP-3302B

*2 Except AST-3211A and AST-3302B

*3  All GP3000 models except GP-3200 series and AGP-3302B

*4 Only the COM port which can communicate by RS-422/485 (2 wire) can be used.  (Except PE-4000B, PS5000,                 
and PS6000)
" IPC COM Port" (page 5)

*5 Except GP-4203T

*6 All GP4000 models except GP-4100 series, GP-4*01TM, GP-Rear Module, GP-4201T and GP-4*03T

*7 Except SP-5B00

*8 Except ST-6200

*9 Due to the COM port specifications, flow control is not possible. Omit wiring the control pins on the Display                  
side of the cable diagram.

*10 When using a Terminal Block Conversion Adapter (CA3-ADPTRM-01) instead of the RS-422 Terminal Block             
Conversion Adapter, refer to Cable Diagram 5A.

*11 Only the COM port which can communicate by RS-422/485 (2 wire) can be used.
" IPC COM Port" (page 5)

Display

(Connection Port)
Cable Notes

Signal name

RDB

RDA

SDA
SG
FG

CA3-ADPCOM-01

CA3-ADPTRM-01

Display

Display side
Terminal block

Shield
External Device side

Terminal block
TERM

SDB

Signal name
-

+

SG
TX

RX

User-created cable

Terminal
resistance
120Ω (1/2W)



XGT/XGB Series Cnet Driver   

GP-Pro EX Device/PLC Connection Manual 70

5B)

5C)

Terminal
resistance

120Ω (1/2W)

Display

Signal name

2

7

1

3

5

4

8

9

6

RDB

SDB

RDA

SDA

SG

ERA

CSA

ERB

CSB

Pin

Display side
D-Sub 9pin (socket)

External Device side
Terminal block

Shell

Shield

-

Signal name

+

SG

TX

RX

Terminal
resistance
120Ω (1/2W)

User-created cable

Signal name

RDB

RDA

SDA
SG
FG

CA4-ADPONL-01

CA3-ADPTRM-01

Display

Display side
Terminal block

Shield
External Device side

Terminal block
TERM

SDB

Signal name
-

+

SG
TX

RX

User-created cable

Terminal
resistance
120Ω (1/2W)
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5D)

5E)

Display

Signal name

1

7

8

2

3

5

TERMRX

RDB

SDB

RDA

SDA

SG

Pin

Display side
D-Sub 9pin (plug)

External Device side
Terminal block

Shell

Shield

-

Signal name

+

SG

TX

RX

Terminal
resistance
120Ω (1/2W)

User-created cable

CA4-ADPONL-01

Signal name

RDB

RDA

SDA
SG
FG

CA3-ADPCOM-01

CA3-ADPTRM-01

Display

Display side
Terminal block

Shield
External Device side

Terminal block
TERM

SDB

Signal name
-

+

SG
TX

RX

User-created cable

Terminal
resistance
120Ω (1/2W)
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5F)

5G)

*1 The resistance in the Display is used as the termination resistance. Set the value of the DIP Switch on the 
rear of the Display as shown in the table below.  

DIP Switch No. Set Value

1 OFF

2 OFF

3 ON

4 ON

Terminal
resistance

120Ω (1/2W)

Display

Signal name

2

1

3

7

5

4

8

9

6

DATA-

DATA+

NC

NC

SG

ERA

CSA

ERB

CSB

Pin

Display side
D-Sub 9pin (socket)

External Device side
Terminal block

Shell

Shield

-

Signal name

+

SG

TX

RX

Terminal
resistance
120Ω (1/2W)

User-created cable

Signal name

RDA

SDA

SG
ERA
CSA

ERB
CSB

Display

Display side
Terminal block

Shield

External Device side
Terminal block

RDB

SDB

Signal name
-

+

SG
TX

RX

User-created cable

Terminal
resistance
120Ω (1/2W)

Terminal
resistance *1
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5H)

5I)

Terminal
resistance

120Ω (1/2W)

Display

Signal name

8

3

1

2

5

4

6

7

9

LINE-

LINE+

NC

NC

SG

RS(RTS)

SV

NC

NC

Pin

Display side
D-Sub 9pin (plug)

External Device side
Terminal block

Shell

Shield

-

Signal name

+

SG

TX

RX

Terminal
resistance
120Ω (1/2W)

User-created cable

Signal name

RDB

RDA

SDA
SG
FG

PFXZCBADTM1

Display

Display side
Terminal block

Shield
External Device side

Terminal block
TERM

SDB

Signal name
-

+

SG
TX

RX

User-created cable

Terminal
resistance
120Ω (1/2W)
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5J)

5K)

Number Name Notes

(1)
RJ45 RS-485 Cable (5m) by Pro-face

PFXZLMCBRJR81

External Device side
Terminal block

-

Signal name

+

SG

TX

RX

Terminal
resistance
120Ω (1/2W)

Display

D1

D0

(1)

Terminal
resistance

120Ω (1/2W)

Display

Signal name

1

2

3

7

5

4

8

9

6

DATA-

DATA+

NC

NC

GND

NC

NC

NC

NC

Pin

Display side
D-Sub 9pin (socket)

External Device side
Terminal block

Shell

Shield

-

Signal name

+

SG

TX

RX

Terminal
resistance
120Ω (1/2W)

User-created cable
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6 Supported Device

Range of supported device address is shown in the table below.

6.1 XGK / XGB

 This address can be specified as system data area.         

Device Bit Address Word Address 32bits Notes

Input / Output Relay P00000 - P2047F P0000 - P2047

Auxiliary Relay M00000 - M2047F M0000 - M2047

Keep Relay K00000 - K4095F K0000 - K4095

Link Relay L000000 - L11263F L00000 - L11263

Special Relay F00000 - F2047F F0000 - F2047 *1

*1 Write disable

Timer (Contact) T0000 - T2047 -

Counter (Contact) C0000 - C2047 -

Timer (Current Value) - T0000 - T2047

Counter (Current Value) - C0000 - C2047

Data Register - D00000 - D32767

Special Module Register - U00.00 - U7F.31  *2

*2 The feature of U device is as follows.

Communication Data Register - N00000 - N21503

File Register - R00000 - R32767  

File Register - ZR00000 - ZR65535  *3

*3 Not supported on XGB series.

• Please note that the actually supported range of the devices varies depending on the External 

Device to be used. Please check the actual range in the manual of your External Device.

• External Device has S and Z Device. But, XGT Cnet Protocol does not support it.

• Please refer to the GP-Pro EX Reference Manual for system data area.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"
• Please refer to the precautions on manual notation for icons in the table.

"Manual Symbols and Terminology"

U 7 F . 3 1 . F
Bit Address (h0 to hF)
Special Module Inner Word Number: word number per slot (00 to 31)
Slot Number (h0 to hF)
Base Number (0 to 7)
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6.2 XGI

 This address can be specified as system data area.         

Device Bit Address Word Address 32bits Notes

Input Points %IX000.00.00 - %IX127.15.63 %IW000.00.0 - %IW127.15.3 *1

*1 The feature of device is as follows.

Output Points %QX000.00.00 - %QX127.15.63 %QW000.00.0 - %QW127.15.3 *1

Direct Variable

%MX0000000 - %MX4194303 %MW000000 - %MW262143 *2

*2 It is a continuous address number.

%RX000000 - %RX524287 %RW000000 - %RW32767 *2

%WX0000000 - %WX8388607 %WW000000 - %WW524287 *2

Analog refresh Flag %UX0.00.000 - %UX7.15.511 %UW0.00.00 - %UW7.15.31 *3

*3 The feature of %UX device and %UW device are as follows.

• Please note that the actually supported range of the devices varies depending on the External 

Device to be used. Please check the actual range in the manual of your External Device.

• Please refer to the GP-Pro EX Reference Manual for system data area.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"
• Please refer to the precautions on manual notation for icons in the table.

"Manual Symbols and Terminology"

%IX000 . 00 . 00
Module Contact Number (0 to 63)
Slot Number  (0 to 15)
Base Number (0 to 127)

%QW000 . 00 . 0
Module Word Number (0 to 3)
Slot Number  (0 to 15)
Base Number (0 to 127)

%UX0 . 00 . 000
Channel Contact Number (0 to 511)
Slot Number  (0 to 15)
Base Number (0 to 7)

%UW0 . 00 . 00
Channel Word Number (0 to 31)
Slot Number  (0 to 15)
Base Number (0 to 7)
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7 Device Code and Address Code

Use device code and address code when you select "Device Type & Address" for the address type in data 

displays.

7.1 XGK / XGB

Device
Device 

Name

Device Code 

(HEX)
Address Code

Input / Output Relay P 0080 Word Address

Auxiliary Relay M 0082 Word Address

Keep Relay K 0083 Word Address

Link Relay L 0084 Word Address

Special Relay F 0085 Word Address

Timer (Current Value) T 0060 Word Address

Counter (Current Value) C 0061 Word Address

Data Register D 0000 Word Address

Special Module Register U 0002 Word Address*1

*1 Internally "Address Indirect specification" is supported in case of U device.
When it is Uxx.dd, the converted formula is like this:
Hex type: ["xx" part]  h20 + [the hexadecimal value of "dd" part]
Dec type: [the decimal value of "xx" part]  32 + ["dd" part]
(Here, "xx" is also a hexadecimal type, "dd" is also a decimal type.)

For example, "01.00" is converted into "0x20 (=32)", "10.00" is converted into "0x200 (=512)", 
"7F.00" is converted into "0xFE0 (=4064)" and so on.

Communication Data Register N 0064 Word Address

File Register R 0001 Word Address

File Register ZR 0003 Word Address
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7.2 XGI

Device
Device 

Name

Device Code 

(HEX)
Address Code

Input Points
%IX

0080
Word Address

%IW Word Address*1

*1 If the Word Address be specified indirectly, please calculate the following formula.
Word Address = [Base Number x 64] + [Slot Number x 4] + [Module Word Number]

Output Points
%QX

0081
Word Address

%QW Word Address*1

Direct Variable

%MX
0000

Word Address

%MW Word Address

%RX
0002

Word Address

%RW Word Address

%WX
0003

Word Address

%WW Word Address

Analog refresh Flag
%UX

0082
Word Address

%UW Word Address*2

*2 If the Word Address be specified indirectly, please calculate the following formula.
Word Address = [Base Number x 512] + [Slot Number x 32] + [Channel Word Number]
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8 Error Messages

Error messages are displayed on the screen of Display as follows: "No. : Device Name: Error Message (Error 

Occurrence Area)". Each description is shown below.

Display Examples of Error Messages

"RHAA035:PLC1: Error has been responded for device write command (Error Code: 2 [02H])"

Item Description

No. Error No.

Device Name
Name of External Device where error occurs. Device name is a title of External Device set 
with GP-Pro EX. (Initial value [PLC1])

Error Message Displays messages related to the error which occurs.

Error Occurrence Area

Displays IP address or device address of External Device where error occurs, or error codes 
received from External Device.

• IP address is displayed such as "IP address (Decimal): MAC address (Hex)".
• Device address is displayed such as "Address: Device address".
• Received error codes are displayed such as "Decimal [Hex]".

• Refer to your External Device manual for details on received error codes.

• Refer to "Display-related errors" in "Maintenance/Troubleshooting Guide" for details on the 

error messages common to the driver.
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